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Introduction
Dolphin Power Tools Overview
Note: Screen captures/icons in this user’s guide may differ from what appears on your device.

Power Tools are used to create custom launch menus and to control your application environment.  Once you have created your 
custom environment, your users are presented with a window with just the applications you wish them to see.  Dolphin Power 
Tools are installed in every Dolphin terminal.  Different versions of Power Tools apply to different Dolphin terminals depending 
on the model or operating system.  

Software Requirements 

Dolphin Terminals

This version of Dolphin Power Tools is designed to work with Windows® Mobile 6.

Desktop
The Power Tools installer and the workstation version of EZConfig Editor are designed to work with the following operating 
systems:

• Microsoft® Windows® XP

• Microsoft® Windows® 2000

• Microsoft® Windows® NT

• Microsoft® Windows® Vista

• Microsoft® .NET Framework 2.0

• Microsoft® ActiveSync® (version 4.5 or higher)

Power Tools Main Window

Tap   > Power Tools and the Power Tools main window opens. 

Description Page

EZConfig Utilities
Opens a window that displays the EZConfig Editor and a 
series of exm files.

3-1

Network Utilities Opens a window that displays the Network utilities. 7-1

RegEdit
Allows you to edit the registry and import and export 
registry keys.

8-1

Suspend Suspends the terminal until the power button is touched.

BTPrint Allows you to print to a Bluetooth printer. 13-1

SysInfo
Displays system information including firmware versions, 
DLL  versions, system parameters, and network and 
radio information.  

11-1

Reboot Performs a reboot. 10-1

Exit Exits Power Tools.

ScanWedge or 
ScanManWedge

Allows you to send bar code data to your application. 9-1
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Additional Dolphin Power Tools
EZMenu is an additional Power Tool that does not appear in the main window.  EZMenu formats application windows to display 
and launch software programs on the terminal.  For further information, see EZMenu beginning on page 12-1.

Upgrading Power Tools
Upgrades for the Power Tools on the Dolphin come in the form of an executable file that installs the upgrade files onto the work-
station.  Upgrades are available from Customer Support (see page 14-1) or www.honeywellaidc.com.  Once the workstation 
installation is complete, transfer the appropriate upgrade files to the Dolphin terminal to upgrade the terminal's Power Tools.

Note: An active Microsoft ActiveSync or Windows Mobile Device Center connection between a host workstation and the Dolphin 
terminal is required to upgrade your Power Tools.
1 - 2
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EZConfig Utilities
Overview
EZConfig Utilities is made up of the EZConfig Editor and a series of exm files.  EZConfig Editor is the tool used to open and edit 
exm files.  The exm files are the building blocks for creating the Power Tools windows you see on your terminal.  Some exm files 
(AutoInstall, Autorun, and DeviceConfig) are used to display and run your applications.  The other exm files are used to build 
your own customized windows and applications for the Dolphin terminal.  

EZConfig Utilities Main Window  

Description Page

EZConfig Editor

Edits exm files for customized applications.  There 
are two versions of EZConfig Editor.  One that runs 
on the Dolphin terminal, and one that can run on 
your PC or workstation.

EZConfig Editor on the Dolphin Terminal 3-1

EZConfig Editor on the PC (Workstation) 4-1

AutoInstall.exm
Installs cab files in the AutoInstall folder, ensuring 
they persist through hard resets. 

5-4

Autorun.exm
Specifies the software applications to be launched 
after each hard reset.

5-1

DemosMenu.exm Specifies the menu for custom Honeywell demos.

DeviceConfig.exm Contains terminal configuration settings. 6-1

EZConfigMenu.exm
Specifies the menu for the Honeywell EZConfig Utilities 
window.  

Network Menu.exm
Specifies the menu for the Honeywell Network Utilities 
window.

Power Tools 
Menu.exm

Specifies the menu for the Honeywell Power Tools 
application.  

Scandemo.exm Specifies the menu for a custom Honeywell scanning demo.

ScanWedge.exm and 
ScanManWedge.exm

Sends data from the decoder or serial port to the 
foreground application as keystrokes.

9-1
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EZConfig Editor on the Dolphin Terminal
Overview
EZConfig Editor creates, edits, and manages EXM files for Dolphin terminals.  There are two versions of EZConfig Editor: one 
for the Dolphin terminal and one for the workstation.  In the workstation editor, EXM files are edited, saved, then transferred to 
the Dolphin terminal.  In the terminal editor, EXM files are edited and saved right on the terminal

This chapter details EZConfig Editor running on a Dolphin terminal.  Refer to EZConfig Editor on the PC 
(Workstation) beginning on page 4-1 for information about using EZConfig Editor on a workstation.

File Types

EXM Files 
The EXM file format is an XML format customized for Dolphin terminals that is comprised of sections that sometimes con-
tain child sections and keys.  Keys contain the values that configure the terminal. 

The EXM file format supports a multi-level, hierarchical, tree structure.  The terminal reads the highest level section first and 
then reads the key values in each section.

EXM files replace INI files for Power Tools and terminal configuration settings.  If both an INI file and an EXM file are pres-
ent for the same application, the terminal defaults to the EXM file and a warning message appears at startup.  Remove the 
INI file from the terminal to avoid this warning message.

Types of Configuration Files
There are two types of configuration files in the EXM file format: 

Configuration Documents - Program and configure the terminal.

Registry Documents - Update and modify the registry.

Accessing EZConfig Editor

EZConfig Editor on the terminal edits and creates EXM files in the terminal and contains the same basic functionality as the edi-
tor on the workstation. 

Tap Start > Power Tools > EZConfig Utilities > EZConfig Editor.     

Opening EXM Files
• Tap directly on an EXM file to open it in EZConfig Editor.
• Tap the EZConfig Editor icon to open EZConfig Editor, then tap File > Open to open an EXM file.
• In File Explorer, navigate to an EXM file and tap once on the file to open it in EZConfig Editor. 
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Menus and Toolbar Options

File Menu

Edit Menu
For Section Edit menu options, see Editing Sections on page 3-3.  For Key Edit menu options, see Editing Keys on page 3-
4.

Menu Item Description

New 

Creates a new document. There are two options:
• Configuration Document - Creates a configuration file.  See 

Creating New Configuration Documents (page 4-12).
• Registry Document - Creates a registry file in the EXM file format.  See 

Registry Documents (page 4-13).

Open Opens an EXM file.

Save 
Saves the open file to the location you select on the terminal.
This option is disabled for new and imported files; use Save As instead. 

Save As Saves the open file with a new name to the location you select on the terminal.

Properties 
Associates the EXM file with an application on the terminal.  See Associating 
Applications on page 4-12.

Exit Closes EZConfig Editor.

Descriptions and values for each key 
are displayed.

Sections appear in the top half of 
the window.

Keys appear in the bottom half of the 
window. 
Enabled keys have a checkmark.
Disabled keys have a blank box.

Disabled sections appear in gray.
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View Menu

Tools Menu

Editing Sections

Modifying Text
There are several options to edit a section name or description: 

1. Select the section and tap Edit > Modify.
Or:  Select an item and press the ENTER key.
Or:  Tap and hold on the section name, then select Modify on the Edit menu that pops up. 

2. All three options open the Edit Section window. 

3. Tap inside the Name or description fields and edit the text.

4. Tap OK to save changes. (You can also press the ENTER key.)  Tap Cancel to close the window without changes.

Menu Item Description

Show Locks 

Shows or hides the icons indicating if a subsection or key is locked.  

For additional information on locks on subsections and keys, see Status Bar on page 4-5.

Menu Item Description

Launch Associated 
App

If the open EXM file is associated with an application on the terminal, this item is active and 
launches the associated application.

Simplify Document
Note: You cannot 

undo this 
action!

Simplifies the EXM file, which makes it smaller. Simplifying permanently removes 
• Disabled sections and keys 
• Descriptions

Warm Boot Reboots the terminal.

The lock icon means the section’s 
subsections are locked.The key icon means that the 

section’s keys are locked.
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Moving Sections
You cannot drag and drop to move sections in the tree. Use the Cut, Copy, Paste, and Paste as Child items on the Edit 
menu to move sections.

Note: The Paste function pastes sections at the same level they were cut by default.

Editing Keys

Modifying Text
There are severl options to edit a key’s name, value, or description:

1. Select the key and tap Edit > Modify,
Select the key and press the ENTER key, OR
Tap and hold on the key’s name, then select Modify on the Edit menu that pops up. 

All three edit options open the Edit Key window. 

2. Tap inside the Name, Value or Description fields and edit the text.

3. Tap OK to save changes. (You can also press the ENTER key.)  Tap Cancel to close the window without changes.

Moving Keys
You cannot drag and drop to move keys. Use the Cut, Copy, and Paste as Child items on the Edit menu to move keys.

Launching Associated Applications
The Tools menu contains an item named Launch Associated App.  Launch Associated App is enabled only when there is an 
application associated with the EXM file.  Selecting this item automatically saves the open EXM file and launches the associated 
application while the EXM file remains open.

To see the associated application, tap File > Properties. 

The Path field contains the launch location of the application.
The Args field contains any command line arguments to execute when the application launches. 
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While the EXM file is open, click File > Properties or the Document Properties toolbar button . 

Example: You’ve saved changes to an open DeviceConfig.exm file. 

To apply those changes immediately, tap Tools > Launch Associated App.  Because the DeviceConfig.exm file is associated 
with DeviceConfig.exe by default, DeviceConfig launches and applies the settings in the DeviceConfig.exm file.

Example: You’ve saved changes to an open ScanWedge.exm file.  The ScanWedge.exm file has the following parameters as 
the associated application:

Path: \program files\power tools\scanwedge.exe

Args: /restart

Tapping Tools > Launch Associated App refreshes ScanWedge with the new settings.

Command Line Arguments
/%filename Executes the EXM file; this is the default entry.

/q Quiet mode

/s Full screen

Field Description

Path Enter the location of the EXE on the terminal.

Arguments

Enter the command line argument you want applied when the application launches.
When an application is entered in the Path field, the following command line appears as the 
argument: /exm %filename.

Enter additional command line arguments (see Command Line Arguments on page 3-5) next to /
exm %filename in this field.

Execute

Launches the application. Execute selects automatically when an application is entered in the Path 
field. 

You cannot de-select Execute for configuration documents. 

You can de-select Execute for registry documents; however, EZConfig Client cannot update the 
registry unless Execute is selected. For more information, see Launch Associated Application 
(page 4-14).

Wait Until Finished
This indicates that the EXM should wait until the associated application has exited before 
continuing.
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/o No menu

/e Exit if first scan fails to deliver a valid bar code

/u Accept (decode) unsecure bar codes
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EZConfig Editor on the PC (Workstation)
Overview
EZConfig Editor creates, edits, and manages EXM files for Dolphin terminals.  There are two versions of EZConfig Editor: one 
for the Dolphin terminal and one for the workstation.  In the workstation editor, EXM files are edited, saved, then transferred to 
the terminal.  In the terminal editor, EXM files are edited and saved right on the terminal

This chapter details EZConfig Editor running on a PC or workstation.  Refer to EZConfig Editor on the Dolphin 
Terminal beginning on page 3-1 for information about using EZConfig Editor on a Dolphin terminal.

Installing EZConfig on the Workstation
Go to www.honeywellaidc.com to download and install Honeywell EZConfig Editor Setup.exe on the workstation.

Upgrades
Upgrades for EZConfig Editor on the workstation are available from Customer Support (see page 14-1) or 
www.honeywellaidc.com.

File Types

EXM Files 
The EXM file format is an XML format customized for Dolphin terminals that is comprised of sections that sometimes con-
tain child sections and keys.  Keys contain the values that configure the terminal. 

The EXM file format supports a multi-level, hierarchical, tree structure.  The terminal reads the highest level section first and 
then reads the key values in each section.

EXM files replace INI files for Power Tools and terminal configuration settings.  If both an INI file and an EXM file are pres-
ent for the same application, the terminal defaults to the EXM file and a warning message appears at startup.  Remove the 
INI file from the terminal to avoid this warning message.

Types of Configuration Files
There are two types of configuration files in the EXM file format: 

Configuration Documents - Program and configure the terminal.

Registry Documents - Update and modify the registry.

Accessing EZConfig Editor
After you complete installation, EZConfig Editor is available on the workstation from the Start menu. 
4 - 1
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Click Start > Programs > Honeywell > EZConfig for Mobility > EZConfig for Mobility.  The following screen appears:
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Menus and Toolbar Options

File Menu

Edit Menu
For Section Edit menu options, see Working with Sections on page 4-6.  For Key Edit menu options, see Working with Keys 
on page 4-9.

Menu Item Description

New 

Creates a new document. There are two options:
• Configuration Document - Creates a configuration file.  See 

Creating New Configuration Documents (page 4-12).
• Registry Document - Creates a registry file in the EXM file format.  See 

Registry Documents (page 4-13).

Open Opens an EXM file located on the workstation.

Open from Device

Opens an EXM file located on the terminal.  The location of the file appears in the 
title bar with the word “[Remote]” to identify that the open file is located on the 
terminal. 
Note: Requires an ActiveSync connection between the workstation and the 

terminal.

Save 
Saves the open file to the location you select on the workstation.
This option is disabled for new and imported files; use Save As instead. 

Save As Saves the open file with a new name to the location you select on the workstation.

Properties 
Associates the EXM file with an application on the terminal.  See Associating 
Applications on page 4-12.

Exit Closes EZConfig Editor.
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View Menu

Tools Menu

Opening EXM Files
EZConfig Editor opens EXM files stored on the workstation or the Dolphin terminal (if an ActiveSync connection is established). 

Opening EXM Files on the Workstation

Click File > Open or the Open toolbar button  and select the EXM file.

Opening Remote EXM Files
EZConfig Editor can open EXM files located on the terminal so that you can make edits to the Dolphin terminal’s configura-
tion using your PC. 

Menu Item Description

Show Locks 

Shows or hides the icons indicating if a subsection or key is locked.  

For additional information on locks on subsections and keys, see Status Bar on page 4-5.

Menu Item Description

Simplify Document
Note: You cannot 

undo this 
action!

Simplifies the EXM file, which makes it smaller. Simplifying permanently removes
 
• Disabled sections and keys 
• Descriptions

Because the following menu items execute commands on the terminal, there must be an ActiveSync connection 
between the workstation and the terminal. 

Launch Associated 
App

If the open EXM file is associated with an application on the terminal, this item is active and 
launches the associated application on the terminal.
Note: You would use this option after saving the EXM file to the terminal; see Saving to the 

Device on page 4-11.

*Cold Boot Factory reset.  Not supported.

*Warm Boot Reboots the terminal.

* Some settings affect the boot process and these menu items can help you run a test without switching to the terminal.

The lock icon means the section’s 
subsections are locked.The key icon means that the 

section’s keys are locked.
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When the terminal and workstation are connected by ActiveSync, click File > Open From Device and the remote open 
window opens. 

To open a file, select it and click OK. 

Note: You can also open EXM files in the editor on the terminal.  See EZConfig Editor on the Dolphin Terminal beginning 
on page 3-1.

Working with Open EXM Files
Whether you open an EXM file, EZConfig Editor displays the content in four different sections of the window. 

Status Bar
The Status Bar appears at the bottom of the window and displays information about selected sections and keys.

Selected Section

See Section Locks on page 4-8.

Displays the root node 
and sections. 

Select a section and the 
details appear in the 
other portions of the 
window.

The folders appear in 
different colors to 
indicate their status.

Displays the section 
name and description. 

Displays the keys in the 
selected section.

Text that appears in blue 
can be edited.

Displays the selected 
key’s name and 
description.

Displays the file name.

If the file is on the 
terminal, the title bar 
displays the remote 
path.

Status Bar

Section Name Merge Mode Locks on subsections and keys
4 - 5



Selected Key

See Key Types on page 4-11.

Working with Sections
The EXM file format supports a multi-level tree structure. The section tree appears in the top left quadrant of the window. 
The root node identifies the EXM file and “Root” appears in the description.

Sections have a Name and Description and contain keys that appear in the upper right quadrant when you select the sec-
tion name. Select a section by clicking on it. You can select only one section at a time.

Edit Menu Options
Select a section and click Edit to see the available options.

Menu Item Description

Modify

Allows you to rename or modify the section name, value, and its description.  You can also 
double click on the description to bring up the Modify screen.
Note: You cannot modify the name if the section is locked or disabled; see Section Locks 

(page 4-8).

Cut Cuts a selected section.

Copy Copies a selected section.

Paste Pastes the section that was just cut or copied at the same level as the selected section.

Paste as Child
Pastes the section that was just cut or copied as a child of the selected section.
Note: You can cut, copy and paste sections within an EXM file or across EXM files.

Delete
Deletes a selected section. 
Note: Because you cannot undo a delete, consider disabling rather than deleting.

Enable

Sections are enabled by default. This menu item enables sections that were previously 
disabled. You can enable a section only if its parent section is enabled.

To enable all the keys inside a section you are enabling, SHIFT + right-click and select 
Enable All.

Key Name Enabled or 
Disabled

Read Only Encrypted Key locked by 
section 
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Moving Sections
To move sections within an EXM file, use the drag and drop method.  By default, sections are dropped at the same 
level in the tree. 

For additional functionality when dragging and dropping, hold: 

• ALT to drop a section as a child section. 
• CTRL to copy a section and drop the copy at the same level in the tree. 
• CTRL + ALT to copy a section and drop the copy as a child section.

Note: You can select only one section at a time; you cannot use SHIFT+Click or CTRL+Click to select more than one 
section.

To move sections between EXM files, open two instances of EZConfig Editor and drag and drop sections between 
them. When dragging, a copy of the section is dragged to the new file.  When dropping, drop the section directly on top 
of the section where you want the child section to appear.

Note: To drop the first section into a new file, press and hold the ALT key and drop the section on the root node. (All 
sections must be child sections of the root node.)

Disable All

Sections are enabled by default. This menu item disables a selection section and all of its 
keys.  Disabled sections remain in the file with a gray folder .

If you disable a section that has child sections, all of its child sections (and the child section 
keys) are disabled automatically. The child section folders are also in gray.

When reading the EXM file, the terminal behaves as though disabled sections are not there 
and moves on to read the next enabled section.

Disabled sections can be removed from the EXM file permanently using the Simplify 
Document (see page 4-4) option. If you want to keep disabled sections in the EXM file on the 
workstation but not in the file deployed to the terminal, use the Simplified option (see page 4-
4).

Insert Section This menu item inserts a new section. 

Append Child 
Section

This menu item adds a new child section to a selected section. The new child section is 
inserted below the previous section.

Menu Item Description
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Section Locks
There are different types of locks on sections. The status bar indicates what type of lock is applied to a selected sec-
tion.

Note: All locks are applied to each individual section and are not recursive. Only text that appears in blue can be 
modified.

Section-Level Merge Modes
EXM files ship with section-level merge modes already defined according to section content. Merge modes determine 
how section information is handled when an updated EXM file is deployed to the terminal where an existing version of 
that EXM file is stored.

Merge modes are indicated by folder icons and in the Status bar.

Lock Type
Status Bar 
Indicator

Description Effect

Name Lock
The section name is 
locked.

Section Name and Description cannot be 
modified. 

Key Lock
All keys are locked. Key Names and Descriptions cannot be 

modified.  Keys cannot be added, moved, or 
deleted within the section. 

Subsection 
Lock

All immediate subsections 
are locked.

Immediate subsection Names and 
Descriptions cannot be modified.  Immediate 
subsections cannot be added, moved, or 
deleted.

Mode Description
Merge 
Effect

Delete + Add

Deletes non-common children elements (i.e., subsections, and keys) in the 
target file, then adds the new information from the exm file.  Basically, the 
new section replaces the old section.
This is the default merge mode for new sections. 

Exclusive

Disable + Add
Disables non-common children elements (i.e., subsections, and keys) in the 
target file, then adds the new information from the bar code. 
Note: Disabled sections and keys end up as disabled in the target file.

Add Only
Adds new information (sections and keys) to the existing section. If this is a 
brand new section, the new section is added to the existing EXM file.
Note: Disabled sections are not modified in the target file.

Inclusive
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To change section-level merge modes, select a section and right click.

The folder colors change immediately after selection.

Working with Keys
Keys have a Name, a Description, and a Value and reside inside sections. For specific key values, consult the chapters of 
this User’s Guide that describe the EXM file you’re editing. 

Edit Menu Options
Select a key and right-click or click Edit to see the available options.

Menu Item Description

Rename
Activates the key name so that you can rename the key. Rename is disabled if the key is 
locked or disabled; see Key Types (page 4-11). 

Cut Cuts a selected key.

Copy Copies a selected key.

Paste Disabled; keys can be pasted only as children of a section.

The same options 
appear on both 
menus.
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Modifying Key Names
To modify key names, double-click on the key name or select Rename on the Edit menu.  Type in the new name and 
press ENTER or TAB.

Note: You cannot modify the description if the key is locked, see Key Types (page 4-11).  Only text that appears in blue 
can be modified.

Modifying Key Values
You can modify a key value only if its text appears in blue.  In that case, double-click on the value or select the key and 
press ENTER.  Type in the new value and press ENTER or TAB to save.

Modifying Key Descriptions
Descriptions are not required to process key values but do help document the EXM file and often contain valuable 
information. To modify a key’s description, click on the key, then click in the key description area. When the cursor is 
active, you can type in the text. 

Note: You cannot modify the description if the key is locked; see Key Types (page 4-11).

Moving Keys
To move keys within an EXM file, use the drag and drop method. Press and hold the CTRL key to drag and drop a copy 
of the key to the new location.

Note: You cannot move a key if it is locked by its section.

Paste as Child
Pastes the key just cut or copied in the selected section. Keys are not multi-level; all keys 
paste at the same level within a section.
You can cut, copy and paste keys within an EXM file or across EXM files. 

Delete
Deletes a selected key. 
You cannot undo a delete; you might want to consider disabling rather than deleting.

Enable

Enables keys that were disabled.  When a key is enabled, the client application can read 
and apply its value.  When you enable a key, make sure to specify a value for that key; do 
not leave it blank.

To enable a key, its parent section must be enabled.

Disable

Disables keys. 
Disabled keys have key values in black.  Enabled keys have key values in blue.

The terminal does not read disabled keys and disabled keys are removed if the file is 
simplified.  See Simplify Document on page 4-4. 

Because many key values are 1 for enable and 0 for disable, remember that disabling a key 
means that the terminal behaves as if the key is not there when reading the file, NOT that 
the key’s value is set to disabled.  The terminal simply moves on to read the next enabled 
key. 

Insert New Key
This menu item inserts a new key above the selected key.
Note: You can also press the Insert key (INS).

Menu Item Description
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To move keys between EXM files, open two instances of EZConfig Editor and drag and drop keys between them. 
When you select the key and drag, a copy of the key is dragged to the new file. In the new file, drop the key in the key 
area of a selected section; keys are always dropped at the same level within a section.

Key Types
When a key is selected, its properties display in the Status bar.

Note: Locked and Read Only properties are not recursive. Properties are applied to each individual key. Only text that 
appears in blue can be modified.

Saving to the Device
You can save EXM files directly to the terminal when there is an ActiveSync connection between the terminal and the work-
station.  Select File > Save to the Device As and the Save Remote File window opens. 

Select the location on the terminal where you want to store the file and click OK.  The file is downloaded directly to the ter-
minal via ActiveSync. 

Lock Type
Status Bar 
Indicator

Description Effect

Name Lock

Keys are locked by the section. • Name and Description cannot be 
modified. 

• Keys cannot be added, moved, or 
deleted within the section.

The key name is locked 
individually.

• Name and Description cannot be 
modified. 

• These keys can be moved.

Read Only

Read-only keys cannot be 
modified in any way. They 
appear in red.

• Name, Description, and Value cannot 
be modified.

• Keys cannot be added, moved, or 
deleted within the section.

Encrypted

Key’s value appears as asterisks 
(*) for added security. 

Note: Encrypted keys are also stored 
encrypted in the EXM file. If you 
open the EXM file in a text editor, 
you won't see the data as clear 
text.
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Creating New Configuration Documents
To create new EXM files that are configuration documents, you can open an existing EXM file and save it with a new name or 
create an EXM file from scratch.

1. Click File > New > Configuration Document. The root node is created and appears as the top level section. All sections 
must be at least one level down from the root node. The name of the root node is always the same as the filename. 

Note: You can also create registry documents in the EXM file format.  For details, see Registry Documents on page 4-13.

2. To create the first subsection, select the root node, right-click, and select Append Child Section. 
Insert Section is disabled because you cannot insert sections at the same level as the root node.

3. Enter a Name and a Description and click OK.
The name is required, the description is optional.

4. To add a new section at the same level, right-click and select Insert Section.
To add a new section one level down, right-click and select Append Child Section.

5. To add keys, select a section, right-click in the key value section, and select Append Key. 

6. Enter the Name, Value, and Description and click OK.
The name is required, the description is optional.

7. Continue adding sections and keys.

8. If necessary, associate this EXM file with an application; see Associating Applications (page 4-12).

9. Click File > Save As to save the file. 
Save is disabled so that you save the document with a name other than “NewDocument.exm.”

Associating Applications
The Properties function associates an EXM file with an application on the terminal.  (To launch the associated application, tap 
on Tools > Launch Associated App on the terminal.) 

The terminal reads 
root node first.

The Description 
says “Root” to 
indicate that this is 
the root section. 
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While the EXM file is open, click File > Properties or the Document Properties toolbar button . 

Registry Documents
EZConfig Editor creates registry documents in the EXM file format and also opens existing REG files and converts them to the 
EXM file format. EZConfig Editor cannot save registry documents in the REG file format. 

Field Description

Path Enter the location of the EXE on the terminal.

Arguments

Enter the command line argument you want applied when the application launches.
When an application is entered in the Path field, the following command line appears as the 
argument: /exm %filename.

Enter additional command line arguments next to /exm %filename in this field.

“%filename” means that the value immediately after the “%” is variable.  Type in the location and 
file name where the EXM file should be deployed on the terminal.  For example, 
\Honeywell\deviceconfig.exm.

Command Line Arguments

/%filename Executes the EXM file; this is the default entry.
/q Quiet mode
/s Full screen
/o No menu
/e Exit if first scan fails to deliver a valid bar code
/u Accept (decode) unsecure bar codes

Execute

Launches the application.  Execute selects automatically when an application is entered in the Path 
field. 

You cannot de-select Execute for configuration documents. 

You can de-select Execute for registry documents, however, the registry is not updated unless 
Execute is selected. For more information, see Launch Associated Application (page 4-14).

Wait Until Finished Waist until the associated application is finished processing before finalizing.
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Updating the Registry on the Terminal
To update the terminal’s registry, you must 

• Create an EXM file that is a registry document – see Creating Registry Documents, below.
• Save the registry document to the terminal
• Tap on Tools > Launch Associated App to update the registry.

Launch Associated Application
While a registry document is open, click File > Properties.

Execute must remain selected for the registry to be updated.  If Execute is not selected, the registry document is 
deployed, but the registry is not updated.

Creating Registry Documents
1. In EZConfig Editor, click File > New > Registry Document.

The new document contains the three top-level sections in a registry. These sections are locked and cannot be 
changed. You can add subsections to each section and then add keys to those subsections.

2. Click File > Save As. 

3. Choose the name and location and click Save. 
You cannot save the document as a .reg file; you must save it as an EXM file. 

4. To add sections, select one of the registry levels, right-click, and select Append Child Section. 
Enter the section information, and click OK.

For more information about adding sections, see Working with Sections on page 4-6.
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5. To add keys to the new section, select the section, and right-click in the key value area.
For details, see Adding Registry Keys on page 4-15.

6. Continue adding sections and keys.

7. Save the file.

Adding Registry Keys
To add a key, select a section, and right-click in the key area of the EZConfig Editor window. 

When you click OK to save the key, the data appears in columns in the key area of the EZConfig Editor window.

Create EZConfig Bar Code
This feature is not supported by the Dolphin 6000 Scanphone.

Field Description

Name Enter the key’s name.

Registry Value Type Select the registry type from the drop down list. This value appears in the Type column.

Value Enter the key’s value.

Desc
Enter a description for the key; descriptions appear in the lower half of the EZConfig Editor 
window when the key is selected.
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Autorun and AutoInstall
Overview
Startup is the launch sequence when a Dolphin terminal is booted. There are two startup Power Tools: Autorun and AutoInstall.

Autorun
Autorun specifies the software applications to launch after each hard reset.  Autorun is located in the \Honeywell folder.  Auto-
run consists of an Autorun.exe that is programmed by the Autorun.exm file (see below).   

During startup, after a soft or hard reset, the operating system looks for and launches \Autorun.exe. If the Autorun.exe is config-
ured (by Autorun.exm) to launch an application, that application launches when Autorun.exe launches.  Autorun can launch up 
to 32 applications or utility programs after each hard reset.

Note: The Autorun.exm file allows applications to be launched based on conditional situations, including the return code of 
another application launched previously and specific characteristics of the Dolphin terminal itself.

Autorun.exm File
The Autorun.exm file has a multi-level tree structure. There are two top level sections: Settings and Programs.

Settings Section
The Settings section stores general Autorun settings.  Double tap or click on any Key to get full information or to edit 
the settings. 

Programs Section
The Programs section contains many child sections and determines the sequence of events at startup, including which 
programs launch and when. 

Program Sections and Launch Sequence
Each section is a program to launch at startup. The sequence of sections determines the launch sequence on the terminal; 
the terminal reads this file consecutively. To change the launch sequence, move the section up or down in the list.  See 
Working with Sections (page 4-6).

Enabling and Disabling Sections
If you don’t want to the application to launch at startup, you can delete the section. However, program sections contain set-
tings you’ll want to keep when adding that same application back to startup.  To keep the program section in the file for 
future reference, disable the program section instead of deleting it.  Disabled sections appear in gray.

When processing files, the terminal behaves as though disabled sections are not there and moves on to the next enabled 
section.

Programs’ Subsections
Each Programs’ subsection contains or can contain the following keys: 

Key Function

Required Keys—These keys must be present in each Program subsection.

Program
Specifies the command line to execute. This is the location of the program’s executable. If 
you want a Power Tool to launch at startup, enter the location of that tool’s EXE here.

Args Specifies the command line arguments to execute at startup.
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Editing the Autorun.exm File
Edit Autorun.exm in EZConfig Editor. For details, see Working with Open EXM Files on page 4-5.

Adding a Program Subsection 
To launch at startup, a new program must be a child section of the Programs section.

1. In EZConfig Editor, right click on the Programs section and select Append Child Section.

2. On the Add New Section window, enter the Name and Description and click OK.

3. The new section is added to the bottom of the list.

4. Use the click and drag method to move the section to the desired launch sequence. 
Press and hold the ALT key to make sure that you move the section at the same level. Do not append the section to an 
existing section!

5. Right-click in the key area and select Append Key. You must add all the required Autorun keys; see Programs’ 
Subsections on page 5-1.

6. Save the file and transport it to the terminal.

Copying a File
If you want to copy a file and move it to another location, use AutoInstall and the /copy command line argument. For 
details, see Command Line Arguments on page 5-4.

Start Options
Start Options define the required system parameters for a software application to launch. The following values can be 
entered for the StartOption key, wherever it appears:

Wait

Determines if Autorun should wait for the program to complete and close before continuing to 
the next program in the sequence. 
• 0=Continue to the next program immediately
• 1=Wait enabled 

StartOption

Specifies the startup options for the program. Autorun launches the program only if the 
startup options entered here are met.
• Blank= Always run the program.
• X=See "Start Options" on page 5-2

Optional Keys—These are keys you can add.

PNPID
Specifies a card description. This option needs to be entered only when PNPID or 
NONPNPID values are specified in the StartOption key.

DependIndex Specifies the index of a dependent program.

DependExitCode
Specifies the required result of the dependent program. If the result of the dependent 
program does not equal the DependExitCode entered here, the current program will not be 
executed at startup.

Option Name The program launches if … Category

DISABLED Never, regardless of other startup options specified. None

Key Function
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COLDBOOT The terminal has performed a factory reset.

Boot type
WARMBOOT The terminal has performed a reboot.

TOUCH The terminal has a touch screen display installed.

Touch Screen
NONTOUCH The terminal doesn’t have a touch screen display installed.

BATCH The terminal is a batch unit (no RF or internal modem cards installed).

Mobility

RF The terminal has an RF card installed (e.g., Cisco 802.11b).

GSM The terminal has a GSM radio.

BT The terminal has a Bluetooth radio.

MODEM The terminal has an internal modem card installed.

IMAGER The terminal has an imager installed.

Scanner
LASER The terminal has a laser scanner installed.

BLIND The terminal has no laser or imager installed.

ANYSCAN The terminal has either an imager or a laser scanner installed.

RFON The RF radio is Enabled.

Radio
GSMON The GSM radio is enabled.

BTON The Bluetooth radio is enabled.

RFGSMBTOFF The RF, GSM, & Bluetooth radios are disabled.

29KEY The terminal has a 29-key keyboard.

Keyboard

35KEY The terminal has a 35-key keyboard.

38KEY The terminal has a 38-key keyboard.

43KEY The terminal has a 43-key keyboard.

56KEY The terminal has a 56-key keyboard.

NO_KEY The terminal has a 56-key keyboard.

99XX A Dolphin terminal beginning with 99. Model

Option Name The program launches if … Category
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Multiple options can be specified for each category. For example, you can specify both 35KEY and 43KEY options to 
request that the program run in either a 35- or 43-key keyboard terminal. Seperate multiple options with commas.

To ignore a category, don’t specify any of its options.

Applying Startup Options to the Autorun Configuration File
For each category, Autorun validates each startup option specified in the StartOption key. If no specified option is valid in a 
category, Autorun does not execute the program. If at least one of the specified options is valid in each category evaluated, 
the program is executed.

To always execute a program, specify no options in the StartOption key.

AutoInstall
AutoInstall consists of an AutoInstall.exe that, when launched, installs the cab files in the AutoInstall folder.  The AutoInstall 
folder is where you store cab files for software applications if you want them to persist through hard resets.  AutoInstall is located 
in the \Honeywell folder.  

The AutoInstall program runs according to the settings in the AutoInstall.exm file. 

Program Install Locations
When triggered by a reset, the CAB file installs the applications to the directories established in the CAB file.  For most 
applications, this means that an EXE for the software application is placed in the \Program Files folder.

AutoInstall.exm
The AutoInstall.exm file controls the behavior and appearance of the AutoInstall window and install process.  Double tap or 
click on any Key to get full information or to edit the settings.  

Note: The Autorun.exm file determines the programs and install sequence, not AutoInstall.exm.

Command Line Arguments
/copy Add /copy to the Autorun.exm file to automatically move a file from one location to another.

Usage:  autoinstall /copy <sourcefilename> <destination>

Example:  autoinstall /copy "/windows/data.mdf" "/storage card/data.mdf"

PNPID
The terminal has a card installed whose identification contains ALL of the 
strings specified in the PNPID setting.

Expansion Card

NONPNPID
The terminal doesn’t have a card installed whose identification contains 
ALL of the strings specified in the PNPID setting.

Option Name The program launches if … Category
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DeviceConfig
Overview
DeviceConfig configures the Dolphin terminal.  DeviceConfig consists of the DeviceConfig.exe and the DeviceConfig.exm file.  
DeviceConfig.exe looks for and applies the settings in the DeviceConfig.exm file.

DeviceConfig.exm File
The DeviceConfig.exm file contains terminal configuration settings. This file’s configuration settings persist through reboots and 
should be considered system defaults.  

Enabling DeviceConfig Functionality
By default, all sections except the About Section (see page 6-5) are disabled, which means that the key values are not 
applied to the terminal.  To use the DeviceConfig.exm file to configure the terminal, enable the sections and keys required 
by your configuration. 

Autorun 
Autorun (see page 5-1) launches DeviceConfig.exe, which applies the DeviceConfig.exm settings, then launches a reboot.  
The DeviceConfig.exm file must be associated with DeviceConfig.exe.  The associated application path must be

\Honeywell\deviceconfig.exe

For more information, see Associating Applications, page 4-12. 

Settings in the WLAN Supplicant
Many settings in the DeviceConfig.exm file match the settings in the WLAN Supplicant on the terminal that allow the user to 
enter and save the same values.  If you change a setting in the WLAN Supplicant, that setting is applied.  During the next 
reboot, Autorun launches DeviceConfig, which then re-applies the settings in the DeviceConfig.exm file.

DeviceConfig.exm Sections and Keys
The sections and keys in the DeviceConfig.exm file are locked, which means that you can change values but not names or 
descriptions.  

Connections Section
The Connections section contains child sections that set communication parameters on the terminal.

ActiveSync Section
The ActiveSync Section configures the terminal’s ActiveSync connection parameters.  Double tap or click on any Key 
to get full information or to edit the settings.

Note: The Connection values must be typed exactly as they appear in the Description field, e.g., ‘115200@Desktop.  

Radio Manager Section
In the Radio Manager, typically, you would enable the radio in the WiFi section, enable DHCP in the TCPIP section, 
then configure the radio settings in the Security\Supplicant\Profile section.

Section Name Description See Page

Connections
Configures communication parameters. There are child sections that 
configure the on-board radios and the ActiveSync connection.

6-1

System Configures basic system settings. 6-5

Applications Configures software applications. 6-5
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Bluetooth Section
The keys in this section enable the Bluetooth radio and configure a Bluetooth printer as a Favorite.  Double tap or 
click on any Key to get full information or to edit the settings.   If there is no Bluetooth radio installed in the terminal, 
disable this section.

Bluetooth Default Printer Values
In general, to establish a printer as a Bluetooth Favorite Device, you must establish the printer as a Bluetooth 
Favorite on the terminal.  The Default Printer section stores these settings permanently in the DeviceConfig.exm 
file so the printer remains a Favorite.

Furthermore, you can distribute a DeviceConfig.exm file with the printer settings to multiple terminals. After Devi-
ceConfig.exe applies the settings in the DeviceConfig.exm file (launched manually or after a reboot), the printer is 
set up as a Favorite automatically, without any special configuration to each terminal.

After you have established a printer as a Bluetooth Favorite Device on an individual terminal, obtain the value for 
the Address key from the registry in RegEdit.

Obtaining the MAC Address
After you have set up the Bluetooth printer on the terminal, use RegEdit to find the printer values.

1. Tap Start > Power Tools > RegEdit .

2. Navigate to HKEY_LOCAL_MACHINE > Software> Microsoft > Bluetooth > Device > [MAC Address].

3. Copy the name of the subsection; this is the MAC address of the printer.

4. Enter this address in the Address key in the Bluetooth > DefaultPrinter section of the DeviceConfig.exm 
file.

WiFi Section
The keys in the WiFi section control the settings of the WLAN radio.  Double tap or click on any Key to get full infor-

mation or to edit the settings. 

TCPIP Section
The keys in the TCPIP section determine how the radio handles IP addresses.  Double tap or click on any Key to 
get full information or to edit the settings. 

Security Section
The Security section has no keys and one child section named “Supplicant,” which contains several profile sub-
sections. 

Supplicant Section
The Supplicant section consists of a number of child sections. The default child section is named Profile1 and 
contains all the keys necessary to create a configuration profile for the WLAN radio. 

To create multiple radio configurations, copy the Profile1 section and paste it at the root level of the Suppli-
cant section. Then, rename that profile and configure the keys according the desired network configuration. 
Each child section name is arbitrary, but each name must be different.
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The Supplicant section contains one key named ActiveProfile. Type in the Value equal to name of one of the 
desired profile child sections. 

When DeviceConfig is activated on the terminal, the terminal will apply the settings in the profile specified in 
the ActiveProfile key. If the ActiveProfile key does not have a matching profile, the radio will be enabled by 
DeviceConfig but no specific radio configuration will be activated, which means that the radio will not connect 
to your network.

Profile Subsections
Each Profile subsection contains the keys that configure the radio connection from the terminal to the net-

work. 

Key Description Available Values

Name

SSID
The service set identifier used to connect to 
network; usually the network name of the access 
point or peer station.

X=Your network’s SSID
Any=Connect to any network

Assoc. Mode

The general association mode (sometimes called 
“authentication”) of the radio.

• None (no authentication or 
encryption)

• WEP
• IEEE 802.1X 
• WPA-Personal (PSK)
• WPA-Enterprise (EAP)
• WPA(2)-Personal (PSK)
• WPA(2)-Enterprise (EAP)

Encryption
The encryption mode available for the 
association mode.

Open & Shared (WEP)
TKIP, AES-CCMP, TKIP & 
CCMP (WPA)

EAP Method

Available EAP methods for IEEE 802.1X and 
WPA(2)-Enterprise (EAP) association modes.

• LEAP
• PEAPv0-MSCHAPV2
• PEAPv1-MSCHAPV2
• PEAPv1-GTC
• PEAPv1-TLS
• FAST-MSCHAPV2
• FAST-GTC
• FAST-TLS
• TLS
• TTLS-MD5
• TTLS-MSCHAPV2
• TTLS-GTC

PSK
Enter the private share key for the WEP 
association mode.

User-defined
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Identity
This is the 802.1X identity supplied to the 
authenticator. The identity value can be up to 63 
ASCII characters and is case-sensitive. 

User-defined

Password

This is the password used for MD5-Challenge or 
EAP authentication. It may contain up to 63 
ASCII characters and is case-sensitive. Asterisks 
appear instead of characters for enhanced 
security.

User-defined

Anonymous ID

Enter the anonymous ID. This ID creates a tunnel 
through which the real ID (as entered in the 
Identity field) can pass. 
For additional security, make this ID different than 
the one entered in the Identity field. 

User-defined

Tunnel PAC 
Machine PAC

For EAP-FAST, a one-time provisioning 
exchange establishes a shared secret, called a 
Protected Access Credential (PAC) Key. That 
PAC Key is used for all subsequent 
authentications.

Enter the address on the 
Dolphin terminal of either PAC 
(tunnel or machine).
Note: The PACs must be 

located on the Dolphin 
terminal!

Provisioning

Provisioning refers to service activation and 
involves programming various network 
databases with the customer's information.

• No Provisioning
• Anonymous
• Authenticated
• Anonymous + Authenticated

CA and/or Client 
Certificate

CA certificates are any certificates created by a 
certified authority (CA).
Client certificates contain information that 
identifies the user, as well as information about 
the organization that issued the certificate. This 
ensures that you can encrypt data end-to-end.

Enter the address on the 
Dolphin terminal of either 
certificate (CA or Client).

The certificates must be located 
on the Dolphin terminal!

Private Key

Private keys are used with certain types of EAP 
authentication.

Enter the address on the 
Dolphin terminal of the private 
key.
The private key must be located 
on the Dolphin terminal!

Priv Key 
Password

Private keys can be locked by passwords. Enter the password that unlocks 
the private key.

WEP Key Mode

Mode being used by the WEP keys (in Key1–
Key4 keys).

Key validation occurs when DeviceConfig is 
loaded on the terminal (often during AutoInstall), 
not when you save the DeviceConfig.exm file. 

ASCII uses all alpha numeric 
characters.
HEX uses only numerics and A-
F.

Valid lengths are as follows:
• 64-bit ASCII=5
• 128-bit ASCII=13
• 64-bit HEX=10
• 128-bit HEX=26

Key Description Available Values
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GSM Section
If there is no GSM radio installed in the terminal, disable this section.  Double tap or click on any Key to get full informa-
tion or to edit the settings.

System Section
The System section contains child sections that configure various system settings.  Double tap or click on any Key to get full 
information or to edit the settings.

About Section
The About section sets a unique device name and description for the terminal.  By default, this section is enabled and 
applied to the terminal after each reboot. 

DeviceName Restrictions
• The DeviceName must begin with a letter.
• The DeviceName cannot exceed 15 characters in length.
• Any text outside brackets (“[xxxx]”) will appear as text in the Device name field.

The following appears in the Device name field:

[SERIALNUMBER] The terminal’s serial number pulled dynamically from the kernel. 
This is the serial number that appears in SysInfo (see page 11-1).

[MODELNUMBER] The terminal’s model number pulled dynamically from the kernel.
This is the serial number that appears in SysInfo (see page 11-1).

Power Management Section
The Power Management section contains child sections that configure various backlight and battery settings.  Double 
tap or click on any Key to get full information or to edit the settings.

Applications Section
The Applications section configures specific software applications installed on the terminal.  Double tap or click on any Key 
to get full information or to edit the settings.

Internet Explorer Section

The Internet Explorer section defines the home page for Pocket® Internet Explorer.

MobiConrol Section
If the terminal includes the MobiControl Bootstrap Agent (MCBootstrapAgent.exe), then DeviceConfig can be used to 
configure the terminal to connect to a MobiControl Server and download the appropriate agent to the device. 

This section is disabled by default and should only be enabled when configuring the device to connect to the MobiCon-
trol Server for the first time.

The root level of the MobiControl section contains the main ConfigPath. 

WEP Key1–Key4

In fields Key 1—Key 4, enter the specific key.
The format of each key must match the key 
length type selected in the WEP Key Mode key. 
To use dynamic keys in your configuration, leave 
all the key fields blank.

User-defined

Active Key
Enter the number of the key that you want to be 
active in this configuration.

1, 2, 3, or 4

Key Description Available Values
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Command Line Arguments

/q Quits the program; this command line in the Args field of the Associated Application window stops the confirmation 
message from appearing after DeviceConfig.exe finishes processing.

Launching DeviceConfig.exe Manually
DeviceConfig.exe launches automatically after each reboot.  However, if you make changes to the DeviceConfig.exm file that 
you want applied in the terminal immediately, manually launch DeviceConfig.exe.

1. Tap Start > Power Tools > EZConfig Utilities > DeviceConfig.exm. 

2. Tap Tools > Launch Associated App.

3. The settings in the DeviceConfig.exm file are saved and applied to the terminal configuration by DeviceConfig.exe.
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7

Network Utilities
Accessing Network Utilities 

Tap Start > Power Tools > Network Utilities. The Network Utilities window opens.

Network Utilities Main Window  

Route

Route is a kernel utility that allows the user to view and edit the rules that govern how packets destined for various subnets are 
routed.  These rules tell the device which gateways on a given interface's subnet may be used to route packets to hosts on other 
subnets.

Route contains three tab windows: Input, Output, and About.  Enter and execute a command on the Input tab and review the 
results on the Output tab. 

Description Page

Route Determines how packets are routed to subnets. 7-4

IP Config
Displays, releases, and renews IP parameters for 
on-board network adapters.

7-3

Ping Sends out an echo request to a specific computer 
on the network.

7-3
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On the Network Menu window, tap the Route icon once . The Route screen opens to the Input tab.   

Print
This selection prints network routing tables to the Output tab.

On the Input tab, tap PRINT and tap Execute.  The Output tab appears displaying the network routing table.   

Add
This selection adds a route.

1. On the Input tab, tap ADD. 

2. Specify the range of IP addresses to which this rule will apply using the Destination and Netmask fields.  For example, 
the settings below specify an address range from 300.300.0.1 to 300.300.255.254. 

3. Enter the Gateway.

4. Enter the Metric (not required).

5. Enter the Interface (not required).

6. Tap Execute. The system verifies your results and the Output tab lets you know if your entry was added successfully.   

Delete
You can delete active routes.

7. On the Input tab, tap DELETE.   

8. Enter the IP address in the Destination field.

9. Tap Execute.  The system processes the request and displays how many routes were deleted. 
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Clear
Executing this command clears routing tables of all gateway entries.

On the Input tab, tap CLEAR and tap Execute. The system processes your request and the number of entries deleted 
appears on the Output tab.

IP Config

IPConfig is a kernel utility that displays, releases, and renews IP parameters for on-board network adapters.  IP Config contains 
three tab windows: Input, Output, and About.  The following fields appear on the Input tab:   

Displaying the Terminal’s IP Configuration
On the Input tab, tap the Display full configuration button. The Dolphin terminal retrieves and displays the IP configura-
tion for the entire terminal. 

Ping

Ping provides a GUI-based version of the traditional command line ping utility.  Pinging sends out an echo request to a specific 
computer on the network. Use Ping to verify communication links or to make sure a specific IP address is working. 

Field Description

Adapter
This drop-down list contains the network adapters currently installed in the Dolphin terminal. 
Every field and button on this screen pertains to the adapter selected in this drop-down list.

MAC Addr
Displays the MAC (Media Access Control) address of the selected Adapter. This is the serial 
number burned into the adapter that uniquely identifies it. 

IP Addr Displays the IP address.

Subnet Mask
Displays the adapter’s subnet mask. The subnet mask determines the subnet upon which the 
adapter resides.

Gateway Displays the adapter’s gateway information.

Release the IP address Click this button to release the IP address.

Renew the IP address Click this button to renew the IP address.

Display full 
configuration

Click this button to retrieve and review the full configuration of the terminal’s IP setup. For more 
information, see below.
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Ping contains three tab windows: Input, Output, and About.  Enter and send packet information to a specified remote host on 
the Input tab, and see the result on the Output tab.  The following fields appear on the Input tab:

Note: You do not need to complete all the fields on the Ping window to successfully execute.  Just enter the Destination IP 
address. 

Reading the Output Tab 
After you enter the IP information on the Input tab and click Execute, the Output tab appears and begins displaying the ping 
results. 

You can click the Stop button at any time to stop the ping.  Any errors encountered display on the screen. 

Field Description

Destination Enter the IP address. This field is required.

Timeout (milliseconds) Enter the timeout time in millisecond intervals; 1000 is the default. 

Send buffer size Indicate the buffer size for sending; 32 is the default.

Send count Indicate the count for sending; 4 is the default. Check Infinite to make the send count infinite.

TTL
Short for Time To Live, this is the maximum amount of time a packet is allowed to travel 
through the network before it is discarded.

TOS Enter the Type of Service (TOS); it should be eight bits broken into five subfields.

Rec route for count hops

Enter the number of hops to record in the IP header; 1–9.
This field traces the route of the packets for each hop.The hop count is the number of network 
devices between the starting node and the destination node that an IP packet hits while 
traveling over a network. The number of hops is recorded in the IP header.

Timestamp route
Enter the number of timestamps to record for each hop; 1–4
The timestamp is the packet’s arrival time at each hop.

Don’t fragment Check this box if you don’t want the packet to fragment during routing.

DNS address required Check this if you want the domain name server to be part of the route path.

Execute Click Execute to send the ping. The Output tab displays the response. 
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Registry Power Tools
Overview
The registry is the configuration database in all 32-bit versions of Windows that contains settings for the hardware and software, 
consisting of the SYSTEM.DAT and USER.DAT files.  Many settings previously stored in the WIN.ini and SYSTEM.ini files in 16-
bit Windows (Windows 3.x) are in the registry.

The RegEdit Power Tool enables you to edit the registry through an easy-to-use application window. You can also import and 
export specific registry keys.

Editing the Registry

1. On the Power Tools Main Window (see page 1-1), tap the RegEdit icon once . RegEdit opens to a split-pane window with a 
collapsible menu in the top half.

This is the top level of the registry; it cannot be edited, copied, pasted, or renamed.

2. Click the + sign to expand the menu options.

3. RegEdit offers the following registry categories:

• HKEY_CLASSES_ROOT
• HKEY_CURRENT_USER
• HKEY_LOCAL_MACHINE

4. Expand the appropriate menu by clicking on the + sign.
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5. Drill-down to the appropriate registry entry. When you click on registry entry in the top half of the screen, the data appears in 
the lower half of the screen. 

The two columns in the bottom half of the window show the Value Name and the Value Data of the selected entry.

6. Double tap Value Name. The Edit Value window pops up.

7. In the Value Data field, type the new value.

8. Tap OK. The new data appears in the list.

9. After all your edits are complete, Reboot (see page 10-1) the terminal to save your changes to the registry.

Menus
The menus on the RegEdit window offer the following editing options:

File Menu
The File menu allows you to create registry entries as well as import and export registry settings.  

Edit Menu
The Edit menu allows you to edit existing registry entries. 

Menu Item Description

New Creates a new Key, String, or DWORD Value. 

Import Imports a registry file; see Importing Registry Files on page 8-3.

Export Exports the current registry; see RegBackup.exm on page 8-3.

Exit Closes RegEdit.

Menu Item Description

Copy Copies a selected item.

Paste Pastes a copied item within RegEdit.

Rename
Renames a registry entry. 
Enter the new name and press the ENTER or OK key.
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View Menu
These menu items shift focus between the Keys Panel and the Values Panel.

Importing Registry Files
The file must be loaded on the terminal and have a REG extension. 

1. Tap File > Import. By default, the import function searches for REG files and displays the search results in the lower half of 
the window. 

2. Tap once on the REG file and it loads automatically.

Exporting Specific Registry Settings
You can export specific registry settings. In RegEdit, navigate to the section you would like to export and select it.

Tap File > Export and select the parameters of the REG file that would contain these settings.

If you want these REG setting to load during AutoInstall, select AutoInstall in the Folder drop-down list and Honeywell in the 
Location drop-down list. 

RegBackup.exm
The RegBackup.exm file is located in the \Honeywell folder and determines the content of the _RegBackup.reg file.

The RegBackup.exm file does NOT contain registry settings! Only REG files contain registry settings. 

Sections
_TEMPLATE_ Section
The _TEMPLATE_ section is a template of the basic registry sections. This section is not used when creating the 
_RegBackup.reg file. Use these subsections as a basis for modifications and additions to the file.

Backup Section
This default section should never be removed as it contains default excludes specified by Honeywell. It can, however 
be added to. Do NOT change the Mode (page 8-4)!

Modifying
Modifying the RegBackup.exm file allows you to include or exclude registry key sections and values during an export. Mul-
tiple subsections can be created.  All should be copied from the Template section which should not be modified.

Delete Deletes a selected registry entry.

Find

Searches for registry entries within a selected section. (Select an item in the top half of the window 
before tapping Edit > Find.) 
Enter the search criteria and tap OK. RegEdit notifies you if the selected section contains data 
matching the entered criteria.

Find Next Launches another search for the criteria entered in Find.

Menu Item Description
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To specify keys and values in the RegBackup.exm file, re-create the registry keys as sections and subsections in the tree 
structure just as they appear in the registry. The same rules that apply to copying directories apply here in that if you re-cre-
ate a key from the registry, all the key’s values and subkey’s values will be copied unless there are values in the top-level 
key.

Only the key or value name is needed in the EXM file and not the associated value data. The EXM file is a structure used to 
define the backup file and not the actual registry data. 

Mode and Kernel Check
In each Subsection root in the tree, there should be two key-value pairs: Mode and KernelCheck.

If these keys are not present, the defaults will be applied: 

Mode = Exclude

KernelCheck = Enabled

Mode
The Mode key specifies export behavior of the values in the section.

1=Include Only the values that follow will be included.

0=Exclude Everything but the values that follow will be included. 

KernelCheck
KernelCheck forces kernel version and service pack validation when a previously exported REG file is imported on a 
Dolphin terminal. This means that if you attempt to load a _RegBackup.reg file (during AutoInstall, for example), Reg-
Backup.exm verifies that the REG file matches the kernel installed on the terminal. If yes, then the REG file loads. If 
not, you’ll receive a warning message and the REG file will not load.

0=Disabled No kernel validation occurs on importing. In general (especially for radio settings), KernelCheck should 
be enabled. if the registry does not match the kernel, the terminal will not function properly.

1=Enabled Kernel validation occurs on importing.

These registry values will be 
included in the 
_RegBackup.reg file.
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Command Line Arguments

Registry Edit Options in EZConfig
You can also use EZConfig Editor to create registry documents on the workstation, create a bar code, then use EZConfig Client 
to decode the bar code and update the registry on the terminal.  See EZConfig Editor on the PC (Workstation) (page 4-1) and 
EZConfig Editor on the Dolphin Terminal (page 3-1).

Argument Description

/export <filename>
Export registry to <filename>. 
The <filename> part is optional. If no filename is entered, the file will default to 
\Honeywell\AutoInstall\_RegBackup.reg.

/import <filename>
Import <filename> to registry. 
The <filename> part is optional. If no filename is entered, the file will default to 
\Honeywell\AutoInstall\_RegBackup.reg.

/exm <filename>
Specify the non-default backup EXM file <filename>. Filenames with spaces must be 
wrapped in quotes. If omitted, the filename defaults to \Honeywell\RegBackup.exm. 
This argument is only valid when used with /export.

/section <SectionName>

Specify the non-default section in the EXM file for exclude or include export, depending on 
the mode setting in that section. If omitted, this defaults to the Backup section of whatever 
EXM file is specified. 
This argument is only valid when used with /export.

/key <key>
Specify the top level of the registry key structure to export. 
This argument is not valid when using /export or /import.

/silent Displays no dialogs. 
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ScanWedge and ScanManWedge
Overview
ScanWedge and ScanManWedge send bar code data from the decoder to the foreground application as keystrokes (as if the 
data were entered via the keyboard). The foreground application is the open software application whose window is currently 
active on the display.  You can review input data in Windows Mobile applications such as Pocket Word, Pocket Excel, and Inbox 
without having to load third-party applications. 

ScanWedge

ScanWedge decodes and sends 1D bar code data to the application.    

ScanManWedge

ScanManWedge decodes and sends both 1D and 2D bar code data to the application.  ScanManWedge must be licensed in 
order to function.  Contact Customer Support (page 14-1) for further information about licensing. 

Tap the ScanWedge or ScanManWedge icon once .  ScanWedge or ScanManWedge initializes and enables.

Enabling ScanWedge or ScanManWedge at Startup
To run ScanWedge or ScanManWedge automatically when the Dolphin terminal boots up, 

Add a link to the ScanWedge.exe or ScanManWedge.exe in the \WINDOWS\STARTUP folder

OR 

Enable the ScanWedge or ScanManWedge section of the Autorun.exm File (see page 5-1).

Disabling ScanWedge or ScanManWedge
Navigate to the Power Tools Main Window (see page 1-1) and tap the ScanWedge or ScanManWedge icon again.

OR

Select Exit on the Enabling ScanWedge or ScanManWedge at Startup (page 9-1).

Modifying the ScanWedge or ScanManWedge Configuration File
A ScanWedge.exm or ScanManWedge.exm file is inserted when ScanWedge or ScanManWedge is installed.  This file specifies 
configuration parameters for ScanWedge or ScanManWedge and must not be moved. 

Use EZConfig Editor on the workstation to modify ScanWedge.exm or ScanManWedge.exm. For more information, see 
Working with Open EXM Files on page 4-5.  
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ScanWedge.exm or ScanManWedge.exm Sections 

Double tap or click on any Key to get full information or to edit the settings in the ScanWedge.exm or ScanManWedge.exm file. 

Data Formatting Reference Charts

ASCII Conversion Chart (Code Page 1252)
Note: This table applies to U.S. style keyboards.  Certain characters may differ depending on your Country Code/PC 

regional settings.

Section Description

Settings Programs general settings for ScanWedge or ScanManWedge.

Comm Specifies how the serial (RS-232) port interfaces with ScanWedge or ScanManWedge.

Decode Specifies how the decoder/scanner interfaces with ScanWedge or ScanManWedge.

Formatting Defines data formatting functionality.

Symbologies Defines the symbologies that the scanner can decode and send to ScanWedge or ScanManWedge.

VK Mapping Defines the virtual key sent to ScanWedge or ScanManWedge for any decoded ASCII character. 

Non-Printable Characters
DEC HEX Character (Code) DEC HEX Character (Code)

0 0 NULL 16 10 DATA LINK ESCAPE (DLE)
1 1 START OF HEADING 

(SOH)
17 11 DEVICE CONTROL 1 (DC1)

2 2 START OF TEXT (STX) 18 12 DEVICE CONTROL 2 (DC2)
3 3 END OF TEXT (ETX) 19 13 DEVICE CONTROL 3 (DC3)
4 4 END OF TRANSMISSION 

(EOT)
20 14 DEVICE CONTROL 4 (DC4)

5 5 END OF QUERY (ENQ) 21 15 NEGATIVE ACKNOWLEDGE-
MENT (NAK)

6 6 ACKNOWLEDGE (ACK) 22 16 SYNCHRONIZE (SYN)
7 7 BEEP (BEL) 23 17 END OF TRANSMISSION 

BLOCK (ETB)
8 8 BACKSPACE (BS) 24 18 CANCEL (CAN)
9 9 HORIZONTAL TAB (HT) 25 19 END OF MEDIUM (EM)
10 A LINE FEED (LF) 26 1A SUBSTITUTE (SUB)
11 B VERTICAL TAB (VT) 27 1B ESCAPE (ESC)
12 C FF (FORM FEED) 28 1C FILE SEPARATOR (FS) 

RIGHT ARROW
13 D CR (CARRIAGE RETURN) 29 1D GROUP SEPARATOR (GS) 

LEFT ARROW
14 E SO (SHIFT OUT) 30 1E RECORD SEPARATOR (RS) 

UP ARROW
15 F SI (SHIFT IN) 31 1F UNIT SEPARATOR (US) 

DOWN ARROW
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Printable Characters
DEC HEX Character DEC HEX Character DEC HEX Character 

32 20 <SPACE> 64 40 @ 96 60 `
33 21 ! 65 41 A 97 61 a
34 22 " 66 42 B 98 62 b
35 23 # 67 43 C 99 63 c
36 24 $ 68 44 D 100 64 d
37 25 % 69 45 E 101 65 e
38 26 & 70 46 F 102 66 f
39 27 ' 71 47 G 103 67 g
40 28 ( 72 48 H 104 68 h
41 29 ) 73 49 I 105 69 i
42 2A * 74 4A J 106 6A j
43 2B + 75 4B K 107 6B k
44 2C , 76 4C L 108 6C l
45 2D - 77 4D M 109 6D m
46 2E . 78 4E N 110 6E n
47 2F / 79 4F O 111 6F o
48 30 0 80 50 P 112 70 p
49 31 1 81 51 Q 113 71 q
50 32 2 82 52 R 114 72 r
51 33 3 83 53 S 115 73 s
52 34 4 84 54 T 116 74 t
53 35 5 85 55 U 117 75 u
54 36 6 86 56 V 118 76 v
55 37 7 87 57 W 119 77 w
56 38 8 88 58 X 120 78 x
57 39 9 89 59 Y 121 79 y
58 3A : 90 5A Z 122 7A z
59 3B ; 91 5B [ 123 7B {
60 3C < 92 5C \ 124 7C |
61 3D = 93 5D ] 125 7D }
62 3E > 94 5E ^ 126 7E ~
63 3F ? 95 5F _ 127 7F <DEL>

Extended ASCII Characters
DEC HEX Character DEC HEX Character DEC HEX Character

128 80 €€ 171 AB « 214 D6 Ö
129 81 172 AC ¬ 215 D7 ×
130 82 ‚ 173 AD 216 D8 Ø
131 83 ƒ 174 AE ® 217 D9 Ù
132 84 „ 175 AF ¯ 218 DA Ú
133 85 … 176 B0 ° 219 DB Û
134 86 † 177 B1 ± 220 DC Ü
135 87 ‡ 178 B2 ² 221 DD Ý
136 88 ˆ 179 B3 ³ 222 DE Þ
137 89 ‰ 180 B4 ´ 223 DF ß
138 8A Š 181 B5 µ 224 E0 à
139 8B ‹ 182 B6 ¶ 225 E1 á
140 8C Œ 183 B7 · 226 E2 â
141 8D 184 B8 ¸ 227 E3 ã
142 8E Ž 185 B9 ¹ 228 E4 ä
143 8F 186 BA º 229 E5 å
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144 90 187 BB » 230 E6 æ
145 91 ‘ 188 BC ¼ 231 E7 ç
146 92 ’ 189 BD ½ 232 E8 è
147 93 “ 190 BE ¾ 233 E9 é
148 94 ” 191 BF ¿ 234 EA ê
149 95 • 192 C0 À 235 EB ë
150 96 – 193 C1 Á 236 EC ì
151 97 — 194 C2 Â 237 ED í
152 98 ˜ 195 C3 Ã 238 EE î
153 99 ™ 196 C4 Ä 239 EF ï
154 9A š 197 C5 Å 240 F0 ð
155 9B › 198 C6 Æ 241 F1 ñ
156 9C œ 199 C7 Ç 242 F2 ò
157 9D 200 C8 È 243 F3 ó
158 9E ž 201 C9 É 244 F4 ô
159 9F Ÿ 202 CA Ê 245 F5 õ
160 A0  203 CB Ë 246 F6 ö
161 A1 ¡ 204 CC Ì 247 F7 ÷
162 A2 ¢ 205 CD Í 248 F8 ø
163 A3 £ 206 CE Î 249 F9 ù
164 A4 ¤ 207 CF Ï 250 FA ú
165 A5 ¥ 208 D0 Ð 251 FB û
166 A6 ¦ 209 D1 Ñ 252 FC ü
167 A7 § 210 D2 Ò 253 FD ý
168 A8 ¨ 211 D3 Ó 254 FE þ
169 A9 © 212 D4 Ô 255 FF ÿ
170 AA ª 213 D5 Õ    

Extended ASCII Characters (Continued)
DEC HEX Character DEC HEX Character DEC HEX Character
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Symbology Chart

Symbology Code ID (hex)

All Symbologies   (0x99)

Australian Post A  (0x41)

Aztec Code z  (0x7A)

British Post B  (0x42)

Canadian Post C  (0x43)

China Post Q  (0x51)

Chinese Sensible Code (Han Xin Code) H  (0x48)

Codabar a  (0x61)

Codablock A V  (0x56)

Codablock F q  (0x71)

Code 11 h  (0x68)

Code 128 j  (0x6A)

GS1-128 I  (0x49)

Code 32 Pharmaceutical (PARAF) <  (0x3C)

Code 39 (supports Full ASCII mode) b  (0x62)

Code 49 l  (0x6C)

Code 93 and 93i i  (0x69)

Data Matrix w  (0x77)

EAN-13 (including Bookland EAN) d  (0x64)

EAN-13 with Add-On d  (0x64)

EAN-13 with Extended Coupon Code d  (0x64)

EAN-8 D  (0x44)

EAN-8 with Add-On D  (0x44)

GS1 Composite y  (0x79)

GS1 DataBar y  (0x79)

GS1 DataBar Limited {  (0x7B)

GS1 DataBar Omnidirectional y  (0x79)

GS1 DataBar Expanded }  (0x7D)

InfoMail ,  (0x2c)

Intelligent Mail Bar Code M  (0x4D)

Interleaved 2 of 5 e  (0x65)

Japanese Post J  (0x4A)

KIX (Netherlands) Post K  (0x4B)

Korea Post ?  (0x3F)

Matrix 2 of 5 m  (0x6D)

MaxiCode x  (0x7 8)

MicroPDF417 R  (0x52)

MSI g  (0x67)

NEC 2 of 5 Y  (0x59)
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Symbologies Section
The Symbologies section specifies the settings for each of the symbologies supported by the decoder.  1D symbologies are 
available in ScanWedge.exm, and both 1D and 2D symbologies are available in ScanManWedge.exm.  Double tap on the 
symbology name to display the default value, and the settings for that symbology.

The settings are in the form: 

Symbology Name=Enable(1 or 0), Parm1, Parm2, Parm3, Parm4, Parm5, Parm6, Parm7, Parm8

Where 

• Enable specifies that the symbology is enabled or disabled. 
• Parms1–8 specify the settings for the symbology. 

To see For more information regarding the individual settings for each of the symbologies, refer to the Honeywell Decode 
API documentation in the SDK documentation.

OCR
For comprehensive information about using OCR, refer to the OCR Programming User’s Guide available on our website at 
www.honeywellaidc.com.

VK (Virtual Key) Mapping Section
The virtual key map settings are located in the VKMapping section in the ScanWedge or ScanManWedge configuration file. 
The virtual key map settings define the virtual key that will be sent to ScanWedge or ScanManWedge for any decoded 
ASCII character. 

The settings are in the form:   ASCII Key = Virtual Key, ShiftMode

Where

• ASCII Key is an ASCII value between 0 an 255 (decimal)
• Virtual Key is the virtual key to be sent when the specified ASCII key is decoded

OCR MICR (E 13 B) O  (0x4F)

OCR SEMI Font O  (0x4F)

OCR-A O  (0x4F)

OCR-B O  (0x4F)

PDF417 r  (0x72)

Planet Code L  (0x4C)

Postal-4i N  (0x4E)

Postnet P  (0x50)

QR Code and Micro QR Code s  (0x73)

Straight 2 of 5 IATA f  (0x66)

Straight 2 of 5 Industrial f  (0x66)

TCIF Linked Code 39 (TLC39) T  (0x54)

Telepen t  (0x54)

UPC-A c  (0x63)

UPC-A with Add-On c  (0x63)

UPC-A with Extended Coupon Code c  (0x63)

UPC-E E  (0x45)

UPC-E with Add-On E  (0x45)

UPC-E1 E  (0x45)

Symbology Code ID (hex)
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• ShiftMode can have the following values:
• 0=the virtual key is never shifted
• 1=the virtual key must be shifted
• 2=the virtual key needs to be shifted if Caps Lock is off
• 3=the virtual key needs to be shifted if Caps Lock is on

Virtual Key Codes Table
The following table shows the symbolic constant names, hexadecimal values, and keyboard equivalents for the virtual-key 
codes used by Windows Mobile 6. The codes are listed in numeric order. 

Note: To use these codes in the VKMapping section, the hexadecimal values need to be converted to decimals. 

Symbolic Constant Name Decimal Value
Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 

VK_LBUTTON 1 01 Touch screen 

VK_CANCEL 3 03 Control-break processing 

—— 5-7 05-07 Undefined 

VK_BACK 8 08 BACKSPACE key 

VK_TAB 9 09 TAB key 

—— 10-11 0A-0B Undefined 

VK_CLEAR 12 0C CLEAR key

VK_RETURN 13 0D ENTER key 

—— 14-15 0E-0F Undefined 

VK_SHIFT 16 10 SHIFT key

VK_CONTROL 17 11 CTRL key

VK_MENU 18 12 ALT key 

VK_CAPITAL 20 14 CAPS LOCK key 

—— 21-25 15-19 Reserved for Kanji systems 

—— 26 1A Undefined 

VK_CLEAR 12 0C CLEAR key 

VK_RETURN 13 0D ENTER key 

—— 14-15 0E-0F Undefined

VK_SHIFT 16 10 SHIFT key 

VK_CONTROL 17 11 CTRL key 

VK_MENU 18 12 ALT key

VK_CAPITAL 20 14 CAPS LOCK key 

—— 21-25 15-19 Reserved for Kanji systems 

—— 26 1A Undefined 
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VK_ESCAPE 27 1B ESC key 

—— 28-31 1C-1F Reserved for Kanji systems 

VK_SPACE 32 20 SPACEBAR key

VK_PRIOR 33 21 PAGE UP key

VK_NEXT 34 22 PAGE DOWN key 

VK_END 35 23 END key

VK_HOME 36 24 HOME key 

VK_LEFT 37 25 LEFT ARROW key

VK_UP 38 26 UP ARROW key

VK_RIGHT 39 27 RIGHT ARROW key 

VK_DOWN 40 28 DOWN ARROW key

VK_SELECT 41 29 SELECT key 

—— 42 2A Original equipment manufacturer 
(OEM)– specific 

VK_EXECUTE 43 2B EXECUTE key

VK_SNAPSHOT 44 2C PRINT SCREEN key for Windows 3.0 and later 

VK_HELP 47 2F HELP key 

VK_0 48 30 0 key 

VK_1 49 31 1 key 

VK_2 50 32 2 key 

VK_3 51 33 3 key 

VK_4 52 34 4 key 

VK_5 53 35 5 key 

VK_6 54 36 6 key 

VK_7 55 37 7 key 

VK_8 56 38 8 key 

VK_9 57 39 9 key 

—— 58-64 3A-40 Undefined 

VK_A 65 41 A key 

VK_B 66 42 B key 

VK_C 67 43 C key 

Symbolic Constant Name Decimal Value
Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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VK_D 68 44 D key 

VK_E 69 45 E key 

VK_F 70 46 F key 

VK_G 71 47 G key 

VK_H 72 48 H key 

VK_I 73 49 I key 

VK_J 74 4A J key 

VK_K 75 4B K key 

VK_L 76 4C L key 

VK_M 77 4D M key 

VK_N 78 4E N key 

VK_O 79 4F O key 

VK_P 80 50 P key 

VK_Q 81 51 Q key 

VK_R 82 52 R key 

VK_S 83 53 S key 

VK_T 84 54 T key 

VK_U 85 55 U key 

VK_V 86 56 V key 

VK_W 87 57 W key 

VK_X 88 58 X key 

VK_Y 89 59 Y key 

VK_Z 90 5A Z key 

—— 91-95 5B-5F Undefined 

VK_NUMPAD0 96 60 Numeric keypad 0 key 

VK_NUMPAD1 97 61 Numeric keypad 1 key 

VK_NUMPAD2 98 62 Numeric keypad 2 key 

VK_NUMPAD3 99 63 Numeric keypad 3 key 

VK_NUMPAD4 100 64 Numeric keypad 4 key 

VK_NUMPAD5 101 65 Numeric keypad 5 key 

VK_NUMPAD6 102 66 Numeric keypad 6 key 

Symbolic Constant Name Decimal Value
Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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VK_NUMPAD7 103 67 Numeric keypad 7 key 

VK_NUMPAD8 104 68 Numeric keypad 8 key 

VK_NUMPAD9 105 69 Numeric keypad 9 key 

VK_MULTIPLY 106 6A Asterisk (*) key 

VK_ADD 107 6B Plus sign (+) key 

VK_SEPARATOR 108 6C Separator key 

VK_SUBTRACT 109 6D Minus sign (–) key 

VK_DECIMAL 110 6E Period (.) key 

VK_DIVIDE 111 6F Slash mark (/) key 

—— 88 88-8F Unassigned 

—— 146-185 92-B9 Unassigned 

—— 186-192 BA-C0 OEM-specific 

—— 193-218 C1-DA Unassigned 

—— 219-228 DB-E4 OEM-specific 

—— 229 E5 Unassigned 

—— 230 E6 OEM-specific 

—— 231-232 E7-E8 Unassigned 

—— 233-245 E9-F5 OEM-specific 

VK_ATTN 246 F6

VK_CRSEL 247 F7

VK_EXSEL 248 F8

VK_EREOF 249 F9

VK_PLAY 250 FA

VK_ZOOM 251 FB

VK_NONAME 252 FC

VK_PA1 253 FD

VK_EM_CLEAR 254 FE

VK_LWIN 91 5B

VK_RWIN 92 5C

VK_APPS 93 5D

VK_LSHIFT 160 A0

Symbolic Constant Name Decimal Value
Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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Command Line Arguments
/restart Forces ScanWedge or ScanManWedge to process its configuration file (ScanWedge.exm or ScanMan-

Wedge.exm) again, which applies changes immediately. If the SoundConnect setting is enabled (set to 1), an 
ascending connect sound is played on restart.

/quit Shuts down ScanWedge or ScanManWedge.

VK_RSHIFT 161 A1

VK_LCONTROL 162 A2

VK_RCONTROL 163 A3

VK_LMENU 164 A4

VK_RMENU 165 A5

Symbolic Constant Name Decimal Value
Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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Reboot
Reboot

You can reboot your system by holding down the power button for 5 seconds, or you can reboot it by tapping the Reboot icon.  
You would perform a reboot when:

• the terminal fails to respond.
• after installing software applications that require a re-boot.
• after making changes to certain system settings, such as network cards.
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SysInfo
SysInfo

SysInfo provides a read-out of important system information including firmware versions, DLL versions, system parameters, as 
well as network and radio information. 

To See System Information
Tap the SysInfo icon once. SysInfo queries the system, compiles the data, and displays a read-only file on the SysInfo screen.  
This information is gathered from the Dolphin terminal and changes only when the terminal’s configuration has changed.  To 
refresh the system information, go to File > Refresh. The system re-compiles system information.

To Save the System Information to a Text File
Tap File > Save to File. A file named “SYSINFO.txt” is generated and saved to the folder specified in the prompt.

To open the file, tap Start  > File Explorer.  Navigate to the Honeywell folder. The SYSINFO.txt file appears in the list.   If you 
tap on the SYSINFO.txt file, the file opens in Pocket Word.  You cannot change system information by editing the text.

To Upload SYSINFO.txt to a Workstation
You can upload the SYSINFO.txt file to a workstation via ActiveSync. 

1. On the workstation, open Windows Explorer.

2. Navigate to the Mobile Device folder.

3. Double click My Windows Mobile-Based Device and navigate to the Honeywell folder. The SYSINFO.txt file appears here.

4. Copy this file to your workstation.
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EZMenu
Overview
EZMenu is an additional tool that is not located under Power Tools.  EZMenu formats application windows to display and launch 
software programs on the terminal. For example, the Power Tools Main Window (see page 1-1) is managed by EZMenu.

EZMenu consists of: 

• Menu configuration files (i.e., EXM files that end in “*Menu.exm”).  They contain the settings for application windows.  
• The EZMenu.exe in the \Program Files\Power Tools folder.  This applies the exm file settings in the terminal.  

EZMenu.exe is launched during AutoInstall by default.

Running Easy Menu 
EZMenu runs when you access an application window that has a menu configuration file.  EZMenu.exe calls that menu configu-
ration file to format the window. 

Menu Configuration Files

Sample Menu Configuration Files
Samples of these default menu configuration files are downloaded when EZConfig Editor is installed on your workstation.  
These samples are located in: C:\Program Files\Honeywell\Power Tools and Demos for <product 
name>\EZConfig EXM Files. 

Modifying Menu Configuration Files 
Menu configuration files can be modified in EZConfig Editor on the workstation or the terminal, If modified on the worksta-
tion, the *Menu.exm file must be deployed to the terminal. 

For details about modifying EXM files in EZConfig Editor:

• See EZConfig Editor on the PC (Workstation) on page 4-1. 
• See EZConfig Editor on the Dolphin Terminal on page 3-1.

Creating Menu Configuration Files 
1. On the workstation, navigate to the following folder: C:\Program Files\Honeywell\Power Tools and Demos 

for <product name>\EZConfig EXM Files.

2. Open a sample menu configuration file in EZConfig Editor.

3. Click on File > Save As and save the file with a new name ending in “Menu.exm.”

Menu.exm Files EZMenu.exe

EXM files have an  icon. Executables have an  icon.
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4. Modify the file.  (Refer to Menu Configuration File Sections, below.)

5. Save or transfer the file to the terminal. 

Menu Configuration File Sections 
Menu configuration files contain two basic sections:  Settings and MenuEntries. Both sections are locked, which means 
only their Values can be changed, not their section names.

Settings Section 
The Settings section defines general EZMenu settings.  Click on each Key in EZConfig Editor to display the available val-
ues.

MenuEntries Subsections 
The MenuEntries section determines which programs appear on the application window. 

The MenuEntries section is locked, which means that you cannot change its name or description.  However, its child sec-
tions are not locked and can have any name and description.

Each child section is a program that launches from the application window and must be at the same level underneath the 
MenuEntries section. The order of child sections from top to bottom determines the order that the programs appear on the 
application window. 

Child Section Keys 

The keys in the child sections are locked, which means only their Values can be changed.  Double tap or click on the 
MenuEntries folder to get full information about the settings in the child sections.
12 - 2



Exit Icon
Default EZMenu configuration files contain a section named Exit as a child section of the MenuEntries section. 

Enabling the Exit section places this icon  on the application window, which allows users to exit.  If you want users 
to be able to exit the application window, make sure the Exit section is a child of the MenuEntries section.  If you want users 
to be unable to exit the application window, disable or delete the Exit section.

Start Options
Start Options define the required system parameters for a software application to launch. The following values can be 
entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category

DISABLED Never, regardless of other startup options specified. None

COLDBOOT The terminal has performed a factory reset.

Boot type
WARMBOOT The terminal has performed a reboot.

TOUCH The terminal has a touch screen display installed.

Touch Screen
NONTOUCH The terminal doesn’t have a touch screen display installed.

BATCH The terminal is a batch unit (no RF or internal modem cards installed).

Mobility

RF The terminal has an RF card installed (e.g., Cisco 802.11b).

GSM The terminal has a GSM radio.

BT The terminal has a Bluetooth radio.

MODEM The terminal has an internal modem card installed.

IMAGER The terminal has an imager installed.

Scanner
LASER The terminal has a laser scanner installed.

BLIND The terminal has no laser or imager installed.

ANYSCAN The terminal has either an imager or a laser scanner installed.

RFON The RF radio is Enabled.

Radio
GSMON The GSM radio is enabled.

BTON The Bluetooth radio is enabled.

RFGSMBTOFF The RF, GSM, & Bluetooth radios are disabled.
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29KEY The terminal has a 29-key keyboard.

Keyboard

35KEY The terminal has a 35-key keyboard.

38KEY The terminal has a 38-key keyboard.

43KEY The terminal has a 43-key keyboard.

56KEY The terminal has a 56-key keyboard.

NO_KEY The terminal has a 56-key keyboard.

7300 It’s a Dolphin 7300 terminal.

Model

7400 It’s a Dolphin 7400 terminal.

7450 It’s a Dolphin 7450 terminal.

74XX It’s any Dolphin terminal beginning with “74”.

7600 It’s a Dolphin 7600 terminal.

76XX It’s any Dolphin terminal beginning with “76”.

7850 It’s a Dolphin 7850 terminal.

78XX It’s any Dolphin terminal beginning with “78”.

7900 It’s a Dolphin 7900 terminal.

79XX It’s any Dolphin terminal beginning with “79”.

9500 It’s a Dolphin 9500 terminal.

9501 It’s a Dolphin 9501 terminal.

9550 It’s a Dolphin 9550 terminal.

9551 It’s a Dolphin 9551 terminal.

95XX It’s any Dolphin terminal beginning with “95”.

9700 It’s a Dolphin 9700 terminal.

9900 It’s a Dolphin 9900 terminal.

99XX It’s any Dolphin terminal beginning with “99”.

Option Name The program launches if … Category
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Multiple options can be specified for each category. For example, you can specify both 35KEY and 43KEY options to 
request that the program run in either a 35- or 43-key keyboard terminal. Seperate multiple options with commas.

To ignore a category, don’t specify any of its options.

Booting the Terminal to the Application Window
You can program the terminal to boot to the application window by modifying the Autorun.exm File (see page 5-1).

1. In EZConfig Editor, open Autorun.exm.

2. Open the Programs section and enable the EasyMenu section.

3. In the EasyMenu section, modify the Args key to call the EXM file of the application window. This is the path to the menu 
configuration file; i.e., “/***menu.exm.”
By default, the Args key calls /demosmenu.exm. 

4. Warm boot the terminal and verify that startup finishes on the application window.

PNPID
The terminal has a card installed whose identification contains ALL of the 
strings specified in the PNPID setting.

Expansion Card

NONPNPID
The terminal doesn’t have a card installed whose identification contains ALL of 
the strings specified in the PNPID setting.

Option Name The program launches if … Category
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Printing
Overview
Dolphin terminals contain two print utilities, BTPrint and Print Demo.

BTPrint
BTPrint allows you to print to a Bluetooth printer wirelessly via the command line, provided that the Bluetooth printer is set 
up as a Bluetooth Favorite on the Dolphin terminal. 

Call BTPrint.exe from the command line \Program Files\Power Tools\BTPrint.exe – with the path of the docu-
ment as the command line argument.

Print Demo
All Dolphin terminals contain a Print Demo (Start > Demos > Print Demo) that prints a sample receipt or bar code to a 
Bluetooth printer. The Print Demo calls the BTPrint.exe when printing to a Bluetooth device. 

Note: You can also call either EXE to print to a Bluetooth printer via command line.
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Customer Support
Technical Assistance
If you need assistance installing or troubleshooting your device, please contact us by using one of the methods below:

Knowledge Base: www.hsmknowledgebase.com

Our Knowledge Base provides thousands of immediate solutions. If the Knowledge Base cannot help, our Technical Support 
Portal (see below) provides an easy way to report your problem or ask your question.

Technical Support Portal: www.hsmsupportportal.com

The Technical Support Portal not only allows you to report your problem, but it also provides immediate solutions to your 
technical issues by searching our Knowledge Base.  With the Portal, you can submit and track your questions online and send 
and receive attachments. 

Web form: www.hsmcontactsupport.com

You can contact our technical support team directly by filling out our online support form.  Enter your contact details and the 
description of the question/problem.

Telephone: www.honeywellaidc.com/locations

For our latest contact information, please check our website at the link above.
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