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Accessing and Upgrading Power Tools
Dolphin Power Tools Overview

Note: Screen captures/icons in this user’s guide may differ from what appears on your device.

Dolphin Power Tools are installed in every Dolphin terminal. Different versions of Power Tools apply to 
different Dolphin terminals depending on their model or operating system.

Power Tool Windows Mobile 5/6/
6.1/6.5

Windows Mobile 2003 
Second Edition

Windows CE 5.0

6.0: 7600 (GSM)
6.1: 9900
6.5: 9700
5.0: 7850/7900/9500

7900/9500 7600

AutoInstall • • •

Autorun • • •

Battery Analyzer
(only on the 9700/9900)

•

BattMon • • •

DeviceConfig • • •

EZConfig Editor • • •

EZConfig Client • • •

EZMenu • • •

HotKeys • •

Keyboard Status • • •

Network Utilities:   

IPConfig • • •

Ping • • •

Route • • •

WiFi Status •

Backup Radio Settings •

Restore Radio Settings •

NoSIP • •

RASMan • •

Reboot • • •

RegBackup • • •

RegEdit • • •

RegRestore • • •

ScanWedge • • •
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Software Requirements 

Dolphin Terminals

Dolphin Power Tools are designed to work with Windows Mobile® 6

Desktop
The Power Tools installer and the workstation version of EZConfig Editor are designed to work with the 
following operating systems:

• Microsoft® Windows® XP
• Microsoft® Windows® 2000
• Microsoft® Windows® NT
• Microsoft® Windows® Vista
• Microsoft® .NET Framework 2.0
• Microsoft® ActiveSync® (version 4.5 or higher)

Power Tools Main Window

Tap Start > Power Tools and the Power Tools main window opens displaying the main Power Tools.  

SetRAM •

Suspend • • •

SysInfo • • •

Icon Name Description Page

BattMon Programs the LEDs on the top panel to monitor battery power. 6-2

EZConfig 
Utilities

Opens a window that displays the EZConfig utilities on the 
terminal.
• EZConfig Editor on the Terminal (see page 2-30)
• EZConfig Client (see page 2-34)

2-1

Power Tool Windows Mobile 5/6/
6.1/6.5

Windows Mobile 2003 
Second Edition

Windows CE 5.0
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Exiting the Power Tools Main Window

• Scroll down and tap the Exit icon .
• Tap File > Exit (ESC).
• Press ESC on the keyboard.

HotKeys Activates button assignments in the Buttons setting. 6-5

Keyboard 
Status

Puts an icon on the Navigation bar that indicates the alpha-
numeric status of the keyboard.

6-7

NoSIP Turns off the Soft Input Panel (SIP) in every application window. 6-9

Network 
Utilities

Opens a window that displays the Network utilities:
• IP Config (see page 9-2)
• Ping (see page 9-4)
• Route (see page 9-6)
• WiFi Status (see page 9-10)
• Backup Radio Settings (see page 9-12) 
• Restore Radio Settings (see page 9-12)

9-1

RASMan Establishes a remote access service (RAS) connection. 6-10

Reboot Performs a warm or cold boot from the touch screen, as 
opposed to the keyboard commands.

6-13

RegBackup Backs up the registry. 8-6

RegEdit Allows you to edit the registry and import and export registry 
keys.

8-1

RegRestore Loads the RegBackup file. 8-6

ScanWedge Enables the Dolphin terminal to interpret as keystrokes data 
received via the decoder, serial port, or IrDA interface.

5-1

SetRAM Allows you to re-set the memory allocation. 11-1

Suspend Manually puts the terminal into Suspend mode from the touch 
screen, as opposed to the keyboard commands or time-out 
settings.

6-14

SysInfo Displays system information. 6-15

Icon Name Description Page
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View Options

The View menu changes the organization of the Power Tools main window and is located at the bottom 
of the screen. A checkmark appears next to the selected view. 

This menu enables you to choose between:

• Small Icon View
• Large Icon View (Default view)
• List View
• Detail View (This view displays a description of the Power Tool in a column to the right of the name.)

Additional Dolphin Power Tools

These Power Tools are in the Dolphin terminal but do not appear on the Power Tools main window. 

Name Function Storage Location Access Location Page

AutoInstall Installs CAB files after a 
hard reset.

\IPSM \IPSM\AutoInstall 4-8

AutoRun Programs which 
applications launch at 
startup.

\IPSM \IPSM 4-1

BTPrint Prints to a Bluetooth 
device.

\Program 
Files\Power Tools

\Program 
Files\Power Tools

12-2

DeviceConfig Configures the terminal \IPSM \IPSM 3-1

EZMenu Programs custom 
application windows.

\Program 
Files\Power Tools

\IPSM 10-1

InstallerCE Stores CAB files after they 
install instead of deleting 
them.

\Program 
Files\Power Tools

You do not launch 
InstallerCE.

4-1

IrDAPrintCE Prints to an IrDA device. \Program 
Files\Power Tools

\Program 
Files\Power Tools

12-2
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Upgrading Power Tools

Dolphin Power Tools come loaded in every Dolphin terminal and are included in system upgrades. 

Acquiring Upgrades

Upgrades are available from Customer Support (see page 13-1) or www.honeywell.com/aidc.

Installing an Upgrade to the Workstation

Power Tools upgrades come in the form of an upgrade executable that installs upgrade files to the 
workstation. Transfer the appropriate upgrade files to the Dolphin terminal.

Requirements:  An active Microsoft ActiveSync connection between a host workstation and the Dolphin terminal.

1. Download the new Honeywell Power Tools and Demos for WM 6.0 Setup.exe to the Program 
Files folder on the workstation.

2. Click the Honeywell Power Tools and Demos for WM 6.0 Setup.exe to install. 

3. Click Next. If you accept the terms of the license agreement, select I accept the terms… 
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4. Click Next. 

5. Accept or change the installation location then click Next.
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6. Click Install and the programs begin installing.

7. The following screen appears when the programs have finished installing: 

8. Click Finish.
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Folder on the Workstation

After installation on the workstation is complete, the upgrade files are stored on the workstation at 
C:\Program Files\Honeywell\Power Tools and Demos for WM 6.0. 

Note: If a Honeywell folder does not already exist in the Program Files folder, the installation creates one.

Device Image A ghost image of the IPSM upgrade. The contents of this folder should replace the contents 
of the \IPSM folder on the Dolphin terminal.

Docs User guides for Demos and Power Tools (including this guide).

EZConfig EXM Files Sample EXM files. These files contain the default configuration settings for Dolphin 
terminals with Windows Mobile 6. 

Installing an Upgrade on the Terminal

1. Using the appropriate Dolphin communication peripheral for your series, connect the Dolphin termi-
nal to the workstation and ensure that the ActiveSync connection is running. 

2. On the workstation, open Windows Explorer and navigate to the \IPSM  folder on the Dolphin 
terminal.

3. Back up the terminal’s \IPSM  folder by copying and pasting its contents to the workstation.

4. Then, on the terminal, delete the entire contents of the \IPSM  folder. 

5. On the workstation, navigate to the C:\Program Files\Honeywell\Power Tools and 
Demos for WM 6.0\Device Image.

6. Copy all items (including the AutoInstall folder). 

7. Navigate to the \IPSM  folder on the Dolphin terminal and paste.

8. Copy and paste all custom CABs (radio drivers, applications, programs, etc.) to the \IPSM  folder. 

a. If you have custom EXM files with settings you want to keep and you want to have the upgrades in the new 
EXM files, merge those EXM files with the new EXM files instead of replacing them. 

b. Then, paste the merged EXM files to the Dolphin terminal.
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9. When all the files are pasted, cold boot the terminal. 

10. The Power Tools upgrade installs during startup.
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EZConfig
Overview

EZConfig is a suite of products that configures Dolphin terminals quickly and efficiently. With the tools in 
the EZConfig suite, you can package data on the workstation, then deploy and unpackage that data on 
the Dolphin terminal.

Components

There are two main components to EZConfig: EZConfig Editor and EZConfig Client.

EZConfig Editor

Edits and creates configuration and registry documents in the EXM file format for Dolphin terminals. There 
are two versions of EZConfig Editor: one for the terminal and one for the workstation.

For details about the workstation editor, see EZConfig Editor on page 2-2.
For details about the terminal editor, see EZConfig Editor on the Terminal on page 2-30.

Capabilities
Both editors:

• Create and modify EXM files–Working with Open EXM Files (see page 2-7)
• Convert INI files to EXM files–Converting Known INI and MNU Files (see page 2-28)

In addition, EZConfig Editor on the workstation 

• Generates bar codes from EXM files–Creating Bar Codes (see page 2-21)

EZConfig Client

Decodes the bar codes generated by EZConfig Editor on the workstation. For details, see EZConfig Client 
on page 2-34.

Upgrades

EZConfig Editor on the workstation must be installed on the workstation separately from the Power Tools 
upgrade. Obtain the Honeywell EZConfig Editor Setup rXX.exe from Customer Support (see page 13-
1) or www.honeywellaidc.com and install it on your workstation.

All components on the terminal–the EZConfig Editor and the EZConfig Client–are installed during Power 
Tools and Demos upgrades. For more information, see Upgrading Power Tools on page 1-5.
2 - 1
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EZConfig Editor

EZConfig Editor creates, edits, and manages EXM files for Dolphin terminals. There is an EZConfig Editor 
on the workstation and an EZConfig Editor on the terminal. In the workstation editor, EXM files are edited, 
saved, then transferred to the terminal. In the terminal editor, EXM files are edited and saved right on the 
terminal; see EZConfig Editor on the Terminal (page 2-30).

EXM Files 
The EXM file format is an XML format customized for Dolphin terminals that are comprised of sections 
that sometimes contain child sections and keys. Keys contain the values that configure the terminal. 

The EXM file format supports a multi-level, hierarchical, tree structure. The terminal reads the highest 
level section first and then reads the key values in each section.

EXM files replace INI files for Power Tools and terminal configuration settings. If both an INI file and an 
EXM file are present for the same application, the terminal defaults to the EXM file and a warning 
message appears at startup. Remove the INI file from the terminal to avoid this warning message.

Types of Configuration Files
There are two types of configuration files in the EXM file format: 

Configuration Documents Program and configure the terminal; see Opening EXM Files on page 2-6.

Registry Documents Update and modify the registry; see Registry Documents on page 2-17.

Installing EZConfig on the Workstation
EZConfig Editor on the terminal installs automatically as part of the Power Tools CAB file. 
You must install EZConfig Editor on the workstation separately.

1. Obtain the Honeywell EZConfig Editor Setup.exe and save it to the workstation.

2. Double-tap this EXE and follow the installation guide.

3. When installation is complete, a C:\Program Files\Honeywell\EZConfig Editor folder is 

created and an EZConfig icon appears on the Desktop .

Sample EXM Files
After you install the new build on the workstation, default EXM files are stored in the C:\Program 
Files\Honeywell\Power Tools and Demos for WM 6.0\EZConfig EXM Files folder.
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Use these files as templates to create new EXM files.

Opening EZConfig Editor on the Workstation
After you complete installation, EZConfig Editor is available on the workstation from the Start menu. 

Click Start > Programs > Honeywell > EZConfig Editor > EZConfig Editor.

Menu and Toolbar Options

The menu and toolbar at the top of the window contains many options.

File Menu

Menu Item Description

New 
Creates a new document. There are two options:

• Configuration Document - Creates a configuration file; 
Creating New Configuration Documents (page 2-15).

• Registry Document - Creates a registry file in the EXM file format;
Registry Documents (page 2-17).

Open 
Opens an EXM file located on the workstation.

Open from Device Opens an EXM file located on the terminal. The location of the file appears in the title bar 
with the word “[Remote]” to identify that the open file is located on the terminal. 
Note: Requires an ActiveSync connection between the workstation and the terminal.

Menu

Toolbar
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Edit Menu

For Section Edit menu options, see Working with Sections on page 2-7.
For Key Edit menu options, see Working with Keys on page 2-12.

View Menu

Save 
Saves the open file to the location you select on the workstation.
This option is disabled for new and imported files; use Save As instead. 

Save As Saves the open file with a new name to the location you select on the workstation.

Save to Device As Saves an open file to the terminal; see Saving to the Device on page 2-14.
Note: Requires an ActiveSync connection between the workstation and the terminal.

Properties 
Associates the EXM file with an application on the terminal; see Associating Applications 
on page 2-16.

Create EZConfig 

Bar Code 

Embeds the open EXM file in an Aztec bar code; see Generating Bar Codes on page 2-
22.

Exit Closes EZConfig Editor.

Menu Item Description

View Locks 
Displays an icon over locked sections. For example,

Information about locks on subsections and keys also appears in the Status Bar (see 
page 2-7).

File Menu

Menu Item Description

The lock icon means the section’s 
subsections are locked.

The key icon means that the 
section’s keys are locked.
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Tools Menu

Menu Item Description

Simplify Document
Note: You cannot 

undo this 
action!

Simplifies the EXM file, which makes it smaller. Simplifying permanently removes 

• Disabled sections and keys 
• Descriptions
• Bar code settings

When you create a bar code, you can simplify the file embedded in the bar code without 
affecting the open EXM file. This reduces the size of the bar code package yet keeps 
the disabled sections, descriptions, and bar code settings in the open EXM file for 
future reference. 
See Simplified (page 2-23) on the Advanced Tab (see page 2-24).

Because the following menu items execute commands on the terminal, there must be an ActiveSync connection 
between the workstation and the terminal. 

Launch Associated 
Application

If the open EXM file is associated with an application on the terminal, this item is active 
and launches the associated application on the terminal.
Note: You would use this option after saving the EXM file to the terminal; see Save to 

Device As on page 2-4.

*Warm Boot Warm boots the terminal.

*Cold Boot Cold boots the terminal.

*Some settings affect the boot process and these menu items can help you run a test without switching to the 
terminal.

Upgrade Remote 
INI Files

Launches the tool that converts existing INI files stored on a device to the EXM file 
format. For more details, see Converting Known INI and MNU Files on page 2-28.
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Opening EXM Files

EZConfig Editor opens EXM files stored on the workstation or the terminal (if an ActiveSync connection 
is established). 

Opening EXM Files on the Workstation

Click File > Open or the Open toolbar button  and select the EXM file.

When you select a known MNU or INI file, EZConfig Editor prompts you to convert the file. When you 
select Yes, EZConfig Editor imports the file and converts it to the EXM file format. Then, you can click 
File > Save As to save the file with the EXM extension. 

You cannot save known INI or MNU files in their original format. For a list of known files, see Known INI 
and MNU Files on page 2-28.

The preferred conversion method is to use the batch conversion tool and then make your edits to the new 
EXM files. For details, see Converting Known INI and MNU Files on page 2-28.

Opening Remote EXM Files

The workstation and the terminal must be connected via ActiveSync!

EZConfig Editor can open EXM files located on the terminal so that you can make edits to the terminal’s 
configuration real-time. 

When the terminal and workstation are connected by ActiveSync, click File > Open From Device and the 
remote open window opens. 

To open, double-tap on a file or select it and click OK. 

Note: You can also open EXM files in the editor on the terminal; see EZConfig Editor on the Terminal (page 2-30).
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Working with Open EXM Files
Whether you open an EXM or INI file, EZConfig Editor displays the content in four different sections of 
the window. 

Status Bar

The Status Bar appears at the bottom of the window and displays information about selected sections and 
keys.

Selected Section

See Section Locks on page 2-10.

Selected Key

See Key Types on page 2-14.

Working with Sections
The EXM file format supports a multi-level tree structure. The section tree appears in the top left quadrant 
of the window. The root node identifies the EXM file and “Root” appears in the description.

Sections have a Name and Description and contain keys that appear in the upper right quadrant when 
you select the section name. Select a section by clicking on it. You can select only one section at a time.

Displays the root node 
and sections. 

Select a section and the 
details appear in the 
other portions of the 
window.

The folders appear in 
different colors to 
indicate their status.

Displays the section 
name and description. 

Displays the keys in the 
selected section.

Text that appears in blue 
can be edited.

Displays the selected 
key’s name and 
description.

Displays the file name.

If the file is on the 
terminal, the title bar 
displays the remote 
path.

Status Bar

Section Name Merge Mode Locks on subsections and keys

Key Name Enabled or 
Disabled

Read Only Encrypted Key locked by 
section 
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Edit Menu Options

Select a section click Edit to see the available options.

Menu Item Description

Rename Activates the section name so that you can rename the section.
Note: You cannot modify the name if the section is locked; see Section Locks (page 2-10).

Cut Cuts a selected section.

Copy Copies a selected section.

Paste Pastes the section that was just cut or copied at the same level as the selected section.

Paste as Child Pastes the section that was just cut or copied as a child of the selected section.
Note: You can cut, copy and paste sections within an EXM file or across EXM files.

Delete Deletes a selected section. 
Note: Because you cannot undo a delete, consider disabling rather than deleting.

Enable Sections are enabled by default. This menu item enables sections that were previously 
disabled. You can enable a section only if its parent section is enabled.

To enable all the keys inside a section you are enabling, SHIFT + right-click and select 
Enable All.

Disable All Sections are enabled by default. This menu item disables sections and all of its keys. 
Disabled sections remain in the file with a gray folder .

If you disable a section that has child sections, all of its child sections (and the child section 
keys) are disabled automatically. The child section folders are also in gray.

When reading the EXM file, the terminal behaves as though disabled sections are not there 
and moves on to read the next enabled section.

Disabled sections can be removed from the EXM file permanently using the Simplify 
Document (see page 2-5) option. If you want to keep disabled sections in the EXM file on 
the workstation but not in the file deployed to the terminal, use the Simplified option (see 
page 2-23) when creating the bar code.
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Modifying Section Names

To change a section name, double-click on the folder and type in the new name or select Rename on the 
Edit menu. Type in the new name and press ENTER.

Note: You cannot modify the name if the section is locked or disabled; see Section Locks (page 2-10).

Modifying Section Descriptions

Descriptions are not required to process key values but do help document the EXM file and often contain 
valuable information. If you want to modify a section description, select the section, click inside the section 
description, and begin typing. You cannot modify descriptions of locked sections.

Moving Sections

To move sections within an EXM file, use the drag and drop method. By default, sections are dropped at 
the same level in the tree. 

For additional functionality when dragging and dropping, press and hold: 

• ALT to drop a section as a child section. 
• CTRL to copy a section and drop the copy at the same level in the tree. 
• CTRL + ALT to copy a section and drop the copy as a child section.

Note: You can select only one section at a time; you cannot use SHIFT+Click or CTRL+Click to select more than 
one section.

To move sections between EXM files, open two instances of EZConfig Editor and drag and drop sections 
between them. When dragging, a copy of the section is dragged to the new file. When dropping, drop the 
section directly on top of the section you want it to be a child section of.

Note: To drop the first section into a new file, press and hold the ALT key and drop the section on the root node. (All 
sections must be child sections of the root node.)

Insert Section This menu item inserts a new section. You can also press the Insert key (INS).

Append Child 
Section

This menu item adds a new child section to a selected section. The new child section is 
inserted below the previous section.

Menu Item Description
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Section Locks

There are different types of locks on sections. The status bar indicates what type of lock is applied to a 
selected section.

Note: All locks are applied to each individual section and are not recursive. Only text that appears in blue can be 
modified.

Section-Level Merge Modes

EXM files ship with section-level merge modes already defined according to section content. Merge 
modes determine how section information is handled when an updated EXM file is deployed to the 
terminal where an existing version of that EXM file is stored.

Merge modes are indicated by folder icons and in the Status bar.

Lock Type Status Bar 
Indicator

Description Effect

Name Lock The section name is 
locked.

• Section Name and Description cannot be 
modified. 

Key Lock All keys are locked. • Key Names and Descriptions cannot be 
modified.

• Keys cannot be added, moved, or deleted 
within the section. 

Subsection 
Lock

All immediate subsections 
are locked.

• Immediate subsection Names and 
Descriptions cannot be modified.

• Immediate subsections cannot be added, 
moved, or deleted.

Mode Description Merge Effect

Delete + Add Deletes non-common children elements (i.e., subsections, and keys) in 
the target file, then adds the new information from the bar code. 
Basically, the new section replaces the old section.
This is the default merge mode for new sections. 

Exclusive

Disable + 
Add

Disables non-common children elements (i.e., subsections, and keys) in 
the target file, then adds the new information from the bar code. 
Note: Disabled sections and keys removed from the simplified bar code 

end up as disabled in the target file.

Add Only Adds new information (sections and keys) to the existing section. If this 
is a brand new section, the new section is added to the existing EXM 
file.
Note: Disabled sections removed from the simplified bar code are not 

modified in the target file.

Inclusive
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To change section-level merge modes, select a section and right click.

The folder colors change immediately after selection.
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Working with Keys
Keys have a Name, a Description, and a Value and reside inside sections. For specific key values, consult 
the chapters of this user’s guide that describe the EXM file you’re attempting to edit. 

Edit Menu Options

Select a key and right-click or click Edit to see the available options.

Menu Item Description

Rename Activates the key name so that you can rename the key. Rename is disabled if the key 
is locked or disabled; see Key Types (page 2-14). 

Cut Cuts a selected key.

Copy Copies a selected key.

Paste Disabled; keys can be pasted only as children of a section.

Paste as Child Pastes the key just cut or copied in the selected section. Keys are not multi-level; all 
keys paste at the same level within a section.
You can cut, copy and paste keys within an EXM file or across EXM files. 

Delete Deletes a selected key. 
You cannot undo a delete; you might want to consider disabling rather than deleting.

Enable Enables keys that were disabled. When a key is enabled, the client application can 
read and apply its value. When you enable a key, make sure to specify a value for that 
key; do not leave it blank.

To enable a key, its parent section must be enabled.

The same options 
appear on both 
menus.
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Modifying Key Names

To modify key names, double-click on the key name or select Rename on the Edit menu. Type in the new 
name and press ENTER or TAB.

Note: You cannot modify the description if the key is locked; see Key Types (page 2-14). Only text that appears in 
blue can be modified.

Modifying Key Values

You can modify a key value only if its text appears in blue. In that case, double-click on the value or select 
the key and press ENTER. Type in the new value and press ENTER or TAB to save.

Modifying Key Descriptions

Descriptions are not required to process key values but do help document the EXM file and often contain 
valuable information. To modify a key’s description, click on the key, then click in the key description area. 
When the cursor is active, you can type in the text. 

Note: You cannot modify the description if the key is locked; see Key Types (page 2-14).

Moving Keys

To move keys within an EXM file, use the drag and drop method. Press and hold the CTRL key to drag 
and drop a copy of the key to the new location.

Note: You cannot move a key if it is locked by its section.

To move keys between EXM files, open two instances of EZConfig Editor and drag and drop keys 
between them. When you select the key and drag, a copy of the key is dragged to the new file. In the new 
file, drop the key in the key area of a selected section; keys are always dropped at the same level within 
a section.

Disable Disables keys. 
Disabled keys have key values in black. Enabled keys have key values in blue.

The terminal does not read disabled keys and disabled keys are removed if the file is 
simplified; see Simplify Document (page 2-5). 

Because many key values are 1 for enable and 0 for disable, remember that disabling a 
key means that the terminal behaves as if the key is not there when reading the file, 
NOT that the key’s value is set to disabled. The terminal simply moves on to read the 
next enabled key. 

Insert New Key This menu item inserts a new key above the selected key.
Note: You can also press the Insert key (INS).

Menu Item Description
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Key Types

When a key is selected, its properties display in the Status bar.

Note: Locked and Read Only properties are not recursive. Properties are applied to each individual key. Only text 
that appears in blue can be modified.

Saving to the Device

You can save EXM files directly to the terminal when there is an ActiveSync connection between the 
terminal and the workstation. Select File > Save to the Device As and the Save Remote File window 
opens. 

Select the location on the terminal where you want to store the file and click OK. The file is downloaded 
directly to the terminal via ActiveSync. 

Note: EXM files for Power Tools must be stored in the \IPSM folder. 

Lock Type Status Bar 
Indicator

Description Effect

Name Lock Keys are locked by the 
section. 

• Name and Description cannot be 
modified. 

• Keys cannot be added, moved, or 
deleted within the section.

The key name is locked 
individually.

• Name and Description cannot be 
modified. 

• These keys can be moved.

Read Only Read-only keys cannot be 
modified in any way. They 
appear in red.

• Name, Description, and Value cannot be 
modified.

• Keys cannot be added, moved, or 
deleted within the section.

Encrypted Key’s value appears as 
asterisks (*) for added 
security. 

Note: Encrypted keys are also stored 
encrypted in the EXM file. If you open 
the EXM file in a text editor, you won't 
see the data as clear text.
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Creating New Configuration Documents
To create new EXM files that are configuration documents, you can open an existing EXM file and save 
it with a new name or create an EXM file from scratch.

1. Click File > New > Configuration Document. The root node is created and appears as the top level 
section. All sections must be at least one level down from the root node. The name of the root node 
is always the same as the filename. 

Note: You can also create registry documents in the EXM file format. For details, see Registry Documents on page 
2-17.

2. To create the first subsection, select the root node, right-click, and select Append Child Section. 
Insert Section is disabled because you cannot insert sections at the same level as the root node.

3. Enter a Name and a Description and click OK.
The name is required, the description is optional.

4. To add a new section at the same level, right-click and select Insert Section.
To add a new section one level down, right-click and select Append Child Section.

5. To add keys, select a section, right-click in the key value section, and select Append Key. 

6. Enter the Name, Value, and Description and click OK.
The name is required, the description is optional.

7. Continue adding sections and keys.

8. If necessary, associate this EXM file with an application; see Associating Applications (page 2-16).

9. Click File > Save As to save the file. 
Save is disabled so that you save the document with a name other than “NewDocument.exm.”

The terminal reads 
root node first.

The Description 
says “Root” to 
indicate that this is 
the root section. 
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Associating Applications
The Properties function associates an EXM file with an application on the terminal. The associated 
application launches after EZConfig Client decodes the bar code containing the EXM file. 

For more information, see Creating Bar Codes on page 2-21.

While the EXM file is open, click File > Properties or the Document Properties toolbar button . 

Field Description

Path Enter the location of the EXE on the terminal.

Arguments Enter the command line argument you want applied when the application launches.
When an application is entered in the Path field, the following command line appears as 
the argument: /exm %filename.

Enter additional command line arguments (see Command Line Arguments on page 2-
37) next to /exm %filename in this field.

“%filename” means that the value immediately after the “%” is variable and the file name 
will be replaced with the remote path entered on the Bar Codes tab; for more information, 
see Remote Path on page 2-23.

Execute Tells EZConfig Client to launch the application after decoding the bar code. Execute 
selects automatically when an application is entered in the Path field. 

You cannot de-select Execute for configuration documents. 

You can de-select Execute for registry documents; however, EZConfig Client cannot 
update the registry unless Execute is selected. For more information, see Default 
Application Association (page 2-17).

Wait Until 
Finished

Tells EZConfig Client to wait until the associated application is finished processing before 
finalizing.
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Registry Documents

EZConfig Editor creates registry documents in the EXM file format and also opens existing REG files and 
converts them to the EXM file format. EZConfig Editor cannot save registry documents in the REG file 
format. 

Updating the Registry on the Terminal

To update the terminal’s registry, you must 

• Create an EXM file that is a registry document–Creating Registry Documents (page 2-18),
• Create a bar code package from that EXM file–Creating Bar Codes (page 2-21), and
• Scan the bar code with the terminal

By default, EZConfig Client on the terminal updates the Windows registry immediately after decoding the 
bar code. 

Default Application Association

By default, registry documents are associated with EZConfig Client. While a registry document is open, 
click File > Properties.

Execute must remain selected for EZConfig Client to update the registry after decoding the bar code. If 
Execute is not selected, the registry document is deployed after decoding but the registry is not updated.
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Creating Registry Documents

1. In EZConfig Editor, click File > New > Registry Document.

The new document contains the three top-level sections in a registry. These sections are locked and 
cannot be changed. You can add subsections to each section and then add keys to those 
subsections.

2. Click File > Save As. 

3. Choose the name and location and click Save. 
You cannot save the document as a .reg file; you must save it as an EXM file. 

4. To add sections, select one of the registry levels, right-click, and select Append Child Section. 
Enter the section information, and click OK.

For more information about adding sections, see Working with Sections on page 2-7.
5. To add keys to the new section, select the section, and right-click in the key value area.

For details, see Adding Registry Keys on page 2-19.

6. Continue adding sections and keys.

7. Save the file.
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Adding Registry Keys

To add a key, select a section, and right-click in the key area of the EZConfig Editor window. 

When you click OK to save the key, the data appears in columns in the key area of the EZConfig Editor 
window.

Processing Registry Documents on the Terminal
After EZConfig Client updates the registry, the EXM file itself is deployed to the location entered in the 
Remote Path (page 2-23) field on the Bar Codes Tab (page 2-22).

Note: EXM files appear with an  icon on terminal windows.

Field Description

Name Enter the key’s name.

Registry Value Type Select the registry type from the drop down list. This value appears in the Type 
column.

Value Enter the key’s value.

Desc Enter a description for the key; descriptions appear in the lower half of the EZConfig 
Editor window when the key is selected.
2 - 19



If you do not want to store the registry EXM file on the terminal after updating the registry, select the 
Temporary (page 2-25) option on the Bar Codes Tab (page 2-22).

Persistent Registry Documents

If you want to update the registry during every cold boot, create a registry document in the EXM format, 
save it to the terminal in the \IPSM\AutoInstall folder, and cold boot. The registry settings in the EXM 
file will load during startup.

Note: Of course, if you want to save a registry file but not load it every startup, simply store the registry EXM file in 
the \IPSM folder.
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Creating Bar Codes 

EZConfig Editor embeds EXM files in bar codes. The EZConfig Client on the terminal decodes the bar 
code and deploys the data. Using bar codes quickly and easily configures Dolphin terminals without an 
IrDA, ActiveSync, or network connection to a workstation.

Document Types

EZConfig Editor produces two kinds of EXM files: configuration documents and registry documents. Both 
can be embedded in bar codes and processed by EZConfig Client on the terminal.

Configuration Documents
EZConfig Client deploys the EXM file in the terminal. If an EXM file is associated with an 
application, EZConfig Client deploys the data to that application for processing; see 
Associating Applications on page 2-16.

Note: The DeviceConfig.exm file must be associated with DeviceConfig.exe to be processed 
appropriately on the terminal.

Registry Documents
EZConfig Client updates the registry immediately without launching another application. 

Bar Code Type

EZConfig Editor creates an Aztec bar code; for example, .

Time and Date Stamp

EXM files are stamped with the time and date the moment EZConfig Editor creates the barcode.

Bar Code Size and Number

The amount of data in the EXM file determines how many bar codes are generated and the physical size 
of each bar code. More data means more bar codes and larger bar codes. 

EZConfig Editor offers four ways to control how many bar codes are produced and adjust the size of each 
bar code: 

1. Set byte size limits on how much data each bar code can contain—see Max Barcode Size on page 
2-24. 

2. Split the data across a specified number of bar codes—see # Bar codes to generate on page 2-23.

3. Simplify the EXM file in the bar code—see Simplified on page 2-23.

4. Scale the bar codes on the bar code sheet—see Bar Code Scaling Factor on page 2-26.
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Bar Code Sheet

EZConfig Editor produces a bar code sheet that contains the generated bar codes. Bar code sheets can 
be printed from a laser printer, copied to the clipboard, and saved as an HTML file; see Printing and 
Saving Options on page 2-26. 

In addition, individual bar codes can be saved as TIF or PNG graphic files that can then be emailed and 
printed; see Bar Codes Tab on page 2-22.

Generating Bar Codes

When creating a bar code, EZConfig Editor automatically encrypts and compresses the data in the EXM 
file. To generate a bar code, click File > Create EZConfig Bar Code OR the Create Bar Code toolbar 

button  while the EXM file is open. EZConfig Editor generates a bar code or codes. The Bar Codes tab 
window opens displaying the details of the bar code package generated. 

The Bar Codes and Advanced tabs offers several processing options. 

Note: The number of bar codes produced depends on the amount of data present in the EXM file. The more data 
present, the more bar codes generated. You must scan all bar codes to deploy the package!

Bar Codes Tab

The Bar Codes tab previews and customizes generated bar code(s). 

Field/Option Description

Display Indicates which bar code is displayed in the preview area; the default is “1,” the first bar 
code in the package. If more than one bar code was generated, you can use the up and 
down arrows to scroll through the bar codes.

(___ bytes) Displays the exact byte size of the bar code displayed in the preview area.
Total Package Size (page 2-26) is displayed at the bottom of the window.
Note: The sum of bar code size is typically larger than the package size. 
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Remote Path Type in the location and filename where the EXM file should be deployed on the terminal. 
For instance, 
\ipsm\deviceconfig.exm

Tap the browse button  to navigate to the location on the terminal. Your ActiveSync 
connection must be active.

Full Contents Includes the full content of the EXM file in the bar code, without simplifying.

Simplified Simplifies the EXM file in the bar code, which removes disabled sections, description 
information, and bar code settings (if any), which decreases the size of the bar code. The 
open EXM file is not simplified.
Simplified is selected by default.

The differences in total package size are displayed in the Package Size (page 2-26) field.

Individual bar code size can be seen in the Display (page 2-22) field.

# Bar codes to 
generate

This is active only if the Always use minimum # bar codes (see page 2-24) is not 
selected. When this slider is active, you can move the slider toward minimum or 
maximum to change the number of bar codes generated. As you move the slider, you’ll 
see the number of bar codes in the counter at the bottom of the window  and 
you’ll notice the graphic of the bar code in the preview area change.

Copy to 
Clipboard

Copies the bar code displayed in the preview area to the clipboard.
Use this option to paste the bar code into another application.

Save Saves the bar code displayed in the preview area as a graphic file as a .png or .tiff. 
By default, the name of the graphic file is the same as the name of the open EXM file. 
You can enter a different name when saving.

Save All Saves all bar codes in the package as individual graphic files.
By default, the graphic files are saved with the same name as the open EXM file with a 
number at the end to distinguish the individual graphic files from each other.

Print Opens the printing window where you can select print options and print the bar code 
package. For details, see Printing and Saving Options on page 2-26.

Field/Option Description
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Advanced Tab

The Options tab contains settings that tell EZConfig Client how to process the EXM file on the terminal. 

Field Description

Bar Code Options–This section determines some of the basic bar code parameters.

Max Barcode 
Size

Set the maximum amount of data (in bytes) one bar code can contain. The lower the 
number of bytes, the smaller the bar code. 

• On the Bar Codes tab, bar code size appears in the Display field (see page 2-22). 
• The total number of bar codes the are created as a result of the max bar code size 

limit appears at the bottom of the Advanced window; see Bar Codes (page 2-26).

Always use 
minimum # bar 
codes

This option is selected by default. It calibrates the data so that the minimum number of bar 
codes are used. When this option is selected, the number of bar codes slider on the Bar 
Codes tab is disabled.

Use custom 
password

This option enables you to password-protect the bar code you’re creating. 
Select this option, then enter the password in the field provided. You will be able to see the 
password when you enter it; however, you will not be able to see the password again once 
you close the window because the password will be encrypted.

If you password-protect the bar code, EZConfig Client on the terminal will prompt you to 
enter that same password on decoding. 

Full screen 
progress dialog

This option runs the deployment progress dialog box on the terminal in full screen mode 
so that the user cannot open another application while the bar codes are being deployed 
on the terminal. 

Warm boot after 
finished

This option automatically launches a warm boot on the terminal after the bar code is 
deployed. Use this options with EXM files that contain application information requiring a 
warm boot to take effect, such as registry settings.

Deployment Options–These options determine how to deploy the EXM file on the terminal. 
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Merge each 
section…
(Default 
selection)

Deploys information according to the section-level merge mode settings; see Section-
Level Merge Modes on page 2-10.
If already exists, deploy:
• Always–Select to always use the section-level merge mode settings.
• Only if newer–Select to use the section-level merge mode settings only if the sections 

are newer than the existing file.

Temporary Deploys the EXM file temporarily. The settings in the EXM file are applied, but the file does 
not remain in the system after EZConfig Client is done. 

If the terminal contains a previous EXM file with the same name, the previous EXM file is 
preserved.

If already exists, deploy–This section determines how the EXM file will be deployed if there exists on 
the terminal an EXM file of the same name in the same location. 

Replace remote 
file

Replaces the existing file; no section-level merge modes are applied.
If already exists, deploy:
• Always–Select to always replace the existing file.
• Only if newer–Select to replace the existing file only if the file in the bar code is newer 

than the existing.
• Never—Do not deploy the new file; this preserves the existing file.
• Prompt—EZConfig Client asks the user if they want to overwrite the existing file during 

deployment.

Persist Bar Code Settings

Stores the settings from the Options, Bar Codes, and Web Page tabs within the EXM file so that the same bar 
code settings are applied the next time a bar code is created. This increases the size of both the EXM file and 
the bar code(s). 

If the Simplify option is selected, bar code setting information is not included in the bar code but remains in the 
open EXM file.

Field Description
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Information at the Bottom of Tab Windows 

Printing and Saving Options

On the Bar Codes tab, when you click Print, a bar code printing window opens offering you a number of 
printing options.   

Field Description

Package Size Displays the total size of the bar code package. This number changes with 
simplifying. 

Compression On Notifies you that compression and encryption are both on.
Compression and encryption are always on by default. EZConfig Editor uses 128-bit 
encryption automatically.Encryption On

Bar Codes Displays the total number of bar codes generated. This number changes as you 
move the slider on the Bar Codes tab.

Field/Option Description

Preview Area This is the largest section of the tab window and displays a preview of the bar code 
sheet. Use the scroll bars to see all the bar codes.

Header Type in a custom header for the page. “EZConfig Bar Code Sheet” is the default 
header.

Footer Type in a custom footer for the page. “Hand Held Products” is the default footer.

Bar Code Scaling 
Factor

Adjusts the size of each bar code by scaling all of them up or down, which 
determines how many bar codes can fit on each page. This does not change the 
amount of data in each bar code, just the size of the bar code on the page.
2 - 26



Save Saves the bar code sheet as an HTML file.

Preview Click to see a print preview. 

Click Print on this window to print your bar codes.

Field/Option Description
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Converting Known INI and MNU Files

EZConfig Editor contains a batch conversion tool that converts known INI files on the terminal to the new 
EXM file format. 

EZConfig Editor pulls INI files from the \IPSM folder of a remote device, converts them to the EXM file 
format, and saves both original INI files and the converted EXM files in folders created on the workstation. 
You don’t lose your original INI files in the conversion.

Note: You must have an ActiveSync connection between the workstation and the device to use this tool. 

Known INI and MNU Files

• *Autorun.ini
• RASMan.ini
• Scanwedge.ini
• RFSettings.ini
• ImageDemo.ini
• ScanDemo.ini
• *Any EZMenu file (INI or MNU)
*These files must be converted using this tool to run properly on Dolphin terminals.

Converting Files

1. In EZConfig Editor on the workstation, click Tools > Upgrade Remote INI Files. You receive a 
warning message describing what is about to happen.

2. Click Yes and EZConfig Editor retrieves remote INI files on the terminal and displays them in a list.

3. Select the files and the location on the workstation for the files. The default location on the 
workstation is: 

These are the INI 
files found. Select 
the files you would 
like to convert. 

SHIFT + click to 
select more than 
one file to convert. 

This is the location 
on the workstation 
where the original 
and converted file 
will be stored. 

Click this Browse 
button to select 
another location. 
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C:\Program Files\Honeywell\Power Tools and Demos for WM 6.0\Device 
Image\Converted Files\Upgrade X. 
The X increases by one each time you run a batch conversion.

4. When you click OK, the conversion runs.

5. EZConfig Editor creates two folders inside the Upgrade X folder: Converted EXMs and Original 
INIs.

Note: An Upgrade X folder with these two subfolders is created every time you run a conversion. 
Upgrades do not save over each other.

6. Check each converted EXM file in EZConfig Editor.

Note: Even though conversion is complete, you have not yet upgraded your terminal! The old INI files remain in their 
original location on the terminal.

Upgrading Dolphin Terminals

Once you approve of the converted EXM files, you must transfer them to the Dolphin terminals manually. 

1. Delete the old INI files stored in the terminal.

2. Follow the steps for installing an upgrade on a Dolphin terminal (see Installing an Upgrade on the 
Terminal on page 1-8) but don’t cold boot yet.

Note: You want to install an upgrade to make sure that you have the latest versions of AutoInstall.exe, 
Autorun.exe, and EZConfig Editor on the terminal. 

3. Transfer the new converted EXM files to the terminal and say yes when you are asked to replace the 
existing files.

4. Cold boot the terminal. The new, converted EXM files install during AutoInstall.
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EZConfig Editor on the Terminal

EZConfig Editor on the terminal edits and creates EXM files in the terminal and contains the same basic 
functionality as the editor on the workstation. 

Accessing EZConfig Editor

Tap Start > Power Tools > EZConfig Utilities .   

The EZConfig Utilities window provides access to both the EZConfig Editor and the EZConfig Client (see 
page 2-34) as well as the EXM files on the terminal. 

Opening EXM Files

• Tap directly on an EXM file to open it in EZConfig Editor.
• Tap the EZConfig Editor icon to open EZConfig Editor. (Then tap File > Open to open an EXM file.)
• In File Explorer, navigate to an EXM file and tap once on the file  to open it in EZConfig Editor. 

The menus contain the same options as the 
menus in EZConfig Editor on the workstation.

Sections appear in the top half of 
the window.

Keys appear in the bottom half of the 
window. 
Enabled keys have a checkmark.
Disabled keys have a blank box.

Disabled sections appear in gray.
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Available Menus

The menus in the Command bar contain the same items as the menus in the EZConfig Editor on the 
workstation.

File Menu For details, see File Menu on page 2-3.

Note: The one difference in the file menus is that you cannot generate bar codes from 
EXM files on the terminal.

Edit Menu The Edit menu pops up when you tap and hold on a section or key. 
For details, see Edit Menu on page 2-4. 

View Menu This menu enables you to view the locked icon over locked section folders.

Tools Menu For details, see Tools Menu on page 2-5.

Editing Sections

Modifying Text

To edit a section name or description, you have three options: 

1. Select the section and tap Edit > Modify.
Select an item and press the ENTER key.
Tap and hold on the section name, then select Modify on the Edit menu that pops up. 

2. All three options open the Edit Section window. 

3. Tap inside the Name or Description fields and edit the text.
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4. Tap OK to save changes. (You can also press the ENTER key.)
Tap Cancel to close the window without changes.

Moving Sections

You cannot drag and drop to move sections in the tree. Use the Cut, Copy, Paste, and Paste as Child 
items on the Edit menu to move sections.

Note: The Paste function pastes sections at the same level they were cut by default.

Editing Keys

Modifying Text

To edit a key’s name, value, or description, you have three options:

1. Select the key and tap Edit > Modify,
Select the key and press the ENTER key, OR
Tap and hold on the key’s name, then select Modify on the Edit menu that pops up. 

All three edit options open the Edit Key window. 

2. Tap inside the Name, Value or Description fields and edit the text.

3. Tap OK to save changes. (You can also press the ENTER key.)
Tap Cancel to close the window without changes.

Moving Keys

You cannot drag and drop to move keys. Use the Cut, Copy, and Paste as Child items on the Edit menu 
to move keys.
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Launching Associated Applications
The Tools menu contains an item named Launch Associated App.

Launch Associated App is enabled only when there is an application associated with the EXM file. 
Selecting this item automatically saves the open EXM file and launches the associated application while 
the EXM file remains open.

To see the associated application, tap File > Properties. 

The Path field contains the launch location of the application.
The Args field contains any command line arguments to execute when the application launches. 

For more information about associating applications, see Associating Applications on page 2-16.

Example 1: You’ve saved changes to an open DeviceConfig.exm file. 

To apply those changes immediately, tap Tools > Launch Associated App. Because the 
DeviceConfig.exm file is associated with DeviceConfig.exe by default, DeviceConfig launches and 
applies the settings in the DeviceConfig.exm file.

Example 2: You’ve saved changes to an open registry document. 

Because registry documents are always associated with EZConfig Client, tapping Tools > Launch 
Associated App updates the registry. EZConfig Client always updates the registry when launched 
from an EXM file that is a registry document.

Example 3: You’ve saved changes to an open ScanWedge.exm file.

And that ScanWedge.exm file has the following parameters as the associated application:
Path: \program files\power tools\scanwedge.exe
Args: /restart
Tapping Tools > Launch Associated App refreshes ScanWedge with the new settings.
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EZConfig Client

EZConfig Client decodes bar codes created in EZConfig Editor and deploys the data in the terminal. In 
addition, if the EXM file in the bar code is associated with an application, EZConfig Client launches that 
application, which then processes the decoded data. 

EZConfig Client decodes bar codes with 40-bit and 128-bit encryption.

Storage Location

The EZConfig Client executable is stored in the \IPSM folder.

For upgrades, EZConfig Client is located in the IPSM image installed on the workstation. This EXE must 
be copied and pasted into the \IPSM folder on the terminal. For more information, see Installing an 
Upgrade on the Terminal on page 1-8.

Using EZConfig Client
1. On the Dolphin terminal, tap Start > Power Tools. The Power Tools Main Window (see page 1-2) 

opens.

You can scan the first bar code from the Power Tools main window by pressing the SCAN key; see 
page 2-36 for details.
EZConfig Client can also be launched with a HotKey from any window; see page 2-37 for details.

2. Tap EZConfig Utilities  > EZConfig Editor . The EZConfig Client window opens.

3. Point the terminal at the first EZConfig Editor bar code, then press the SCAN key.

4. EZConfig Client decodes the bar code. 
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If there is only one bar code in the package, EZConfig Client deploys the package.
If there is more than one bar code in the package, EZConfig Client decodes the bar code, records 
that one bar code has been read, and waits for the next scan. 

5. Scan all the bar codes in the package. Bar codes can be scanned in any order.

6. When all bar codes in the package have been scanned, the EZConfig client deploys the data. 

Note: If the EXM file is programmed to launch an application such as ScanWedge, a window pops up informing you 
of initialization.

EXM File Processing

After decoding, EZConfig Client saves EXM files to the location in the terminal selected in the Remote 
Path (page 2-23) field on the Bar Codes Tab (page 2-22). (If the Temporary, page 2-25, option is selected 
in the bar code, EZConfig Client does not save the EXM file.)

There are two types of EXM files: configuration documents and registry documents. EZConfig Client 
processes each type of file differently.

Configuration Documents
If the EXM file was associated with an application, EZConfig Client launches and deploys the 
data to that application for processing.
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Note: DeviceConfig.exm must be associated with DeviceConfig.exe to be processed on the terminal 
appropriately. After decoding the bar code, EZConfig Client deploys the data to 
DeviceConfig.exe, which applies the settings to the terminal. 

Registry Documents
Registry documents are always associated with EZConfig Client. The Execute option 
(Execute, page 2-16) determines whether the registry is updated or not. If Execute is selected, 
EZConfig Client updates the registry immediately after decoding the bar code.

Multiple Bar Codes

Some EXM files generate more than one bar code. If multiple bar codes were generated, EZConfig Client 
recognizes that there is more than one bar code in the package and tracks each bar code scanned and 
decoded. Bar codes can be scanned in any order, but EZConfig Client does not deploy the data until all 
the bar codes in the package have been scanned.

EZConfig Client Window

Scanning Bar Codes Directly from the Power Tools Main Window

When the Power Tools or Demos main windows are open, press the SCAN key and:

• If there is only one bar code in the package, EZConfig Client decodes and deploys the bar code without 
opening the EZConfig Client window.

• If there are multiple bar codes in the package, EZConfig Client decodes the first bar code and opens 
the EZConfig Client window showing that one bar code in the package has been scanned.

Field Description

Package ID This is the ID of the entire package. 
EZConfig Editor assigns an ID to bar code packages when creating the bar code. 

Status This field displays the decode status of the bar codes scanned so far. 
If there is more than one bar code in the package, this field acts as a decode 
counter. 
The Status field displays:

• How many bar codes have been scanned and 
• How many bar codes are in the package

Read # box This box displays the list of bar codes scanned and decoded.

Accept Unsecure This option allows EZConfig Client to scan bar codes that are not encrypted.
Note: By default, all bar codes created in EZConfig Editor are encrypted.
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Launching EZConfig Client with a HotKey

Pressing ALT + SCAN launches EZConfig Client from any application window after you activate the 
HotKeys Power Tool; see HotKeys on page 6-5.

ScanWedge

Bar code decoding in EZConfig Client is compatible with ScanWedge. You can set ScanWedge to pass 
bar code information to EZConfig Client for further processing. 

For details, see Accept EZConfig on page 5-4.

Command Line Arguments

/%filename Executes the EXM file; this is the default entry.

/q Quiet mode

/s Full screen

/o No menu

/e Exit if first scan fails to deliver a valid bar code

/u Accept (decode) unsecure bar codes
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3

DeviceConfig
Overview

DeviceConfig consists of the DeviceConfig.exe and the DeviceConfig.exm file located in the \IPSM 
folder. DeviceConfig.exe looks for and applies the settings in the DeviceConfig.exm file.

DeviceConfig.exm File

The DeviceConfig.exm file contains terminal configuration settings. Because this file is stored in the 
\IPSM folder, its configuration settings persist through cold boots and should be considered system 
defaults. 

Enabling DeviceConfig Functionality

By default, all sections except the About Section (see page 3-9) are disabled, which means that the key 
values are not applied to the terminal. To use the DeviceConfig.exm file to configure the terminal, enable 
the sections and keys required by your configuration in EZConfig Editor (page 2-2) on the workstation or 
EZConfig Editor on the Terminal (page 2-30). 

Autorun 

Autorun (see page 4-1) launches DeviceConfig.exe, which applies the DeviceConfig.exm settings, then 
launches a cold boot followed by a warm boot. 

Bar Code Delivery

When the DeviceConfig.exm file is delivered to the terminal via bar code, EZConfig Client launches 
DeviceConfig.exe automatically after decoding. DeviceConfig.exe then applies the settings in 
theDeviceConfig.exm file in the terminal. For more information, see Creating Bar Codes (page 2-21) and 
EZConfig Client (page 2-34).

The DeviceConfig.exm file must be associated with DeviceConfig.exe for EZConfig Client to launch 
DeviceConfig.exe after decoding the bar code. In EZConfig Editor, the associated application path must 
be

\IPSM\deviceconfig.exe

For more information, see Associating Applications, page 2-16. 

Settings in the WLAN Supplicant
Many settings in the DeviceConfig.exm file match the settings in the WLAN Supplicant on the terminal 
that allow the user to enter and save the same values. If a user changes a setting in the WLAN Supplicant, 
that setting is applied but stored in RAM memory and erased during the next cold boot. During the next 
cold boot, Autorun launches DeviceConfig, which then re-applies the settings in the DeviceConfig.exm 
file.
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DeviceConfig.exm Sections and Keys

The sections and keys in the DeviceConfig.exm file are locked, which means that you can change values 
but not names or descriptions.  

Connections Section
The Connections section contains child sections that set communication parameters on the terminal.

Beam Section

The Beam section enables and disables the IrDA port. 

Radio Manager Section
In the Radio Manager, typically, you would enable the radio in the WiFi section, enable DHCP in the 
TCPIP section, then configure the radio settings in the Security\Supplicant\ProfileX or 
Security\NonSupplicant section. 

Section Name Description See Page

Connections Configures communication parameters. There are child sections 
that configure the IrDA port, the on-board radios, and the 
ActiveSync connection.

3-2

System Configures basic system settings. 3-9

Applications Configures software applications. 3-10

WiFi Section

The keys in the WiFi section control the settings of the WLAN radio. 

Key Description Default 
Value

Available Values

Enable Enables and disables the WLAN radio. 1 0=Disabled
1=Enabled; if enabled, the GSM radio 

section is disabled automatically

PowerMode Specifies the power save mode. 1 1=Disable; radio is powered 
constantly (power save mode is 
not used)

2=Always Enable; power save mode 
is used

3=Auto Enable; EPSParm key 
defines radio vs. battery 
performance

EPSParm When PowerMode is set to 3 (Auto 
Enable), this parameter specifies radio 
vs. battery performance. 

N/A X=A value between 1 and 10, where:
1=Best Radio Performance 

(Minimum)
10=Best Battery Life (Maximum)
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DriverName Specifies the name of the radio driver. 
This string must match the name of the 
driver for the current device.

N/A X=A value in the drop-down list; radio 
driver names are terminal-specific. 
Different Dolphins have different 
radio drivers.

TCPIP Section

The keys in the TCPIP section determine how the radio handles IP addresses. 

Key Description Default 
Value

Available Values

DHCP Enables and disables DHCP (Dynamic 
Host Configuration Protocol). 

1 0=Disabled; the static IP address in 
the IPAddress key is used for the 
radio interface.

1=Enabled; the IP address for the 
radio interface is requested from a 
DHCP server. 

The remaining keys need to be set when DHCP is disabled. When DHCP is enabled, these numbers are 
dynamically requested from a DHCP server.

IPAddress Static IP address for the radio 
interface. 

N/A Static IP address

SubnetMask SubNet mask for the static IP address. N/A Subnet mask address

DefaultGateway Default gateway for the static IP 
address.

N/A Gateway address

DNS Domain name server for the static IP 
address. 

N/A Domain name server address

Domain Domain name for the terminal N/A Terminal’s domain name

WINS Windows name server. N/A Windows name server address

WiFi Section

The keys in the WiFi section control the settings of the WLAN radio. 

Key Description Default 
Value

Available Values
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Security Section

The Security section has no keys and one child section named “Supplicant,” which contains several 
profile subsections. 

Supplicant Section
The Supplicant section consists of a number of child sections. The default child section is named Profile1 
and contains all the keys necessary to create a configuration profile for the WLAN radio. 

To create multiple radio configurations, copy the Profile1 section and paste it at the root level of the 
Supplicant section. Then, rename that profile and configure the keys according the desired network 
configuration. Each child section name is arbitrary, but each name must be different.

The Supplicant section contains one key named ActiveProfile. Type in the Value equal to name of one 
of the desired profile child sections. 

When DeviceConfig is activated on the terminal, the terminal will apply the settings in the profile specified 
in the ActiveProfile key. If the ActiveProfile key does not have a matching profile, the radio will be enabled 
by DeviceConfig but no specific radio configuration will be activated, which means that the radio will not 
connect to your network. 

Profile Subsections
Each Profile subsection contains the keys that configure the radio connection from the terminal to the 
network.

Key Description Default 
Value

Available Values

SSID The service set identifier used to connect to 
network; usually the network name of the 
access point or peer station.

N/A X=Your network’s SSID
Any=Connect to any network

Assoc. Mode The general association mode (sometimes 
called “authentication”) of the radio.

N/A • None (no authentication or 
encryption)

• WEP
• IEEE 802.1X 
• WPA-Personal (PSK)
• WPA-Enterprise (EAP)
• WPA(2)-Personal (PSK)
• WPA(2)-Enterprise (EAP)

Encryption The encryption mode available for the 
association mode.

N/A Open & Shared (WEP)
TKIP, AES-CCMP, TKIP & 
CCMP (WPA)
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EAP Method Available EAP methods for IEEE 802.1X and 
WPA(2)-Enterprise (EAP) association modes.

N/A • LEAP
• PEAPv0-MSCHAPV2
• PEAPv1-MSCHAPV2
• PEAPv1-GTC
• PEAPv1-TLS
• FAST-MSCHAPV2
• FAST-GTC
• FAST-TLS
• TLS
• TTLS-MD5
• TTLS-MSCHAPV2
• TTLS-GTC

PSK Enter the private share key for the WEP 
association mode.

N/A User-defined

Identity This is the 802.1X identity supplied to the 
authenticator. The identity value can be up to 
63 ASCII characters and is case-sensitive. 

N/A User-defined

Password This is the password used for MD5-Challenge 
or EAP authentication. It may contain up to 63 
ASCII characters and is case-sensitive. 
Asterisks appear instead of characters for 
enhanced security.

N/A User-defined

Anonymous ID Enter the anonymous ID. This ID creates a 
tunnel through which the real ID (as entered in 
the Identity field) can pass. 
For additional security, make this ID different 
than the one entered in the Identity field. 

N/A User-defined

Tunnel PAC 
Machine PAC

For EAP-FAST, a one-time provisioning 
exchange establishes a shared secret, called 
a Protected Access Credential (PAC) Key. 
That PAC Key is used for all subsequent 
authentications.

N/A Enter the address on the 
Dolphin terminal of either PAC 
(tunnel or machine).
Note: The PACs must be 

located on the Dolphin 
terminal!

Provisioning Provisioning refers to service activation and 
involves programming various network 
databases with the customer's information.

N/A • No Provisioning
• Anonymous
• Authenticated
• Anonymous + Authenticated

CA and/or 
Client 
Certificate

CA certificates are any certificates created by 
a certified authority (CA).
Client certificates contain information that 
identifies the user, as well as information 
about the organization that issued the 
certificate. This ensures that you can encrypt 
data end-to-end.

N/A Enter the address on the 
Dolphin terminal of either 
certificate (CA or Client).

The certificates must be 
located on the Dolphin 
terminal!

Profile Subsections
Each Profile subsection contains the keys that configure the radio connection from the terminal to the 
network.

Key Description Default 
Value

Available Values
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Private Key Private keys are used with certain types of 
EAP authentication.

N/A Enter the address on the 
Dolphin terminal of the private 
key.
The private key must be 
located on the Dolphin 
terminal!

Priv Key 
Password

Private keys can be locked by passwords. N/A Enter the password that 
unlocks the private key.

WEP Key 
Mode

Mode being used by the WEP keys (in Key1–
Key4 keys).

Key validation occurs when DeviceConfig is 
loaded on the terminal (often during 
AutoInstall), not when you save the 
DeviceConfig.exm file. 

N/A ASCII uses all alpha numeric 
characters.

HEX uses only numerics and 
A-F.

Valid lengths are as follows:
• 64-bit ASCII=5
• 128-bit ASCII=13
• 64-bit HEX=10
• 128-bit HEX=26

WEP Key1–
Key4

In fields Key 1—Key 4, enter the specific key.
The format of each key must match the key 
length type selected in the WEP Key Mode 
key. 
To use dynamic keys in your configuration, 
leave all the key fields blank.

N/A User-defined

Active Key Enter the number of the key that you want to 
be active in this configuration.

N/A 1, 2, 3, or 4

Profile Subsections
Each Profile subsection contains the keys that configure the radio connection from the terminal to the 
network.

Key Description Default 
Value

Available Values
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Bluetooth Section  

Bluetooth Default Printer Values

In general, to establish a printer as a Bluetooth Favorite Device, you must establish the printer as a 
Bluetooth Favorite on the terminal. The problem is that Bluetooth Favorite settings are stored in RAM 
memory and therefore erased during each cold boot. The Default Printer section stores these settings 
permanently in the DeviceConfig.exm file so the printer remains a Favorite after a hard reset.

Furthermore, you can distribute a DeviceConfig.exm file with the printer settings to multiple terminals. 
After DeviceConfig.exe applies the settings in the DeviceConfig.exm file (launched manually or after a 
hard reset), the printer is set up as a Favorite automatically, without any special configuration to each 
terminal.

After you have established a printer as a Bluetooth Favorite Device on an individual terminal, obtain the 
values for the Address and Service keys from the registry in RegEdit.

Obtaining the MAC Address

After you have set up the Bluetooth printer on the terminal, use RegEdit to find the printer values.

1. Tap Start > Power Tools > RegEdit .

2. Navigate to HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Bluetooth > Device > [MAC 
Address] .

3. Copy the name of the subsection; this is the MAC address of the printer.

4. Enter this address in the Address key in the Bluetooth > DefaultPrinter section of the 
DeviceConfig.exm file.

  

The keys in this section enable the Bluetooth radio and configure a Bluetooth printer as a Favorite.
If there is no Bluetooth radio installed in the terminal, disable this section.

Key Description Default 
Value

Available Values

Enable Enable and disable the Bluetooth radio.
This is the top level of the tree; printer 
settings are in a child section.

1 0=Disable
1=Enable; the GSM radio is 

disabled automatically

Default Printer This is a child section that configures a Bluetooth printer as a Favorite Bluetooth Device. By 
entering the necessary information from the Bluetooth printer in the DeviceConfig.exm file, 
and then distributing that file to a group of terminals, you can bypass the manual process of 
setting up a printer as a Bluetooth Favorite on each terminal.

Address Bluetooth MAC Address of the printer; see 
Obtaining the MAC Address on page 3-7.

N/A MAC Address

COMPort Number to assign to the virtual COM Port. 
Note: It’s best to leave this value as 0.

0 Min=0
Max=9

DeviceName Friendly name of the printer. N/A Printer name
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GSM Section

If there is no GSM radio installed in the terminal, disable this section.

Key Description Default 
Value

Available Value

Enable Enables and disables the GSM radio. 0 0=Disable
1=Enable; when enabled, the 

WLAN radio turns off 
automatically.

APN Enter the Access Point Name (APN) for 
the GPRS network.

Empty APN value

IPAddress Enter the IP Address. Empty Empty=GSM uses DHCP (server-
assigned IP address)

X=IP address

Protocol Enter the protocol to use. IP Protocol type

Username Enter the username for the GPRS 
connection.

Variable Empty=Disabled
0=Disabled
X=The username for the GPRS 

connection.

Password Enter the password associated with the 
username for the GPRS connection.
Note: This key is encrypted; see 

Encrypted on page 2-14.

Variable Empty=Disabled
0=Disabled
X=The password for the GPRS 

connection.

ActiveSync Section

The ActiveSync Section configures the terminal’s ActiveSync connection parameters.

Key Description Default 
Value

Available Values

AutoConnect Enables and disables the ActiveSync 
connection when the terminal first 
connects to the communication 
peripheral.

1 0=Disable ActiveSync connection
1=Enable ActiveSync connection

Connection Specifies the connection type and baud 
rate.

‘USB 
Connection

`USB Connection
`115200 Default
`19200 Default
`38400 Default
`57600 Default
Note: These values must be typed 

in exactly as they appear 
here.
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System Section
The System section contains child sections that configure various system settings. For specifics on each 
sections and their keys, refer to the Description sections in the DeviceConfig.exm file itself.

About Section

The About section sets a unique device name and description for the terminal. 
By default, this section is enabled and applied to the terminal after each cold boot. 

Device ID Tab

The values of the DeviceName and DeviceDescription keys appear in the Device name and 
Description fields on the Device ID tab on the terminal. 

On the Dolphin terminal, tap Start > Settings > About > Device ID tab. 

Note: ActiveSync recognizes the Device name and Description from this applet.

DeviceName Restrictions
• The DeviceName must begin with a letter.
• The DeviceName cannot exceed 15 characters in length.
• Any text outside brackets (“[xxxx]”) will appear as text in the Device name field.

Content What appears in the Device name field…

[SERIALNUMBER] The terminal’s serial number pulled dynamically from the kernel. 
This is the serial number that appears in SysInfo (see page 6-15) as the Terminal Serial 
Number (see page 6-17).

[MODELNUMBER] The terminal’s model number pulled dynamically from the kernel.
This is the serial number that appears in SysInfo (see page 6-15) as the Model Number 
(see page 6-17).

  

Key Name Description Default Value Available Values

DeviceName Sets the name of the device. ID
[SerialNumber]

See DeviceName Restrictions on 
page 3-9.

DeviceDescription Sets the device description. N/A User-defined; however, the description 
cannot exceed 15 characters in 
length.
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Split Restrictions

The percentage split you are able to enter is specific to each terminal’s memory configuration. Min/max 
ranges can be retrieved from SysInfo or SetRAM. 

• See RAM INFO on page 6-20.
• See SetRAM Window on page 11-2.

AutoInstall

When the RAM section is enabled on Windows Mobile 6.0-based devices, AutoInstall.exe launches 
DeviceConfig in a mode that checks only the memory allocation in the RAM section of DeviceConfig.exm 
against the terminal’s current memory allocation. 

If there is a discrepancy and the Prompt key in the RAM section is enabled, a prompt appears asking if 
you want to apply the memory allocation in DeviceConfig. If there is a discrepancy and the Prompt key in 
the RAM section is disabled, the memory allocation in DeviceConfig is applied.

Note: AutoInstall.exe launches the RAM section of DeviceConfig prior to installing cab files. No other DeviceConfig 
settings are applied at this time. 

Applications Section
The Applications section configures specific software applications installed on the terminal.

Internet Explorer Section

The Internet Explorer section defines the home page for Pocket® Internet Explorer.

RAM Section

The RAM section allows you to provision RAM memory on Windows Mobile 6.0-based terminals.

Key Description Default 
Value

Available Values

Split This is the RAM split percentage; the 
percentage that will be allocated to 
the filesystem.

50 Min=0
Max=100 
See Split Restrictions on page 3-10. 

Prompt Determines whether the system 
prompts you before the memory is re-
allocated.

1 0=Disabled; you will not be prompted. 
DeviceConfig’s settings are applied 
automatically.

1=Enabled; you are prompted before the 
memory is re-allocated.

Note: If the allocation is the same, nothing 
will occur.
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MobiConrol Section

If the terminal includes the MobiControl Bootstrap Agent (/IPSM/MCBootstrapAgent.exe), then 
DeviceConfig can be used to configure the terminal to connect to a MobiControl Server and download the 
appropriate agent to the device. 

This section is disabled by default and should only be enabled when configuring the device to connect to 
the MobiControl Server for the first time.

The root level of the MobiControl section contains the main ConfigPath. By default, this is 
“\IPSM\MCBootstap.ini.”

Key Description Default 
Value

Available Value

Device Subsection

NameType Mandatory
The name the device will register as on 
the server.

1 1=Use Device ID as the device name
2=Use custom name

DeviceName Mandatory when NameType is set to 2. 
This is the custom name of the device.

N/A X=Custom name can contain 
customized macros; e.g., 
“%AUTONUM%” 

DeviceClass Optional
The rule tag of the Add devices rule. 
When the rule tag is not specificed here, 
the device will use an Open, Add 
devices rule.

N/A X=The specific rule tag. Please refer 
to MobiControl Help on how to 
create an open rule.

DeviceIDType Optional
Specifies what is used for the device ID.

3 1=HAL Old Device ID 
2=HAL New Device ID 
3=HAL UUID 
4=User Defined 
5=Server specified 
6=MAC

Info Subsection

SiteName Mandatory
This is the site name of the MobiControl 
Server

N/A X=MobiControl Server name

Method Mandatory
The installation method. 

1 1 (Honeywell standard)

Comm Subsection

Broadcast Optional
Enable broadcasting for discovering 
server addresses. 

0 0=Disable
1=Enable

RetryDelay Optional
Retry delay time when connection to the 
server fails. 

30000 X=Milliseconds

Connection Subsection

DeploySvr1 Mandatory when Broadcast key is 
disabled.
This is the MobiControl Server IP 
address and port.

N/A X=IP address:port
e.g., 192.168.1.238:5494
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Command Line Arguments

/q Quits the program; this command line in the Args field of the Associated Application window 
stops the confirmation message from appearing after DeviceConfig.exe finishes 
processing.

/boot Reboots DeviceConfig.exe
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Launching DeviceConfig.exe Manually

DeviceConfig.exe does launch automatically after each cold boot. However, if you make changes to the 
DeviceConfig.exm file that you want applied in the terminal immediately, manually launch 
DeviceConfig.exe.

1. Tap Start > Power Tools > EZConfig Utilities > DeviceConfig.exm. 

2. Tap Tools > Launch Associated App.

3. The settings in the DeviceConfig.exm file are saved and applied to the terminal configuration by 
DeviceConfig.exe.

4. A message appears confirming that DeviceConfig.exe has finished processing the 
DeviceConfig.exm file.

Temporary Option for Bar Code Deployment

The Bar Codes Tab (see page 2-22) in EZConfig Editor contains a Temporary option (see page 2-25) 
that, when selected during bar code creation, applies the settings in the DeviceConfig.exm file 
temporarily, which means until the next cold boot.

In the terminal, EZConfig Client deploys the DeviceConfig.exm file and launches DeviceConfig.exe, which 
applies the settings in the DeviceConfig.exm file as usual. However, when the Temporary option is 
selected, the DeviceConfig.exm file is not saved after processing is finished. The original file is preserved 
instead, and its settings will be restored during the next cold boot.

Select this option when you want establish a temporary configuration in the Dolphin (such as access to a 
specific network in a facility) without changing the default configuration. 
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4

Autorun and AutoInstall
Overview

Startup is the launch sequence when a Dolphin terminal is booted. 
There are two startup Power Tools:

1. Autorun (see page 4-1)

2. AutoInstall (see page 4-8)

Autorun

Autorun specifies the software applications to launch after each hard reset. Autorun is located in the 
\IPSM folder and consists of an Autorun.exe that is programmed by the Autorun.exm File (page 4-1).   

During startup, after a soft or hard reset, the operating system looks for and launches 
\IPSM\Autorun.exe. If the Autorun.exe is configured (by Autorun.exm) to launch an application, that 
application launches when Autorun.exe launches. Autorun can launch up to 32 applications or utility 
programs after each hard reset.

Note: The Autorun.exm file allows applications to be launched based on conditional situations, including the return 
code of another application launched previously and specific characteristics of the Dolphin terminal itself.

Autorun.exm File
The Autorun.exm file has a multi-level tree structure. There are two top level sections: Settings and 
Programs.

Settings Section

The Settings section stores general Autorun settings; see Settings Section Keys on page 4-2.

Programs Section

The Programs section contains many child sections and determines the sequence of events at startup, 
including which programs launch and when. 

Program Sections and Launch Sequence
Each section is a program to launch at startup. The sequence of sections determines the launch 
sequence on the terminal; the terminal reads this file consecutively. To change the launch sequence, 
move the section up or down in the list; see Working with Sections (page 2-7).

Enabling and Disabling Sections
If you don’t want to the application to launch at startup, you can delete the section. However, program 
sections contain settings you’ll want to keep when adding that same application back to startup. To keep 
the program section in the file for future reference, disable the program section instead of deleting it. 
Disabled sections appear in gray.
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When processing files, the terminal behaves as though disabled sections are not there and moves on to 
the next enabled section.

Settings Section Keys

Note: This section and most of its keys are locked, which means that you can change the value but not the name 
or description. 

Programs’ Subsections

Here are a few of the standard child sections of the Programs section:

Note: Other subsections launch the executable entered in the Program (see page 4-3) key.

Key Function Default Available Values

Version Stores the EXM file version. 22 You cannot modify this 
value!

ByPassKey Defines the key that can be pressed to bypass 
Autorun

42=SCAN key

StartMenu Enables and disables the Start menu during 
Autorun

1 0=Disable; the Start 
menu is disabled 
during Autorun.

1=Enable; the Start 
menu is enabled.

Debug Controls the debug function at AutoInstall. 0 0=Disable
1=Enable, an 

autorun.log file is 
created in the 
\IPSM folder.

TestMode Runs the terminal in test mode and tests the 
functionality of AutoInstall. This is a diagnostic tool.
When enabled, applications stored in the 
AutoInstall folder, including the radio drivers, are 
not loaded during startup. 

0 0=Disable
1=Enable

EZConfigKey Specifies a key that launches EZConfig Client 
before Autorun starts processing the Programs 
section; i.e., before Autorun starts launching 
programs.

9=Tab 
key

Empty=You must launch 
EZConfig Client to 
scan bar codes from 
EZConfig Editor

Section Description

Update Attempts to launch an Update.exe application from the SD (Secure Digital) card, if one exists.

AutoRun 
SC1 & SC2

Attempts to process an Autorun configuration file from the SD card (if one exists); for example, 
to install CAB files from the AutoInstall folder in the SD card. One section applies to cold boots 
and the other to warm boots.

Reset Initiates a warm boot after the cold boot during startup. Do NOT disable the Reset section!
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Keys in Each Programs’ Subsection

Each Programs’ subsection contains or can contain the following keys: 

Editing the Autorun.exm File

Edit Autorun.exm in EZConfig Editor. For details, see Working with Open EXM Files on page 2-7.

Adding a Program Subsection 

To launch at startup, a new program must be a child section of the Programs section.

1. In EZConfig Editor, right click on the Programs section and select Append Child Section.

2. On the Add New Section window, enter the Name and Description and click OK.

3. The new section is added to the bottom of the list.

4. Use the click and drag method to move the section to the desired launch sequence. 
Press and hold the ALT key to make sure that you move the section at the same level. Do not 
append the section to an existing section!

5. Right-click in the key area and select Append Key. You must add all the required Autorun keys; see 
Keys in Each Programs’ Subsection on page 4-3.

Key Function

Required Keys—These keys must be present in each Program subsection.

Program Specifies the command line to execute. This is the location of the program’s 
executable. If you want a Power Tool to launch at startup, enter the location of that 
tool’s EXE here.

Args Specifies the command line arguments to execute at startup.

Wait Determines if Autorun should wait for the program to complete and close before 
continuing to the next program in the sequence. 
• 0=Continue to the next program immediately
• 1=Wait enabled 

StartOption Specifies the startup options for the program. Autorun launches the program only if 
the startup options entered here are met.
• Blank= Always run the program.
• X=See Start Options on page 4-4.

Optional Keys—These are keys you can add but don’t appear in the default file.

PNPID Specifies a card description. This option needs to be entered only when PNPID or 
NONPNPID values are specified in the StartOption key.

DependIndex Specifies the index of a dependent program.

DependExitCode Specifies the required result of the dependent program. If the result of the 
dependent program does not equal the DependExitCode entered here, the current 
program will not be executed at startup.
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6. Save the file and transport it to the terminal.

Copying a File

If you want to copy a file and move it to another location, use AutoInstall and the /copy command line 
argument. For details, see Command Line Arguments on page 4-10.

Sample Autorun Configuration File

A sample Autorun.exm file installs on the workstation to C:\Program Files\Honeywell\Power 
Tools and Demos for WM 6.0\EZConfig EXM Files. 

For more information, see Sample EXM Files on page 2-2.

 

Start Options
Start Options define the required system parameters for a software application to launch. The following 
values can be entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category

DISABLED Never, regardless of other startup options specified. None

COLDBOOT The terminal has performed a cold boot.
Boot type

WARMBOOT The terminal has performed a warm boot.

TOUCH The terminal has a touch screen display installed.
Touch Screen

NONTOUCH The terminal doesn’t have a touch screen display installed.

BATCH The terminal is a batch unit (no RF or internal modem cards installed).

Mobility

RF The terminal has an RF card installed (e.g., Cisco 802.11b).

GSM The terminal has a GSM radio.

BT The terminal has a Bluetooth radio.

MODEM The terminal has an internal modem card installed.

IMAGER The terminal has an imager installed.

Scanner
LASER The terminal has a laser scanner installed.

BLIND The terminal has no laser or imager installed.

ANYSCAN The terminal has either an imager or a laser scanner installed.
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RFON The RF radio is Enabled.

Radio
GSMON The GSM radio is enabled.

BTON The Bluetooth radio is enabled.

RFGSMBTOFF The RF, GSM, & Bluetooth radios are disabled.

29KEY The terminal has a 29-key keyboard.

Keyboard

35KEY The terminal has a 35-key keyboard.

38KEY The terminal has a 38-key keyboard.

43KEY The terminal has a 43-key keyboard.

56KEY The terminal has a 56-key keyboard.

NO_KEY The terminal has a 56-key keyboard.

Start Options
Start Options define the required system parameters for a software application to launch. The following 
values can be entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category
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Multiple options can be specified for each category. For example, you can specify both 35KEY and 
43KEY options to request that the program run in either a 35- or 43-key keyboard terminal. Seperate 
multiple options with commas.

7300 It’s a Dolphin 7300 terminal.

Model

7400 It’s a Dolphin 7400 terminal.

7450 It’s a Dolphin 7450 terminal.

74XX It’s any Dolphin terminal beginning with “74”.

7600 It’s a Dolphin 7600 terminal.

76XX It’s any Dolphin terminal beginning with “76”.

7850 It’s a Dolphin 7850 terminal.

78XX It’s any Dolphin terminal beginning with “78”.

7900 It’s a Dolphin 7900 terminal.

79XX It’s any Dolphin terminal beginning with “79”.

9500 It’s a Dolphin 9500 terminal.

9501 It’s a Dolphin 9501 terminal.

9550 It’s a Dolphin 9550 terminal.

9551 It’s a Dolphin 9551 terminal.

95XX It’s any Dolphin terminal beginning with “95”.

9700 It’s a Dolphin 9700 terminal.

9900 It’s a Dolphin 9900 terminal.

99XX It’s any Dolphin terminal beginning with “99”.

PNPID The terminal has a card installed whose identification contains ALL of 
the strings specified in the PNPID setting.

Expansion Card
NONPNPID The terminal doesn’t have a card installed whose identification contains 

ALL of the strings specified in the PNPID setting.

Start Options
Start Options define the required system parameters for a software application to launch. The following 
values can be entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category
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To ignore a category, don’t specify any of its options.

Applying Startup Options to the Autorun Configuration File

For each category, Autorun validates each startup option specified in the StartOption key. If no specified 
option is valid in a category, Autorun does not execute the program. If at least one of the specified options 
is valid in each category evaluated, the program is executed.

To always execute a program, specify no options in the StartOption key.
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AutoInstall

AutoInstall consists of an AutoInstall.exe that, when launched, installs the cab files in the AutoInstall 
folder. The AutoInstall folder is where you store cab files for software applications if you want them to 
persist through hard resets. 

The AutoInstall program runs according to the settings in the AutoInstall.exm file. 

Program Install Locations
When triggered by a hard reset, the CAB file installs the applications to the directories established in the 
CAB file. For most applications, this means that an EXE for the software application is placed in the 
\Program Files folder.
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AutoInstall.exm
The AutoInstall.exm file controls the behavior and appearance of the AutoInstall window and install 
process. 

Key Function Default 
Value

Available Values

Version This is the current version of the AutoInstall.exm 
file. This key is read-only and cannot be modified.

3 N/A

Debug Enable and disables logging of debug information 
to \IPSM\AUTOINSTALL.LOG. 

0 0=Disabled
1=Enabled

Cancel Enable and disables the Cancel button on the 
AutoInstall window.

0 0=Disabled
1=Enabled

FullScreen Determines if the AutoInstall window runs in full 
screen mode (barring access to other windows).

1 0=Disabled
1=Enabled
2=Autoselects based 

on the operating 
platform.

HaltOnError Sets the behavior of AutoInstall when an error is 
encountered. 

1 0=Log the error and 
continue AutoInstall

1=Halt AutoInstall and 
prompt the user to 
continue or cancel

MaskPassword If a password is entered in the Password key, this 
key determines if that password is masked when 
entered on the screen.

1 0=Disabled
1=Enabled

AutoInstall 
window
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Note: Remember! It’s the Autorun.exm file that determines the programs and install sequence, not AutoInstall.exm.

Command Line Arguments

/copy Add /copy to the Autorun.exm file to automatically move a file from one location to 
another.

Usage:  autoinstall /copy <sourcefilename> <destination>

Example:  autoinstall /copy "/windows/data.mdf" "/storage card/data.mdf"

Password Establishes a password required to halt 
AutoInstall. 

Blank Blank=User can halt 
and exit AutoInstall 
without entering a 
password

X=Password

Key Function Default 
Value

Available Values
4 - 10



5

ScanWedge
Overview

ScanWedge sends data from the decoder, serial port, or IrDA interface to the foreground application as 
keystrokes (as if the data were entered via the keyboard). The foreground application is the open software 
application whose window is currently active on the display. 

As a result, you can review input data in Windows Mobile applications such as Pocket Word, Pocket 
Excel, and Inbox without having to load third-party applications. 

Enabling ScanWedge

Tap the ScanWedge icon once . ScanWedge initializes and enables.

Command Bar Menu

When ScanWedge is enabled, a smaller ScanWedge icon appears in the command bar at the bottom of 
the Today screen. 

Tap this icon to open the command bar menu. 

Enabling ScanWedge at Startup

To run ScanWedge automatically when the Dolphin terminal boots up, 

Add a link to the Scanwedge.exe in the \WINDOWS\STARTUP folder

OR 

Enable the ScanWedge section of the Autorun.exm File (see page 4-1).

Menu Item This item …

Enable Enables and disables ScanWedge without exiting ScanWedge.

Settings Opens the ScanWedge.exm file in EZConfig Editor.

About Opens the About screen for ScanWedge.

Exit Exits ScanWedge. The icon no longer appears in the Command bar.
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Disabling ScanWedge

Navigate to the Power Tools Main Window (see page 1-2) and tap the ScanWedge icon again.

OR

Select Exit on the Command Bar Menu (page 5-1).

Modifying the ScanWedge Configuration File

When ScanWedge is installed, a ScanWedge.exm file is inserted in the \IPSM folder. This file specifies 
configuration parameters for ScanWedge and must be located in the \IPSM directory. Do not move 
ScanWedge.exm!

Use EZConfig Editor on the workstation to modify ScanWedge.exm. For more information, see Working 
with Open EXM Files on page 2-7.

ScanWedge.exm Sections 

Basic Values

In each section, the following values apply (unless otherwise specified in the tables below):

0 = Disable 

1 = Enable

Section Description See Page

Settings Programs general settings for ScanWedge. 5-3

Comm Specifies how the serial (RS-232) port interfaces with ScanWedge. 5-6

Decode Specifies how the decoder/scanner interfaces with ScanWedge. 5-8

Centering Defines the centering window for scanning bar codes when ScanWedge is 
interfacing with the decoder.

5-11

Formatting Defines data formatting functionality. 5-12

Symbologies Defines the symbologies that the scanner can decode and send to 
ScanWedge.

5-17

VK Mapping Defines the virtual key sent to ScanWedge for any decoded ASCII character. 5-20
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Settings Section
The Settings section determines how ScanWedge interprets data from the decoder, serial port, and IrDA 
interface.

0 = Disable    1 = Enable

Settings Section 
Key

Description Default 
Value

Available Values

Version This is the version of ScanWedge 3 You cannot modify this value.

Debug Enables and disables the logging of 
debug information to a 
SCANWEDGE.TXT file. 

0 1=Enable. Debug data is logged 
in a Scanwedge.txt file stored 
in the \IPSM folder.

Sound Enables and disables the audio 
notification for decode/data reception. 
There is one sound for success and 
another sound for an error.

1 0=Disable; no sound on 
decoding.

1=Enable; sound on decoding.

Leds Enables and disables LED notification 
for decode/data reception. 

1 0=Disable; no LEDs on 
decoding.

1=Enable; LEDs on decoding.

DataTerminator
Specifies the 
character to recognize 
as the data terminator 
when receiving data 
from the IrDA interface 
or serial port. 

When the data terminator character is 
received, ScanWedge considers the 
data received as successful, and sends 
the specified prefix key + data 
received + specified suffix key to the 
foreground application. 

Note: The data terminator character 
itself will not be transmitted. If 
required, put this character in the 
suffix. 

13 Set to the desired character. 

This parameter is ignored for the 
decoder. The decoder knows 
when the data ends by itself.

PrefixKeys Defines the ASCII keys to be sent prior 
to the decoded/received data. The 
ASCII keys are converted to virtual 
keys; for conversion parameters, see 
Virtual Key Codes Table on page 5-21. 
This field supports up to 16 ASCII keys; 
data is comma-delimited. 

0
Empty, 
No 
prefix 
sent

For example: 
PrefixKeys=80,82,69,70,73,88

The example listed above would 
cause “PREFIX” to be sent prior 
to any decoded data. 

SuffixKeys Defines the ASCII keys to be sent after 
the decoded/received data. The ASCII 
keys are converted to virtual keys; for 
conversion parameters, see Virtual Key 
Codes Table on page 5-21.

This field supports up to 16 ASCII keys; 
data is comma-delimited.

13
ENTER 
key

For example: 
SuffixKeys=83,85,70,70,73,88,1
3 

The example listed above would 
cause “SUFFIX” and the 
ENTER key to be sent after any 
decoded data. 

PrefixID Specifies the symbology identifier sent 
prior to the decoded/received data.

0 0=No symbology identifier is 
sent.

1=The Code ID is sent.
2=The AIM ID is sent.
3=The SymModifier is sent.
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SuffixID Specifies the symbology identifier sent 
after the decoded/received data.

0 0=No symbology identifier is 
sent.

1=The Code ID is sent.
2=The AIM ID is sent.
3=The SymModifier is sent.

SoundConnect Enables and disables 
• The sound that ScanWedge makes 

when starting up, shutting down, or 
restarting.

• The audio notification when an IrDA 
session is established and closed 
and the serial port is opened and 
closed.

1 0=Disabled 
1=Enabled

Note: Audio notifications for 
errors can’t be disabled.

MessageConnect
This key applies only 
to the IrDA and serial 
ports.

Enable and disables a notification 
message when an IrDA session is 
established and closed and the serial 
port is opened and closed. 

0 0=Disabled
1=Enabled

Accept EZConfig
This key applies only 
to the decoder.

Enables and disables ScanWedge’s 
compatibility with EZConfig Client when 
decoding bar codes. 

1 0=Disabled; ScanWedge 
processes EZConfig 
barcodes as it would any 
other barcode.

1=Enabled; ScanWedge 
recognizes EZConfig 
barcodes and passes them 
on to the EZConfig Client for 
further processing.

Settings Section
The Settings section determines how ScanWedge interprets data from the decoder, serial port, and IrDA 
interface.

0 = Disable    1 = Enable

Settings Section 
Key

Description Default 
Value

Available Values
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SendMode Specifies the method to use when 
sending the decoded message to the 
foreground application. 

Note: This setting affects only the 
decoded message; the prefix and 
suffix are always sent using the 
virtual key method to allow 
navigational functionality.

0 0=Virtual key method: each 
character is sent as a virtual 
keystroke. This method 
works well with almost any 
Windows Mobile application. 

1=Direct Text method: the 
decoded message is sent as 
text directly to the window 
that has the keyboard focus 
in the foreground application. 
This method is faster than the 
virtual key and supports 
barcodes with ASCII 
characters between 1 and 
255 but works only if the 
foreground application uses 
standard Window’s Edit 
controls for user input.

2=Virtual Key (safe) method: 
each character is sent as a 
virtual keystroke using 
PostKeybdMessage(). 
This method only support bar 
codes containing ASCII 
characters and does not 
support VKMapping. This 
method only generates 
WM_CHAR messages, it 
does not generate 
WM_KEYDOWN and 
WM_KEYUP messages.

GoodScanWav Specifies a .wav file played on the 
completion of a successful decode/data 
reception. 

Empty Empty=No .wav file is specified. 
The default beep or sound is 
played. Use the Sound (page 
5-3) key to enable and 
disable all audio notification. 

X=The path to the specific .wav 
file you want played for either 
option. The .wav files should 
be 8-bit, 11KHz, mono, and 
PCM. 

BadScanWav Specifies a .wav file played for an 
unsuccessful decode/data reception. 

Empty

Settings Section
The Settings section determines how ScanWedge interprets data from the decoder, serial port, and IrDA 
interface.

0 = Disable    1 = Enable

Settings Section 
Key

Description Default 
Value

Available Values
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Comm Section
The serial port settings in the Comm section determine the interaction between ScanWedge and the serial 
port.

Comm Section 
Key

Description Default 
Value

Available Values

Enable Enables (or disables) ScanWedge to 
receive and interpret data from the 
serial port. 

0 0=Disabled; no data is received
1=Enabled; ScanWedge receives 

data from the serial port 
(specified in the Port key) as 
keystrokes to the foreground 
application.

AutoConnect Enables or disables the auto-
connection between ScanWedge 
and the serial port. 

0 0=Disabled; ScanWedge opens the 
serial port immediately at startup 
and doesn’t close until 
ScanWedge is closed. This is the 
recommended setting when the 
serial port is port 2 or 3.

1=Enabled; ScanWedge connects to 
the serial port when a power 
source is detected and 
disconnects when the power 
source is removed/not detected.

Port Specifies the serial port to use to 
connect to ScanWedge.
Note: This setting is ignored for Port 4.

The use of port 4/6 is not 
encouraged. 

FlowControl Specifies the flow control method to 
use–software only, hardware only, or 
software and hardware. 
Note: This setting is ignored for Port 4.

4 1=Software (Xon-Xoff)
2=Hardware 
3=Hardware and software 
4=No flow control

BaudRate Specifies the baud rate for the serial 
port.
Note: This setting is ignored for Port 4.

38400 X=The appropriate baud rate.

Parity Specified the parity for the connection.

Note: This setting is ignored for Port 4.

0 0=No parity
1=Odd parity
2=Even parity
3=Mark parity
4=Space parity

DataBits Specifies the number of bits per byte to 
use.

Note: This setting is ignored for Port 4.

8 X=Number of bits per byte

StopBits Specified the number of stop bits to 
use.

Note: This setting is ignored for Port 4.

0 0=1 stop bit
1=1.5 stop bits
2=2 stop bits
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Powerout Enables and disables power out of the 
serial port for ScanWedge specifically. 
General power out settings are 
established in the registry.

The serial port powers out 5V at 
500mA.

0 0=Disabled; do not power out when 
scanning with ScanWedge

1=Enabled; power out when 
scanning with ScanWedge.

2=No change for ScanWedge. This 
means that ScanWedge is not 
altering the default power out 
setting in the registry. The 
terminal defaults to the power-out 
setting in the registry.

EnablePrefixData Enables or disables all prefix data 
received via COM port after a 
successful scan.

All prefix data is defined in the Settings 
Section (see page 5-3).

0 0=Disabled
1=Enabled

EnableSuffixData Enables or disables all suffix data 
received via COM port after a 
successful scan.

All suffix data is defined in the Settings 
Section (see page 5-3).

0 0=Disabled
1=Enabled

Comm Section
The serial port settings in the Comm section determine the interaction between ScanWedge and the serial 
port.

Comm Section 
Key

Description Default 
Value

Available Values
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Decode Section
The Decode section specifies decoder settings when using the decoder with ScanWedge.

ScanWedge Entry Description Default 
Value

Available Values

Enable Enables and disables the decoder for 
ScanWedge. 

1 0=Disabled; decoder is not 
used.

1=Enabled; decoder sends bar 
code data as keystrokes to 
the active window.

Trigger Sets the key used by ScanWedge to 
initiate a scan/decode. The key is 
registered as a system hotkey and 
cannot be registered as a hot key by 
any other applications. 

42 42=OnScan or Scan key

ContScan Enables and disables continuous 
scan. 

0 0=Disabled; trigger key must be 
released between scans.

1=Enabled; data is 
continuously decoded and 
sent to the application while 
the trigger key is depressed.

PowerSave Enables and disables power saving 
mode.

1 1=Enabled; the decoder 
automatically initializes and 
un-initializes as needed. A 
slight delay occurs when the 
trigger is activated.

0=Disabled; the decoder 
initializes when the utility 
starts and un-initializes 
when the utility terminates. 

ScanTimeout Specifies the decode time out in 1/
1000th seconds. If a barcode is not 
decoded within the specified timeout 
an audio and visual notification 
indicates that an error occurred. 

5000 X=Time in 1/1000th of a 
second.

ScanMode Specifies the decode mode. 1 1=Full Omni/Normal
2=ALD (Aggressive Linear 

Decode) mode
4=Quick Omni

LinearRange Specifies the linear search range to 
be used while in ALD mode.   

3 X=Range from 1 to 6.
1 indicates a tight vertical 
range near the aimer. 
6 indicates a vertical range 
of the entire height of the 
imager.
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AimerDuration The number of milliseconds the 
scanner aimer is displayed, after the 
trigger key has been pressed down, 
before attempting to decode a 
barcode.

0
[Decode 
begins 
instantly.
]

Enter times in 1/1000th of a 
second.

AimerDelay The amount of time between scans 
before the aimer turns on again.

500

AimerDurationALR The amount of time the aimer stays 
on. This setting is for an ALR 
decoder.

2000

AimerDelayALR The amount of time between scans 
before the aimer turns on again.
This setting is for an ALR decoder.

500

DefaultEnabledSymbo
logies

Specifies which symbologies should 
be enabled before processing the 
Symbologies section.

See Symbologies Section on page 5-
17.

0 0=Use internal list
1=All symbologies are disabled 

initially. Enable specific 
symbologies in the 
Symbologies section.

2=All symbologies are enabled 
initially. Disable specific 
symbologies in the 
Symbologies section.

EnablePrefixData Enables or disables all prefix data 
received from the decoder after a 
successful scan.
All prefix data is defined in the 
Settings Section (see page 5-3).

1 0=Disabled
1=Enabled

EnableSuffixData Enables or disables all suffix data 
received via decoder after a 
successful scan.
All suffix data is defined in the 
Settings Section (see page 5-3).

1 0=Disabled
1=Enabled

Decode Section
The Decode section specifies decoder settings when using the decoder with ScanWedge.

ScanWedge Entry Description Default 
Value

Available Values
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GoodScanFreq Sound frequency used for play a 
custom good scan beep. 

Note: The Window's "Good Decode" 
sound (if defined in the control 
panel) takes precedence over 
this option.

2749 Variable

Use the up and down arrows to 

change the number 

OR 

Type in the code for the sound 
you want.GoodScanLen Number of milliseconds to play the 

sound as specified in GoodScanFreq 
key.

50

BadScanFreq Sound frequency used for play a 
custom bad scan beep.

Note: The Window's "Bad Decode" 
sound (if defined in the control 
panel) takes precedence over 
this option.

523

BadScanLen Number of milliseconds to play the 
sound as specified in BadScanFreq 
key.

25

Decode Section
The Decode section specifies decoder settings when using the decoder with ScanWedge.

ScanWedge Entry Description Default 
Value

Available Values
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Centering Section
The Centering section determines the centering window for bar code scanning. 

ScanWedge Entry Description Default 
Value

Available Values

CenteringEnable= Enable and disables the decode 
centering window for the decoder.    

0 0=Disabled; centering is 
disabled for ScanWedge.

1=Enabled; bar codes are 
decoded only if they are 
within the centering window 
specified by the rest of the 
keys in this section. 

CenteringTop= Specifies the top coordinate of the 
centering window. 

210 Enter the coordinates in pixels.

CenteringBottom= Specifies the bottom coordinate of 
the centering window.

270

CenteringLeft= Specifies the left coordinate of the 
centering window. 

346

CenteringRight= Specifies the right coordinate of 
the centering window. 

406
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Formatting Section
ScanWedge supports data formatting. 

The Formatting section contains subsections and each subsection supports one data format.

Formatting Subsections

Subsection 
Key

Description Default 
Value

Available Values

Format Specifies data formatting parameters Empty See Available Data Formatting 
Commands on page 5-13.

CodeID Identifies the Code ID that the bar code's 
symbology must have for the format to be 
applied. The Code ID is a single character that 
is case-sensitive; e.g., set CodeID=j to apply 
the format to Code 128 only.

Empty Empty=No Code ID
X=See Code ID on page 5-14.

Length Determines the length the bar code data must 
have for the format to be applied.

Empty Empty=Format applies to any 
length

0=Format applies to any length
X=The length
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Available Data Formatting Commands

These are the data formatting operations applied to the bar code data. The entire command string is 
entered into the Format key.

Command Description

Send Commands

F1xx Send all characters followed by “xx” key or function code, starting from current cursor 
position. 

F2nnxx Send “nn” characters followed by “xx” key or function code, starting from current cursor 
position.

F3ssxx Send up to but not including “ss” character (Search and Send) starting from current 
cursor position, leaving cursor pointing to “ss” character followed by “xx” key or function 
code. 

F4xxnn Send “xx” character “nn” times (Insert) leaving cursor in current cursor position. 

E9nn Send all but the last “nn” characters, starting from the current cursor position. 

Move Commands

F5nn Move the cursor ahead “nn” characters from current cursor position.

F6nn Move the cursor back “nn” characters from current cursor position.

F7 Move the cursor to the beginning of the data string.

EA Move the cursor to the end of the data string.

Search Commands

F8xx Search ahead for “xx” character from current cursor position, leaving cursor pointing to 
“xx” character. 

F9xx Search back for “xx” character from current cursor position, leaving cursor pointing to 
“xx” character.

E6xx Search ahead for the first non “xx” character from the current cursor position, leaving 
cursor pointing to non “xx” character.

E7xx Search back for the first non “xx” character from the current cursor position, leaving 
cursor pointing to non “xx” character. 

Miscellaneous Commands

FExx Compare character in current cursor position to the character “xx.” If characters are 
equal, increment cursor. If characters are not equal, no format match.

EC Check to make sure there is an ASCII number at the current cursor position.If character 
is not numeric, format is aborted.
5 - 13



Note: xx and ss stand for hex values of a character (00-FF), nn for a numeric count (00-99). 

ED  Check to make sure there is a non-numeric ASCII character at the current cursor 
position. If character is numeric, format is aborted.

FBnnxxyy…zz Suppress all occurrences of up to 15 different characters, starting at the current cursor 
position, as the cursor is advanced by other commands. When the FC command is 
encountered, the suppress function is terminated. The cursor is not moved by the FB 
command. nn is a count of the number of suppressed characters in the list and xxyy…zz 
is the list of characters to be suppressed. 

FC  Disables suppress filter and clear all suppressed characters. 

E4nnxx1xx2yy1
yy2…zz1zz2 

Replaces up to 15 characters in the data string with user specified characters. 
Replacement continues until the E5 command is encountered. nn is the total count of 
both characters to be replaced plus replacement characters; xx1 defines characters to 
be replaced and xx2 defines replacement characters, continuing through zz1 and zz2.

E5 Terminates character replacement.

Code ID

Symbology Name Code ID

Australian Post A (0x41)

Aztec Code z (0x7A)

Aztec Mesa Code Z (0x5A)

British Post B (0x42)

Canadian Post C (0x43)

China Post Q (0x51)

Codabar a (0x61)

Codablock F q (0x71)

Code 11 h (0x68)

Code 128 j (0x6A)

Code 16K o (0x6F)

Code 32 Pharmaceutical (PARAF) < (0x3C)

Available Data Formatting Commands

These are the data formatting operations applied to the bar code data. The entire command string is 
entered into the Format key.

Command Description
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Code 39 b (0x62)

Code 49 l (0x6C

Code 93 and 93i i (0x69)

Coupon Code c (0x63)

Data Matrix w (0x77)

EAN·UCC Composite y (0x79)

UCC / EAN-128 I (0x49)

EAN-13 d (0x64)

EAN-8 D (0x44)

Interleaved 2 of 5 e (0x65)

ISBT j (0x6A)

Japanese Post J (0x4A)

KIX (Netherlands) Post K (0x4B)

Korea Post ? (0x3F)

Matrix 2 of 5 m (0x6D)

MaxiCode x (0x78)

MicroPDF417 R (0x52)

MSI g (0x67)

OCR US Money Font, 
MICR (E 13 B) and SEMI Font

O (0x4F)

OCR-A O (0x4F)

OCR-B O (0x4F)

PDF417 r (0x72)

Planet Code L (0x4C)

Plessey Code n (0x6E)

Code ID

Symbology Name Code ID
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PosiCode W (0x57)

Postnet P (0x50)

QR Code s (0x73)

Reduced Space Symbology 
(RSS-14,RSS Limited, RSS 
Expanded)

y (0x79)

Straight 2 of 5 IATA (two-bar start/
stop)

f (0x66)

Straight 2 of 5 Industrial 
(three-bar start/stop)

f (0x66)

TCIF Linked Code 39 (TLC39) T (0x54)

Telepen t (0x74)

Trioptic Code = (0x3D)

UCC/EAN-128 I (0x49)

UPC-A c (0x63)

UPC-E0 E (0x45)

UPC-E1 E (0x45)

Code ID

Symbology Name Code ID
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Symbologies Section
The Symbologies section specifies the settings for each of the symbologies supported by the decoder.

The settings are in the form: 

Symbology Name=Enable(1 or 0), Parm1, Parm2, Parm3, Parm4, Parm5, Parm6, Parm7, Parm8

Where 

• Enable specifies that the symbology is enabled or disabled. 
• Parms1–8 specify the settings for the symbology. 

For more information regarding the individual settings for each of the symbologies, refer to the Honeywell 
Decode API documentation in the SDK documentation.

Symbologies Settings

0=Disabled  1=Enabled

ScanWedge Entry Default Enabled/
Disabled Value

Default Value

Australian Post 0=Disabled 0,0,0,0,0,0,0,0,0

Aztec Code 1=Enabled 1,1,3750,0,0,0,0,0,0

Aztec Mesas 0=Disabled 0,0,0,0,0,0,0,0,0

British Post 0=Disabled 0,0,0,0,0,0,0,0,0

Canadian Post 0=Disabled 0,0,0,0,0,0,0,0,0

China Post 0=Disabled 0,4,80,0,0,0,0,0,0

Codabar 1=Enabled 1,0,0,0,4,60,0,0,0

Codablock 0=Disabled 0,1,2048,0,0,0,0,0,0

Code 11 0=Disabled 0,1,4,80,0,0,0,0,0

Code 128/EAN 128 1=Enabled 1,0,80,0,0,0,0,0,0

Code 16K 0=Disabled 0,1,160,0,0,0,0,0,0

Code 32 0=Disabled 0,0,0,0,0,0,0,0,0

Code 39 1=Enabled 1,0,0,0,0,0,0,48,0

Code 49 0=Disabled 0,1,81,0,0,0,0,0,0

Code 93 0=Disabled 0,0,80,0,0,0,0,0,0
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Coupon Code 0=Disabled 0,0,0,0,0,0,0,0,0

Data Matrix 0=Disabled 0,1,1500,0,0,0,0,0,0

Dutch Post 0=Disabled 0,0,0,0,0,0,0,0,0

EAN-8 0=Disabled 0,1,0,0,0,1,0,0,0

EAN-13 1=Enabled 1,1,0,0,0,1,0,0,0

EAN.UCC Composites 0=Disabled 0,1,300,0,0,0,0,0,0

Interleaved 2 of 5 1=Enabled 1,0,0,4,80,0,0,0,0

ISBT 0=Disabled 0,0,0,0,0,0,0,0,0

Japanense Post 0=Disabled 0,0,0,0,0,0,0,0,0

Korea Post 0=Disabled 0,4,48,0,0,0,0,0,0

Matrix 2 of 5 0=Disabled 0,4,80,0,0,0,0,0,0

MaxiCode 0=Disabled 0,0,1,150,0,0,0,0,0

MicroPDF417 1=Enabled 1,1,366,0,0,0,0,0,0

MSI 0=Disabled 0,4,48,0,0,0,0,0,0

OCR 0=Disabled 0,2,dddddddd,,,,0

PDF417 1=Enabled 1,1,2750,0,0,0,0,0,0

Planet Code 0=Disabled 0,0,0,0,0,0,0,0,0

Plessey 0=Disabled 0,4,48,0,0,0,0,0,0

PosiCode 0=Disabled 0,4,48,2,0,0,0,0,0

Postnet 0=Disabled 0,0,0,0,0,0,0,0,0

QR Code 0=Disabled 0,1,3500,0,0,0,0,0,0

Reduced Space 
Symbology (RSS)

0=Disabled 0,4,74,0,0,0,0,0,0

Symbologies Settings

0=Disabled  1=Enabled

ScanWedge Entry Default Enabled/
Disabled Value

Default Value
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Straight 2 of 5 IATA 0=Disabled 0,4,48,0,0,0,0,0,0

Straight 2 of 5 
Industrial

0=Disabled 0,4,48,0,0,0,0,0,0

TCIF Linked Code 39 
(TLC39)

0=Disabled 0,0,0,0,0,0,0,0,0

Telepen 0=Disabled 0,1,60,0,0,0,0,0,0

Trioptic Code 0=Disabled 0,0,0,0,0,0,0,0,0

UPC-A 1=Enabled 1,1,1,0,0,0,1,0,0

UPC-E0 0=Disabled 0,1,1,0,0,0,0,1,0

UPC-E1 0=Disabled 0,1,1,0,0,0,0,1,0

Symbologies Settings

0=Disabled  1=Enabled

ScanWedge Entry Default Enabled/
Disabled Value

Default Value
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VK (Virtual Key) Mapping Section
The virtual key map settings are located in the VKMapping section in the ScanWedge configuration file. 
The virtual key map settings define the virtual key that will be sent to ScanWedge for any decoded ASCII 
character. 

The settings are in the form:   ASCII Key = Virtual Key, ShiftMode

Where

• ASCII Key is an ASCII value between 0 an 255 (decimal)
• Virtual Key is the virtual key to be sent when the specified ASCII key is decoded
• ShiftMode can have the following values:

• 0=the virtual key is never shifted
• 1=the virtual key must be shifted
• 2=the virtual key needs to be shifted if Caps Lock is off
• 3=the virtual key needs to be shifted if Caps Lock is on

For detailed information about the values in this section, see Virtual Key Codes Table on page 5-21.
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Virtual Key Codes Table

The following table shows the symbolic constant names, hexadecimal values, and keyboard equivalents 
for the virtual-key codes used by Microsoft Windows Mobile 6.0. The codes are listed in numeric order. 

Note: To use these codes in the VKMapping section, the hexadecimal values need to be converted to decimals. 

Virtual Key Codes Table

Symbolic Constant 
Name

Decimal 
Value

Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 

VK_LBUTTON 1 01 Touch screen 

VK_CANCEL 3 03 Control-break processing 

—— 5-7 05-07 Undefined 

VK_BACK 8 08 BACKSPACE key 

VK_TAB 9 09 TAB key 

—— 10-11 0A-0B Undefined 

VK_CLEAR 12 0C CLEAR key

VK_RETURN 13 0D ENTER key 

—— 14-15 0E-0F Undefined 

VK_SHIFT 16 10 SHIFT key

VK_CONTROL 17 11 CTRL key

VK_MENU 18 12 ALT key 

VK_CAPITAL 20 14 CAPS LOCK key 

—— 21-25 15-19 Reserved for Kanji systems 

—— 26 1A Undefined 

VK_CLEAR 12 0C CLEAR key 

VK_RETURN 13 0D ENTER key 

—— 14-15 0E-0F Undefined

VK_SHIFT 16 10 SHIFT key 

VK_CONTROL 17 11 CTRL key 
5 - 21



VK_MENU 18 12 ALT key

VK_CAPITAL 20 14 CAPS LOCK key 

—— 21-25 15-19 Reserved for Kanji systems 

—— 26 1A Undefined 

VK_ESCAPE 27 1B ESC key 

—— 28-31 1C-1F Reserved for Kanji systems 

VK_SPACE 32 20 SPACEBAR key

VK_PRIOR 33 21 PAGE UP key

VK_NEXT 34 22 PAGE DOWN key 

VK_END 35 23 END key

VK_HOME 36 24 HOME key 

VK_LEFT 37 25 LEFT ARROW key

VK_UP 38 26 UP ARROW key

VK_RIGHT 39 27 RIGHT ARROW key 

VK_DOWN 40 28 DOWN ARROW key

VK_SELECT 41 29 SELECT key 

—— 42 2A Original equipment manufacturer 
(OEM)– specific 

VK_EXECUTE 43 2B EXECUTE key

VK_SNAPSHOT 44 2C PRINT SCREEN key for Windows 3.0 and 
later 

VK_HELP 47 2F HELP key 

VK_0 48 30 0 key 

VK_1 49 31 1 key 

VK_2 50 32 2 key 

Virtual Key Codes Table

Symbolic Constant 
Name

Decimal 
Value

Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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VK_3 51 33 3 key 

VK_4 52 34 4 key 

VK_5 53 35 5 key 

VK_6 54 36 6 key 

VK_7 55 37 7 key 

VK_8 56 38 8 key 

VK_9 57 39 9 key 

—— 58-64 3A-40 Undefined 

VK_A 65 41 A key 

VK_B 66 42 B key 

VK_C 67 43 C key 

VK_D 68 44 D key 

VK_E 69 45 E key 

VK_F 70 46 F key 

VK_G 71 47 G key 

VK_H 72 48 H key 

VK_I 73 49 I key 

VK_J 74 4A J key 

VK_K 75 4B K key 

VK_L 76 4C L key 

VK_M 77 4D M key 

VK_N 78 4E N key 

VK_O 79 4F O key 

VK_P 80 50 P key 

Virtual Key Codes Table

Symbolic Constant 
Name

Decimal 
Value

Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
5 - 23



VK_Q 81 51 Q key 

VK_R 82 52 R key 

VK_S 83 53 S key 

VK_T 84 54 T key 

VK_U 85 55 U key 

VK_V 86 56 V key 

VK_W 87 57 W key 

VK_X 88 58 X key 

VK_Y 89 59 Y key 

VK_Z 90 5A Z key 

—— 91-95 5B-5F Undefined 

VK_NUMPAD0 96 60 Numeric keypad 0 key 

VK_NUMPAD1 97 61 Numeric keypad 1 key 

VK_NUMPAD2 98 62 Numeric keypad 2 key 

VK_NUMPAD3 99 63 Numeric keypad 3 key 

VK_NUMPAD4 100 64 Numeric keypad 4 key 

VK_NUMPAD5 101 65 Numeric keypad 5 key 

VK_NUMPAD6 102 66 Numeric keypad 6 key 

VK_NUMPAD7 103 67 Numeric keypad 7 key 

VK_NUMPAD8 104 68 Numeric keypad 8 key 

VK_NUMPAD9 105 69 Numeric keypad 9 key 

VK_MULTIPLY 106 6A Asterisk (*) key 

VK_ADD 107 6B Plus sign (+) key 

VK_SEPARATOR 108 6C Separator key 

Virtual Key Codes Table

Symbolic Constant 
Name

Decimal 
Value

Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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VK_SUBTRACT 109 6D Minus sign (–) key 

VK_DECIMAL 110 6E Period (.) key 

VK_DIVIDE 111 6F Slash mark (/) key 

—— 88 88-8F Unassigned 

—— 146-185 92-B9 Unassigned 

—— 186-192 BA-C0 OEM-specific 

—— 193-218 C1-DA Unassigned 

—— 219-228 DB-E4 OEM-specific 

—— 229 E5 Unassigned 

—— 230 E6 OEM-specific 

—— 231-232 E7-E8 Unassigned 

—— 233-245 E9-F5 OEM-specific 

VK_ATTN 246 F6

VK_CRSEL 247 F7

VK_EXSEL 248 F8

VK_EREOF 249 F9

VK_PLAY 250 FA

VK_ZOOM 251 FB

VK_NONAME 252 FC

VK_PA1 253 FD

VK_EM_CLEAR 254 FE

VK_LWIN 91 5B

VK_RWIN 92 5C

VK_APPS 93 5D

Virtual Key Codes Table

Symbolic Constant 
Name

Decimal 
Value

Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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Command Line Arguments

/restart Forces ScanWedge to process its configuration file (Scanwedge.exm) again, which applies 
changes immediately. If the SoundConnect (see page 5-4) is set to 1 (enabled), an 
ascending connect sound is played on restart.

/quit Shuts down ScanWedge.

VK_LSHIFT 160 A0

VK_RSHIFT 161 A1

VK_LCONTROL 162 A2

VK_RCONTROL 163 A3

VK_LMENU 164 A4

VK_RMENU 165 A5

Virtual Key Codes Table

Symbolic Constant 
Name

Decimal 
Value

Hexadecimal 
Value

Touch Screen or Keyboard Equivalent 
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Additional Power Tools
Overview

This chapter describes the following Power Tools:

Power Tool Icon See Page

BattMon 6-2

InstallerCE No icon 6-4

Hotkeys 6-5

Keyboard Status 6-7

NoSIP 6-9

RASMan 6-10

Reboot 6-13

Suspend 6-14

SysInfo 6-15
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BattMon

BattMon programs the terminal’s LEDs to monitor the charge status of the battery.The LEDs are located 
on the top, front panel of Dolphin terminals. 

To Enable BattMon 

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the BattMon icon once . After activation, BattMon monitors the battery’s charge status. 

When the battery is at 100%, the green LED lights solid green. 
When the battery is charging the green LED flashes.

Note: To start BattMon automatically after each hard reset, enable the BattMon Program section of the Autorun.exm 
File (see page 4-1).

To Disable BattMon 

Navigate to the Power Tools Main Window (see page 1-2) and tap the BattMon icon again.

OR

Select Exit on the Command Bar Menu (page 6-2).

Command Bar Menu

When BattMon is enabled, a smaller BattMon icon appears in the Command bar at the bottom of the 
Today screen.

Tap this icon to open the Command bar menu: . 

Menu Item This item …

Status Displays the battery charge status in percentage.

Enable Enables and disables BattMon without exiting BattMon. 

About Provides version and copyright information for BattMon.

Exit Closes BattMon. The icon no longer appears in the Command bar.
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Command Line Arguments

/quit Shut down BattMon.

/noicon Run BattMon with no icon.

/nosplash Hide the BattMon splash screen.

To Check Battery Power Manually

You can,

Tap the BattMon icon in the Command bar on the Today screen. The Status (page 6-2) menu item 
displays the charge percentage.

OR

Tap Start > Settings > System tab > Power. The Power window opens displaying the current charge 
status of the terminal’s batteries.
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InstallerCE

InstallerCE is a utility that saves CAB files after a manual install initiated by double-tapping on the CAB. 
Normally, when you install a program by double-tapping on its CAB, the CAB file is deleted after 
installation is complete. InstallerCE preserves the original CAB file in its original location.

Location InstallerCE is located in the \Program Files\Power Tools folder.

To Manually Install a CAB File 

1. On the Dolphin terminal, open File Explorer.

2. Navigate to the \IPSM\AutoInstall folder.

3. Double-tap on a CAB file. The program begins installing.

4. If the program is already installed, the system will ask you if you want to re-install it. Click Yes.

5. After installation is complete, notice that the CAB file remains in the AutoInstall folder.
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HotKeys

The HotKeys Power Tool activates the hardware button assignments in the Buttons setting. To start 
HotKeys automatically after each hard reset, enable the HotKeys Program section of the Autorun.exm 
File (see page 4-1).

To Enable HotKeys

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the HotKeys icon once . HotKeys is enabled and the button assignments in the Buttons 
setting are active.

3. Verify the assignment by tapping the button on the keyboard. To see button assignments, see 
Buttons Setting on page 6-5.

Buttons Setting

The Buttons System setting programs hardware buttons to launch applications or execute commands. To 
see the hardware button assignments that HotKeys activates, open the Buttons setting.

1. After HotKeys is enabled, tap Start > Settings > Personal tab > Buttons. 

Note: The buttons that appear on this window are the only buttons that can be programmed in the 
Buttons setting. You cannot add hardware buttons to this window.

2. To change button assignment, tap on the name of the application in the Assignment column and 
select a program or command in the Assign a program drop down list. 

3. Tap OK to save.

To Disable HotKeys

Navigate to the Power Tools Main Window (see page 1-2) and tap the HotKeys icon again.

OR

Select Exit on the Command Bar Menu (page 6-6).
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Command Bar Menu

When HotKeys is enabled, a small HotKeys icon appears in the Command bar at the bottom of the screen.

Tap this icon to open the Command bar menu for HotKeys: .    

Command Line Arguments

/quit Shut down HotKeys. 

/noicon Run HotKeys with no icon.

/nosplash Hide the HotKeys splash screen.

Menu Item Selecting this item …

Settings Opens the Buttons setting. 

Enable Enables and disables HotKeys

About Displays version and description information for HotKeys.

Exit Closes HotKeys. The icon no longer appears in the Command bar.
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Keyboard Status

Keyboard Status indicates whether the keyboard is in alpha, caps lock alpha, or numeric modes. 

Each Dolphin terminal series has keyboards that switch between alpha and numeric modes, often by way 
of a keyboard combination. Keyboard Status displays an alpha-numeric indicator in the Navigation bar 
that tells you if the keyboard is in alpha or numeric mode so that you don’t have to test type in your 
application to find out.  

Keyboard Status is enabled automatically after each hard reset by default. This setting is programmed 
Autorun.exm File (see page 4-1).

Keyboard Status Menu

When Keyboard Status is enabled, the indicator icon appears in the Command bar at the bottom of the 
screen.

Tap this icon to open the Keyboard Status menu for: .

Indicator Keyboard is in …

Alpha mode, lower case (CAPS lock off).

Alpha mode, upper case (CAPS lock on).

Numeric mode.

Menu Item Selecting this item …

About Displays version and description information for Keyboard Status.

Settings Opens the Sounds & Notifications setting.

Enable Enables and disables Keyboard Status.

Exit Closes Keyboard Status. The icon no longer appears in the Command bar.

Navigation Bar Indicator
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Notification Menu 

When Keyboard Status is enabled, a Notification menu appears in the command bar on the Today screen 
that displays the keyboard status when tapped.

Note: You can also tap the icon in the Navigation bar to make this pop-up window appear.

Tap Hide to remove the keyboard status icon from the navigation bar. (The Keyboard Status Power Tool 
will continue to run in the background, and appear in the task tray on the Today screen.) The next time 
you switch keyboard modes

Tap Dismiss to remove the notification menu from the command bar. (If the terminal uses the phone, 
then the Phone menu appears in the command bar instead.)

Accessing the Keyboard Status Power Tool

Keyboard Status is enables after each hard reset by default.

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the Keyboard Status icon once  and Keyboard Status is enabled.
To disable Keyboard Status again.

Command Line Arguments

/debug Log debug output to \IPSMkeyboardstatus.log

/quit Shut down Keyboard Status. 

/noicon Run Keyboard Status with no icon.

/nosplash Hide the Keyboard Status splash screen.

Notification Menu

This icon indicates that 
Keyboard Status is running.
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NoSIP

NoSIP toggles the Soft Input Panel (SIP) between enabled and disabled. When disabled, the SIP does 
not pop up over application windows automatically. In addition, the SIP icon  does not appear in the 
Command bar on application windows.

To Enable NoSIP

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the NoSIP icon once . The SIP should not pop up on application screens.

Note: To disable the SIP automatically after each hard reset, enable the NoSIP Program section of the Autorun.exm 
File (see page 4-1).

To Disable NoSIP 

Navigate to the Power Tools Main Window (see page 1-2) and tap the NoSIP icon again.

OR

Select Exit on the Command Bar Menu (page 6-9).

Command Bar Menu

When NoSIP is enabled, a smaller NoSIP icon appears in the Command bar at the bottom of the Today 

screen . Tap this icon to open the Command bar menu: .

Command Line Arguments

/noicon Run NoSIP with no icon

/nosound Turn off the sound

/nohotkey Disable the NoSIP hotkey

/enable Enable the SIP

/disable Disable the SIP

Menu Item Selecting this item …

Enable SIP Enables the SIP without stopping NoSIP. 
When this item is selected, the indicator in the Command bar changes to 

to indicate that the SIP is now active, even though the NoSIP is still running.

About Displays version and description information for NoSIP.

Exit Disables NoSIP; the icon no longer appears in the Command bar.
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RASMan

RASMan establishes a PPP (Point-to-Point Protocol) connection with a RAS server.

To Enable RASMan

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Click the RASMan icon once . The PPP connection is established according to the settings in 
the RASMan Configuration File (see page 6-11).

Note: To start RASMan automatically after each hard reset, enable the RASMan Program section of the 
Autorun.exm File (see page 4-1).

To Disable RASMan 

Navigate to the Power Tools Main Window (see page 1-2) and tap the RASMan icon again.

OR

Select Exit on the Command Bar Menu (page 6-10).

Command Bar Menu

When RASMan is enabled, the RASMan icon appears in the Command bar at the bottom of the Today 

screen . Tap this icon to open the Command bar menu. 

Menu Item Selecting this item …

Auto Connect This item is selected by default; it means that the terminal is connected to the RAS server via 
PPP.

Connect Re-establishes the PPP connection if it was disconnected.

Disconnect Disconnects the PPP connection.

About Displays version and description information about RASMan.

Exit Disables RASMan; the icon no longer appears in the Command bar.
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RASMan Configuration File 

RASMan application settings are stored in the Settings section of \IPSM\RASMan.exm. Use EZConfig 
Editor (see page 2-2) to change the values in the RASMan.exm file.

Key Description Default 
Value

Available Values

AudioNotification Enable and disable audio 
notifications on connecting and 
disconnecting.

1 0=Disable
1=Enable

AutoConnectOnDock Connects and disconnects RASMan 
when the terminal is docked and 
removed from the communication 
peripheral.

1 0=Disabled; RASMan connection 
must be launched manually 
when the terminal is docked.

1=RASMan connects on an AC 
power event.

2=RASMan connects on RS-232/
USB connection.

AutoConnectOnStart
up

Controls the automatic connection 
when RASMan is started.

Note: RASMan attempts to connect 
only if the device is docked 
and AC power is detected.

1 0=Disabled; the PPP connection 
is not established when 
RASMan is started.

1=Enabled; the PPP connection 
is established when RASMAN 
is started.

Connectoid Indicates the connection RASMan 
should use. 

`USB 
Connectio
n

`USB Connection
`115200 Default
`19200 Default
`38400 Default
`57600 Default
Note: These values must be 

typed in exactly as they 
appear here.

CommandLine Command to execute on a 
successful connection. 

Empty Leave empty if no action is 
required.

CommandArgs Command arguments for the 
CommandLine setting.

Empty Leave empty if no action is 
required.

ConnectDelay Specifies the amount of time to wait 
before establishing the PPP 
connection after RASMan is 
started. 

2000 Enter values in milliseconds.

Debug Enables and disables the creation 
of a debug log file.

0 0=Disabled; no log file
1=Enabled; Creates a log file of 

RASMan activity in the \IPSM 
folder.

DisableActiveSync Disables the ActiveSync connection 
when RASMan is running.

1 0=Disabled; ActiveSync runs 
while RASMan is running.

1=Enabled; the ActiveSync 
connection is disabled while 
RASMan is running.
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Retry Specifies the retry count. 10

RetryDelay Specifies the retry delay. 1000 Enter values in milliseconds.

ShowError Enables and disables error 
messages on connecting.

1 0=Disable
1=Enable

ShowStatus Enables and disables the 
appearance of status dialog boxes.

1 0=Disabled; status dialogs do not 
appear.

1=Enabled; status dialogs do 
appear.

StatusMessageDelay Specifies a delay in milliseconds (i.e 
1000 is 1 second) to apply after 
status and error messages are 
displayed.

25 X=Number of milliseconds.

StopOnCriticalError Forces RASMan to stop running 
when a critical error occurs.

1 0=Disabled; RASMan continues 
to run when a critical error 
occurs.

1=Enabled; RASMan stops 
running when a critical error 
occurs.

TrayIcon Enables or disables the RASMan 
tray icon.

1 0=Disable
1=Enable

RASMan Configuration File 

RASMan application settings are stored in the Settings section of \IPSM\RASMan.exm. Use EZConfig 
Editor (see page 2-2) to change the values in the RASMan.exm file.

Key Description Default 
Value

Available Values
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Reboot

Reboot performs a warm or cold boot from the touch screen. All Dolphin terminals reboot with keyboard 
commands; Reboot offers you the option of using the touch screen instead.

Warm Boot

A warm boot is a soft reset. A soft reset re-boots the device without losing RAM data. 

You would perform a soft reset when

• the terminal fails to respond.
• after installing software applications that require a re-boot.
• after making changes to certain system settings, such as network cards.

Cold Boot

A cold boot is a hard reset. A hard reset resets the operating system, restores the terminal back to factory 
defaults, and resets the terminal. 

A hard reset erases all of the data stored in RAM memory and all RAM installed applications! Only data 
and applications stored in \IPSM memory persist.

Rebooting the Dolphin terminal

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the Reboot icon . The Reboot screen appears. 

To perform a warm boot, tap the Warm Boot button. 

To perform a cold boot, tap the Cold Boot button.

The Dolphin terminal begins booting immediately.

Command Line Arguments

/r Warm Reset

/c Cold Reset
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Suspend

Suspend puts the terminal in Suspend mode. All Dolphin terminals have keyboard commands that put the 
terminal in Suspend mode; Suspend offers you the option of using the touch screen instead.

To Suspend the Dolphin Terminal

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the Suspend icon once . The terminal goes into Suspend mode.

To Wake the Dolphin Terminal from Suspend Mode

Press the SCAN key.
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SysInfo

SysInfo provides a read-out of important system information including firmware versions, DLL versions, 
system parameters, as well as network and radio information. 

To See System Information

1. Tap Start > Power Tools. The Power Tools Main Window (see page 1-2) appears. 

2. Tap the SysInfo icon once . 

3. SysInfo queries the system, compiles the data and displays it on the SysInfo screen. 

You cannot edit information in SysInfo. This information is gathered from the Dolphin terminal and 
changes only when the terminal’s configuration has changed.

To refresh the system information, go to File > Refresh. The system re-compiles system information.

To Save the System Information to a Text File

Tap File > Save to File. A file named “SYSINFO.txt” is generated and saved to the My Device folder.

To open the file, tap Start > Programs > File Explorer. Navigate to the My Device folder. The 
SYSINFO.txt file appears in the list. 
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Viewing Options

If you tap on the SYSINFO.txt file in the My Device folder, the file opens in Pocket Word. 

You cannot change system information by editing the text!

To Upload SYSINFO.txt to a Workstation

You can upload the SYSINFO.txt file to a workstation via ActiveSync. 

1. On the workstation, open Windows Explorer.

2. Navigate to the Mobile Device folder.

3. Select My Windows Mobile-Based Device. The SYSINFO.txt file appears here.

4. Copy and paste this file to a folder on your workstation.
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Sample SysInfo File

Field Sample Data This entry specifies the …

SYSTEM DATE/TIME

Date 1/14/2008 Date.

Time 10:38:36 Time.

SYSTEM INFO Sample Data This entry specifies the …

Hardware Revision 0 Hardware revision.

OS Version WM60 Operating System version.

Kernel 22.06 (Dec 21, 2007) Kernel version and date.

Service Pack NONE Service Pack level.

Boot Loader 0.00 () Bootloader version and date.

Keyboard Firmware 0.00 Keyboard firmware version.

Manufacture Date 20070711 Manufacture date.

Model Number 7600 Model number.

Part Number 7600EH-112-B4EE Part number of the main board.

Special Part Number 7600EH-112-B4EE Special part number, if any.

Terminal Serial Number 07193E0564 Terminal serial number.

CPLD Version Unknown CPLD firmware version.

Keyboard Type 29-key Keyboard type.

Scanner Type IT5300 Imager installed on the terminal.

Touch Panel Type Installed Touch panel type.

Display Type Toppoly Display type.

CPU INFO Sample Data This entry specifies the …

ProcessorName S3C2440A Name of the CPU

Architecture ARM Systems processor architecture.

ProcessorLevel 4 System’s architecture-dependent processor level.

Processor Frequency 400 Mhz System’s processor operating frequency.

DLL VERSION INFO Sample Data This entry specifies the …

Decoder.dll 1.16.1.2 Current Decoder.dll api build revision.

Matrix Engine 4.84.1.11 Current Matrix engine build revision.

HHPScanInterface.dll 1.16 Current HHPScanInterface.dll api build revision.

Scan Driver 1.212.1.14 Current scan driver build revision.

HHPMT9V022HW.dll 1.00.02 Current HHPMT9V022HW.dll api build revision.
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ImgApi.dll 1.16 Current ImgApi.dll api build revision.

SYSTEM PARAMETERS Sample Data This entry specifies the …

BatteryIdleTimeout 0

ExternalIdleTimeout 0

OEMInfo Hand Held Products Name of the OEM.

PlatformType PocketPC Type of operating system.

NETWORK INFO Sample Data This entry specifies the …

Hostname ID07193E0563 Terminal’s ID (recognized by ActiveSync, for example)

NumberOfAdapters 2 Number of network adapters installed.

1: Mac Address 001641F81262 MAC and IP address of the on-board 802.11b/g radio. 
The 0.0.0.0 indicates that the 802.11b/g radio is using 
DHCP instead of a static IP address.1: IP Address 0.0.0.0

2: Mac Address 8200600FE800 MAC and IP address of the on-board Bluetooth radio.

2: IP Address 169.254.2.1

RADIO INFO Sample Data This entry specifies the …

Current Mode: GSM/GPRS On-board radio active when the SysInfo icon was 
pressed.

Bluetooth Hardware: CSR Bluetooth radio driver.

WiFi Hardware: USI SPI 802.11b/g radio driver.

GSM Hardware: Siemens MC-75 GSM radio driver.

IPSM/ Sample Data

File(1)–File (XX): AutoInstall.exe
AutoInstall.exm
Autorun.exe
Autorun.exm
DeviceConfig.exe
DeviceConfig.exm
EZConfigPPC.exe
DemosMenu.exm
EZConfigMenu.exm
NetworkMenu.exm
PowerToolsMenu.exm
RASMan.exm
ScanWedge.exm
RegBackup.exm

These are the files in the \IPSM folder. They persist 
through cold boots.

IPSM/AutoInstall/ Sample Data

Sample SysInfo File

Field Sample Data This entry specifies the …
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File(XX)–File(XX): xDecoder.cab
SDKRT_armv4i.cab
Demos_armv4i.cab
PowerTls_armv4i.cab
DefaultSettings.reg

These are the files in the \IPSM\AutoInstall folder. 
They persist through cold boots and install during 
AutoInstall.

POWER STATUS Sample Data This entry specifies the …

ACLineStatus AC online AC power status.

BatteryFlag High Battery charge status.

BatteryLifePercent 100 % Percentage of full battery charge remaining.

BackupBatteryFlag High Backup battery charge status.

BackupBatteryLifePerce
nt

100 % Percentage of full backup battery charge remaining.

STORE INFO Sample Data This entry specifies the …

StoreSize 23711744 Size in bytes of the object store.

FreeSize 16615424 Amount of free space in bytes in the object store.

SYSTEM VERSION Sample Data This entry specifies the …

MajorVersion 5

MinorVersion 2

BuildNumber 1944

PlatformId 3

CSDVersion Latest Service Pack installed on the system.

GLOBAL MEMORY 
STATUS

Sample Data This entry specifies the …

MemoryLoad 24 Number between 0 and 100 that gives a general idea 
of current memory utilization.
0 = No memory use
100 = Full memory use

TotalPhysical 100204544 Total number of bytes of physical memory.

TotalPageFile 0 Number of bytes of physical memory available.

AvailPageFile 0 Total number of bytes that can be stored in the paging 
file.

TotalVirtual 33554432 Total number of bytes that can be described in the 
user mode portion of the virtual address space of the 
calling process.

AvailVirtual 30212096 Number of bytes of unreserved and uncommitted 
memory in the user mode portion of the virtual 
address space of the calling process.

Sample SysInfo File

Field Sample Data This entry specifies the …
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RAM INFO Sample Data This entry specifies the …

Total Installed RAM 128 MB Actual size of installed RAM chip.

Total User RAM 128 MB Total RAM available for file system and program 
memory after kernel overhead.

Min File System Size 16 MB Minimum sized allowed for the file system.

File System Size 23 MB Current size of the file system.

Min Program Memory 
Size

64 MB Minimum size allowed for program memory.

Program Memory Size 95 MB Current size of the program memory.

Current Split % 18 Percentage of the Total User RAM allocated to the file 
system.

Valid Split % Range 12% - 50% Valid % range that can be used when setting file 
system size. If set out of range value will be set to 
closest min or max.

IMAGER INFO Sample Data This entry specifies the …

PSOC Version 2.3 Current PSOC revision.

AimerXoffset 448 Imager’s AimerXoffset parameter.

AimerYoffset 239 Imager’s AimerYoffset parameter.

BitsPerPixel 8 Imager’s BitsPerPixel parameter.

EngineID 9 Imager’s EngineID parameter.

ImagerCols 752 Imager’s ImagerCols parameter.

ImagerRows 480 Imager’s ImagerRows parameter.

Rotation 0 Imager’s Rotation parameter.

YDepth 1 Imager’s YDepth parameter.

Sample SysInfo File

Field Sample Data This entry specifies the …
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7

Using the Battery Analyzer
Overview

The Battery Analyzer Power Tool helps you manage the battery power installed in the Dolphin 9700/9900 
terminal.

Requirements

For the Battery Analyzer to work, you must have the following items installed on the Dolphin terminal in 
the following locations:

• The BatteryAnalyzer.exe is stored in the \Program Files\Power Tools folder.
• The BatteryAnalyzer.exm is stored in the \IPSM folder.
• The Battalyzer.dll is stored in the \Windows folder.

When all of these items are installed, the Battery Analyzer icon  appears on the Power Tools Main 
Window (see page 1-2).

Operating Temperature=0°—50°C

The operating temperature of the battery must be between 0°C and 50°C. If you attempt to 
analyze a battery when the operating temperature is outside this range, the analyze cycle 
stops. You will be notified that the analyze cycle was aborted due to temperatures below 0°C 
or above 50°C. If this happens, recharge the battery. 

AC Power Supply 

You must have a continuous supply of AC power to the terminal and installed battery prior to 
analyzing. If you attempt to analyze a battery and AC power is interrupted, the analyze process 
stops. You will be notified that the analyze cycle was aborted due to AC power interruptions. 
If this happens, recharge the battery. 

Recommendation
Batteries should be analyzed only once every three months. 
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Analyzing a Battery

During the analyze cycle, the installed battery charges to 100%, then drains it to 0%, then charges it back 
up to 100%.

When the operating temperature of the battery is between 0°C and 50°C and there is a constant AC 
supply to the terminal and battery, tap Start > Power Tools > Battery Analyzer. The Battery Analyzer 
main window displays specific battery information for your review, including the operating temperature. 

Note: The Charge Status field indicates if the installed battery is charging or fully charged. 

The Estimated Time field displays the amount of time it will take to complete a full cycle.

Analyze Cycle Steps

There are three steps to the analyze cycle:

Step 1: The battery charges to 100%.

Step 2: The battery discharges to 0%.

Step 3: The battery re-charges to 100%.

Automatic Shut Down

The analyze cycle aborts if:

• The operating temperature drops below 0°C or above 50°C.
• AC power is lost.
The text box at the bottom of the window displays the details about why the process aborted.

Stopping an Analyze Cycle
You can stop the analyze cycle manually any time by tapping the File menu in the command bar. Tap 
Stop Analyzing or Start Analyzing.

The status bar at the top of 
the window shows the 
progress of the analyze 
cycle.

The text box at the bottom 
of the window displays the 
details of the analyze cycle.
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Command Line Arguments

The following command line arguments can be used in the CommandArgs key of the Battery Analyzer 
section of the PowerToolsMenu.exm file.

/a Indicates “admin” and launches Battery Analyzer in Advanced Mode (see page 7-3). 

/d Indicates “debug” and creates a log file that tracks the activity of Battery Analyzer from the 
moment the application is launched. The log file is: \IPSM\BatteryAnalyzer.log.

/s Indicates “autostart” and launches the analyze cycle the moment you launch Battery 
Analyzer from the main window.

/q Indicates “quit” and stops the analyze process if it’s running.

Advanced Mode

You run Battery Analyzer in advanced mode when you enter “/a” in the CommandArgs key of the Battery 
Analyzer section of the PowerToolsMenu.exm. The next time you open the Battery Analyzer Power Tool, 
it will be running in Advanced Mode.

When you do run the Battery Analyzer in advanced mode, additional fields appear on the Battery Analyzer 
window.

Capacity Displays the capacity of the installed battery.

Log to File Option to create a log file after the analyze cycle is complete.
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Log File

The log file records data in the following order:

• Date
• Time
• Conditioning Flag
• Battery Temperature
• Battery Voltage
• Capacity Percentage
• Charge Percentage
• Charge State
• Charge Status
• Analyzing Start Time
• Elapsed Time
• Estimated Completion Time
• Formatted Estimated Completion Time
• Estimated Progress 

The log file is stored as “BatteryAnalyzer.log” in the \IPSM folder. Open this file with Pocket Word.

Should the analyze cycle abort automatically for some reason, check the log file for details.
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8

Registry Power Tools
Overview

The registry is the configuration database in all 32-bit versions of Windows that contains settings for the 
hardware and software, consisting of the SYSTEM.DAT and USER.DAT files. Many settings previously 
stored in the WIN.ini and SYSTEM.ini files in 16-bit Windows (Windows 3.x) are in the registry.

The RegEdit Power Tool enables you to edit the registry through an easy-to-use application window. You 
can also import and export specific registry keys.

Editing the Registry

1. On the Power Tools Main Window (see page 1-2), tap the RegEdit icon once . RegEdit opens 
to a split-pane window with a collapsible menu in top half.

This is the top level of the registry; it cannot be edited, copied, pasted, or renamed.

2. Click the + sign to expand the menu options.

3. RegEdit offers the following registry categories:

• HKEY_CLASSES_ROOT
• HKEY_CURRENT_USER
• HKEY_LOCAL_MACHINE

4. Expand the appropriate menu by clicking on the + sign.
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5. Drill-down to the appropriate registry entry. When you click on registry entry in the top half of the 
screen, the data appears in the lower half of the screen. 

The two columns in the bottom half of the window show the Value Name and the Value Data of the 
selected entry.

6. Double-click on the Value Name. The Edit Value window pops up.

In the Value Data field, type the new value.

7. Press the ENT(ER) key or tap OK. The new data appears in the list.

8. After all your edits are complete, Warm Boot (see page 6-13) the terminal to save your changes to 
the registry.

Note: If you want your edits to persist through the next cold boot, run RegBackup after saving your changes; see 
Backing Up the Registry on page 8-6. 
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Menus

The menus on the RegEdit window offer you many editing options.

File Menu
The File menu allows you to create registry entries as well as import and export registry settings.  

Edit Menu
The Edit menu helps you work with existing registry entries. 

Menu Item Description

New Creates a new Key, String, or DWORD Value. 

Import Imports a registry file; see Importing Registry Files on page 8-5.

Export Exports the current registry; see Backing Up the Registry on page 8-6.

Exit Closes RegEdit.

Menu Item Description

Copy Copies a selected item.

Paste Pastes a copied item within RegEdit.
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View Menu

These menu items shift focus between the Keys Panel and the Values Panel.

Rename Renames a registry entry. 

Enter the new name and press the ENTER or OK key.

Delete Deletes a selected registry entry.

Find Searches for registry entries within a selected section. (Select an item in 
the top half of the window before tapping Edit > Find.) 

Enter the search criteria and tap OK. RegEdit notifies you if the selected 
section contains data matching the entered criteria.

Find Next Launches another search for the criteria entered in Find.

Menu Item Description
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Importing Registry Files

The file must be loaded on the terminal and have a REG extension. 

1. Tap File > Import. By default, the import function searches for REG files and displays the search 
results in the lower half of the window. 

2. Tap once on the REG file and it loads automatically.

Exporting Specific Registry Settings

You can export specific registry settings. In RegEdit, navigate to the section you would like to export and 
select it.

Tap File > Export and select the parameters of the REG file that would contains these settings.

If you want these REG setting to load during AutoInstall, select AutoInstall in the Folder drop-down list 
and IPSM in the Location drop-down list. 

Other Export Options
You can export

• The entire registry–see Backing Up the Registry on page 8-6.
• Radio settings–see Backup Radio Settings on page 9-12.
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Backing Up the Registry

You can export the current registry by tapping the RegBackup icon on the Power Tools Main Window 

(see page 1-2) . A _RegBackup.reg file containing the entire registry is created and stored in the 
\IPSM\AutoInstall folder. 

Because this REG file is stored in the \IPSM\AutoInstall folder, AutoInstall will launch and install this 
REG file during the next cold boot.

Restoring the Registry
After you have backed up the registry, a _RegBackup.reg file of the entire registry is stored in the 
\IPSM\AutoInstall folder.

You have a number of options to restore the registry by loading the _RegBackup.reg file.

RegRestore

On the Power Tools Main Window (see page 1-2), tap the RegRestore icon . 

Tap on the REG File: 
Tapping on a REG file in any folder immediately tries to add the information in that file to the registry. A 
message appears asking if you want to add the information to the registry. Tap Yes to add the information. 

Cold Boot
Because this REG file is stored in the \IPSM\AutoInstall folder, AutoInstall will launch and install this 
REG file during the next cold boot.
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RegBackup.exm

The RegBackup.exm file is located in the \IPSM folder and determines the content of the 
_RegBackup.reg file.

The RegBackup.exm file does NOT contain registry settings! Only REG files contain registry settings. 

Sections

_TEMPLATE_ Section The _TEMPLATE_ section is a template of the basic registry sections. This section is not 
used when creating the _RegBackup.reg file. Use these subsections as a basis for 
modifications and additions to the file.

Backup Section When you backup the registry (see Backing Up the Registry on page 8-6), the include/
exclude settings in this section indicate what content to backup. 

This default section should never be removed as it contains default excludes specified by 
Honeywell. It can, however be added to. Do NOT change the Mode (page 8-8)!

SyChip & Philips Sections

When you backup radio settings (see Backup Radio Settings on page 9-12), the include/
exclude settings in this section indicate what content to backup. 

Modifying

Modifying the RegBackup.exm file allows you to include or exclude registry key sections and values 
during an export. Multiple subsections can be created below. All should be copied from the Template 
section which, itself, should not be modified.

To specify keys and values in the RegBackup.exm file, re-create the registry keys as sections and 
subsections in the tree structure just as they appear in the registry. The same rules that apply to copying 
directories apply here in that if you re-create a key from the registry, all the key’s values and subkey’s 
values will be copied unless there are values in the top-level key.

Only the key or value name is needed in the EXM file and not the associated value data. The EXM file is 
a structure used to define the backup file and not the actual registry data. 

These registry values will be 
included in the 
_RegBackup.reg file.
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Mode and Kernel Check

In each Subsection root in the tree, there should be two key-value pairs: Mode and KernelCheck.

If these keys are not present, the defaults will be applied: 

Mode=Exclude

KernelCheck=Enabled

Mode

The Mode key specifies export behavior of the values in the section.

1=Include Only the values that follow will be included.

0=Exclude Everything but the values that follow will be included. 

KernelCheck

KernelCheck forces kernel version and service pack validation when a previously exported REG file is 
imported on a Dolphin terminal. This means that if you attempt to load a _RegBackup.reg file (during 
AutoInstall, for example), RegBackup.exm verifies that the REG file matches the kernel installed on the 
terminal. If yes, then the REG file loads. If not, you’ll receive a warning message and the REG file will not 
load.

0=Disabled No kernel validation occurs on importing. In general (especially for radio settings), 
KernelCheck should be enabled. if the registry does not match the kernel, the terminal will 
not function properly.

1=Enabled Kernel validation occurs on importing.
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Command Line Arguments

Argument Description

/export <filename> Export registry to <filename>. 
The <filename> part is optional. If no filename is entered, the file will default to 
\IPSM\AutoInstall\_RegBackup.reg.

/import <filename> Import <filename> to registry. 
The <filename> part is optional. If no filename is entered, the file will default to 
\IPSM\AutoInstall\_RegBackup.reg.

/exm <filename> Specify the non-default backup EXM file <filename>. Filenames with spaces must 
be wrapped in quotes. If omitted, the filename defaults to \IPSM\RegBackup.exm. 
This argument is only valid when used with /export.

/section 
<SectionName>

Specify the non-default section in the EXM file for exclude or include export, 
depending on the mode setting in that section. If omitted, this defaults to the 
Backup section of whatever EXM file is specified. 
This argument is only valid when used with /export.

/key <key> Specify the top level of the registry key structure to export. 
This argument is not valid when using /export or /import.

/silent Displays no dialogs. 
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Registry Edit Options in EZConfig

You can also use EZConfig Editor to create registry documents on the workstation, create a bar code, 
then use EZConfig Client to decode the bar code and update the registry on the terminal.

For more information, see

• Registry Documents on page 2-17
• Creating Bar Codes on page 2-21
• EZConfig Client on page 2-34
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9

Network Utilities
Accessing Network Utilities 

Tap Start > Power Tools > Network Utilities . The Network Utilities window opens.

Standard Network Utilities
There are three Network Utilities that mirror DOS-prompt functions of your workstation:

• IP Config (see page 9-2)
• Ping (see page 9-4)
• Route (see page 9-6)

WiFi Status
WiFi Status helps you monitor the on-board 802.11b radio:

• WiFi Status (see page 9-10)

Radio Settings
There are two Power Tools on the Network Utilities window that enable you to backup and restore radio 
settings in the registry.

• Backup Radio Settings (page 9-12)
• Restore Radio Settings (page 9-12)

Note: WiFi Status and the Radio Settings Power Tools appear on this window only if an RF radio is installed in the 
terminal.
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IP Config

IPConfig is a kernel utility that displays, releases, and renews IP parameters for on-board network 

adapters. On the Network Menu window, click the IPConfig icon . The IPConfig screen opens 
displaying the Input tab.    

Field Description

Adapter This drop-down list contains the network adapters currently installed in the Dolphin 
terminal. Every field and button on this screen pertains to the adapter selected in this 
drop-down list.

MAC Addr Displays the MAC (Media Access Control) address of the selected Adapter. This is the 
serial number burned into the adapter that uniquely identifies it. 

Subnet Mask Displays the adapter’s subnet mask. The subnet mask determines the subnet upon 
which the adapter resides.

Gateway Displays the adapter’s gateway information.

Release the IP 
address

Click this button to release the IP address.

Renew the IP 
address

Click this button to renew the IP address.

Display full 
configuration

Click this button to retrieve and review the full configuration of the terminal’s IP setup. 
For more information, see Displaying the Terminal’s IP Configuration (see page 9-3).
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Displaying the Terminal’s IP Configuration

On the Input tab, tap the Display full configuration button. The Dolphin terminal retrieves and displays 
the IP configuration for the entire terminal. 

About Tab

The About tab displays information about this Power Tool.
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Ping

Ping provides a GUI-based version of the traditional command line ping utility. Pinging sends out an echo 
request to a specific computer on the network. Use Ping to verify communication links or that a specific 
IP address is working. 

Ping contains three tab windows: Input, Output, and About. On the Input tab, you enter and send packet 
information to a specified remote host and see the result on the Output tab.

On the Network Menu window, tap the Ping icon . The Pings screen opens to the Input tab. 

Using the Input Tab

Note: You do not need to complete all the fields on the Ping window to successfully execute, just the Destination IP 
address.

Field Description

Destination Enter the IP address. This field is required.

Timeout 
(milliseconds)

Enter the timeout time in millisecond intervals; 1000 is the default. 

Send buffer size Indicate the buffer size for sending; 32 is the default.

Send count Indicate the count for sending; 4 is the default. Check Infinite to make the send 
count infinite.

TTL Short for Time To Live, this is the maximum amount of time a packet is allowed to 
travel through the network before it is discarded.

TOS Enter the Type of Service (TOS); it should be eight bits broken into five subfields.

Rec route for count 
hops

Enter the number of hops to record in the IP header; 1–9.
This field traces the route of the packets for each hop.The hop count is the number 
of network devices between the starting node and the destination node that an IP 
packet hits while traveling over a network. The number of hops is recorded in the IP 
header.
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Reading the Output Tab 

After you enter the IP information on the Input tab and click Execute, the Output tab appears and begins 
displaying the ping results. 

You can click the Stop button at any time to stop the ping. Any errors encountered display on the screen. 
When the Ping process is complete or if you stop the ping at any point, ***Ping Stopped *** displays.

About Tab

The About tab displays description and version information about Ping. 

Timestamp route Enter the number of timestamps to record for each hop; 1–4
The timestamp is the packet’s arrival time at each hop.

Don’t fragment Check this box if you don’t want the packet to fragment during routing.

DNS address required Check this if you want the domain name server to be part of the route path.

Execute Click Execute to send the ping. The Output tab displays the response. 

Using the Input Tab

Note: You do not need to complete all the fields on the Ping window to successfully execute, just the Destination IP 
address.

Field Description
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Route

Route is a kernel utility that allows the user to view and edit the rules that govern how packets destined 
for various subnets are routed. These rules tell the device which gateways on a given interface's subnet 
may be used to route packets to hosts on other subnets.

Route contains three tab windows: Input, Output, and About. You enter and execute the command on the 
Input tab and review the results on the Output tab. 

On the Network Menu window, tap the Route icon once .The Route screen opens to the Input tab.   

Output tab 

The Output tab displays the information that results from executing a command on the Input tab; it 
displays no information on its own. See the individual tasks below to see the Output tab for each 
command.

To Print Network Routing Tables

1. On the Input tab, select PRINT in the Command drop-down list.

Using the Input Tab

Field Description

Command This drop-down list contains the available routing commands. Select from:

• PRINT - Prints the network routing tables to the Output tab; see page 9-6.

• ADD - Adds a route; see page 9-7.

• DELETE - Deletes a route with a specified destination; see page 9-8.

• CLEAR - Clears routing tables of all gateway entries; see page 9-8.

Text under Command The text describes each command. The content changes automatically when a 
command is selected from the Command drop-down list.

Execute Click this button to execute the selected command. The Output tab displays the 
results.
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2. Click the Execute button. The Output tab appears displaying the network routing table. 

3. This table displays Destination, Netmask, Gateway, Metric, and Interface columns. Scroll right to 
see all the columns.

To Add a Route

You can add a custom route with the Add command.

1. On the Input tab, select ADD in the Command drop-down list. Fields appear on the Input tab. 

2. Specify the range of IP address to which this rule will apply using the Destination and Netmask 
fields. For example, the settings in the screenshot below specify an address range from 300.300.0.1 
to 300.300.255.254. 

3. Enter the Gateway.

4. Enter the Metric (not required).

5. Enter the Interface (not required).
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6. Tap Execute. The system verifies your results and the Output tab lets you know if your entry was 
added successfully.   

To Delete a Route

You can delete active routes.

1. On the Input tab, select DELETE from the Command drop-down list. The Destination field appears.   

2. Enter the IP address in the Destination field.

3. Click the Execute button.The system processes the request and displays how many routes were 
deleted. 

To Clear Gateway Entries

Executing this command clears routing tables of all gateway entries.
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1. On the Input tab, select CLEAR in the Command drop-down list. 

2. Click the Execute button. The system processes your request and the number of entries deleted 
appears on the Output tab.
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WiFi Status

The WiFi Status Power Tool displays information from the 802.11 adapter installed in the terminal and 
enables you to configure certain operating parameters.

 Tap Start > Power Tools > Network Utilities > WiFiStatus . 

Setup Tab

The Setup tab enables you to change specific parameters of the 802.11 adapter. 

Field Description

Adapter Name of the radio module installed on the terminal.

Update inv This is the update interval used to poll the 802.11 adapter for status information.

SSID Displays the SSID value presently configured in the 802.11 adapter.

Power mode Choose between the following power modes:

CAM Continuous access mode (CAM); the device is always on.

Max PSP* Maximum power saving; provides the greatest power savings for the 802.11 NIC radio.

Fast PSP* Fast power saving mode; provides the best combination of network performance and power 
usage.

*PSP=Power Save Polling

BSS Mode Choose between the following modes:
Automatic=Switches between Ad hoc and infrastructure modes as required.
IBSS (Ad hoc)=Specifies independent basic service set (IBSS).
Infrastructure (ESS)=Specifies infrastructure.

Enable & 
Disable

Tap these buttons to enable and disable the 802.11 radio
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Status Tab

The Status tab displays statistics for the 802.11 radio. 

The Release IP and Renew IP buttons enable you to release and renew the terminal’s IP address.

BSSID Tab

When accessed, the BSSID tab causes the radio to scan for all APs in range and displays the results. 

Apply Tap this button to apply changes to the Update interval, SSID, Power mode, and BSS 
mode.

Field Description

Signal Strength Percentage

AP SSID

BSSID (same as the AP 
MAC address)
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Backup Radio Settings

When the terminal’s radios are configured, entries are made in the registry that contain those settings. 
However, those entries are removed during the next cold boot. Backup Radio Settings exports those radio 
settings into a RadioSettings.reg file and places it in the \IPSM\AutoInstall folder. By default, the 
settings in the RadioSettings.reg file will be added to the registry during the next cold boot and your radios 
will be configured automatically when the boot process is complete. 

On the Network Utilities main window, tap the Backup Radio Settings icon . The RadioSettings.reg 
file is created and placed in the \IPSM\AutoInstall folder. 

Restore Radio Settings
You have a number of options to restore the registry by loading the RadioSettings.reg file.

Restore Radio Settings

On the Network Utilities window, tap the Restore Radio Settings icon . A message appears 
asking if you want to load the RadioSettings.reg file. Tap Yes and RegEdit imports the radio registry 
entries to the current registry.

Tap on the REG File: 
Tapping on a REG file in any folder immediately tries to add the information in that file to the registry. A 
message appears asking if you want to add the information to the registry. Tap Yes to add the information. 

Cold Boot
Because this REG file is stored in the \IPSM\AutoInstall folder, AutoInstall will launch and install this 
REG file during the next cold boot.
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EZMenu
Overview

EZMenu formats application windows to display and launch software programs on the terminal. For 
example, the Power Tools Main Window (see page 1-2) is managed by EZMenu.

EZMenu consists of 

• Menu configuration files (i.e., EXM files that end in “*Menu.exm”) in the \IPSM folder that contain the 
settings for application windows.

• The EZMenu.exe in the \Program Files\Power Tools folder that applies those settings in the 
terminal. EZMenu.exe is launched during AutoInstall by default. 

Running Easy Menu 
EZMenu runs when you access an application window that has a menu configuration file. EZMenu.exe 
calls that menu configuration file to format the window. 

Default EZMenu Configuration Files 
Dolphin terminals ship with a number of menu configuration files in the \IPSM folder: 

DemosMenu.exm Programs the Demos main window (Start > Demos). 

EZConfigMenu.exm Programs the EZConfig Utilities window; see EZConfig Editor on the Terminal on page 2-
30.

NetworkMenu.exm Programs the Network Utilities window; see Accessing Network Utilities on page 9-1.

PrintDemoMenu.exm Programs the Print Demo window (Start > Demos > Print Demo). 

PowerToolsMenu.exm Programs the Power Tools main window; see Power Tools Main Window on page 1-2. 

Default menu configuration files must be located in the \IPSM folder.

Sample Menu Configuration Files
Samples of these default menu configuration files install to the workstation in the following folder: 
C:\Program Files\Honeywell\Power Tools and Demos for WM 6.0\EZConfig EXM Files. 

*Menu.exm Files EasyMenu.exe

EXM files have an  icon. Executables have an  icon.
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Modifying Menu Configuration Files 

Menu configuration files can be modified in EZConfig Editor on the workstation or the terminal, If modified 
on the workstation, the *Menu.exm file must be deployed to the terminal. 

For details about modifying EXM files in EZConfig Editor:

• See EZConfig Editor on page 2-2. 
• See EZConfig Editor on the Terminal on page 2-30.

Creating Menu Configuration Files 
Save as the Default EZMenu Configuration Files (see page 10-1) to create new menu configuration files.

1. On the workstation, navigate to the following folder: C:\Program Files\Honeywell\Power 
Tools and Demos for WM 6.0\EZConfig EXM Files.

2. Open a sample menu configuration file in EZConfig Editor.

3. Tap File > Save As and save the file with a new name ending in “Menu.exm.”

4. Modify the file; to see the available values, see Menu Configuration File Sections on page 10-3.

5. Save or transfer the file to the \IPSM folder on the terminal. 
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Menu Configuration File Sections 

Menu configuration files contain of two basic sections: Settings and MenuEntries. Both sections are 
locked, which means only their Values can be changed, not their section names.

Settings Section 
The Settings section defines general EZMenu settings. The keys in this section are locked, which means 
that only their Values can be changed. 

Key Description Default 
Value

Available Values 

Sig Identifies this file as a menu file. EZMenu These keys are read-only and 
cannot be changed.

Version This is the EZMenu version number. 1

EnableDebug Enables system debugging. 0 0=Disable 1=Enable; an 
Easymenu.log file is created in 
the \IPSM folder. 

ListViewMode Determines the default view mode 
for the window. For details, see 
View Options on page 1-3.

3 0=Detail
1=List 
2=Small Icon 
3=Large Icon 

Caption Defines the caption or title displayed 
in the title bar of the application 
window.

Variable User-defined 

StartMenu Enables and disables access to the 
Start menu from the application 
window.

Variable 0=Disable Start Menu 
1=Enable Start Menu 

OK Enables and disables the OK button 
in the upper right corner of the 
application window.

Variable 0=Disable OK Button 
1=Enable OK Button 

Menu Determines which menus appear in 
the Command bar. There are three 
menus: File, View, Help. 
Exit=File menu 
View=View menu 
Default=File, View & Help menus

3 0=No Menus 
1=Default Menu + No Exit + No 

View 
2=Default Menu + No Exit
3=Default Menu

The following three parameters determine the icon spacing in all view modes: 

ListViewIconSpacingY Sets vertical icon spacing. 80 Spacing is measured in pixels. 

ListViewIconSpacingX Sets horizontal icon spacing. 75 Spacing is measured in pixels.

ListViewGradient Determines whether the gradient 
background (horizontal blue and 
white lines) appears on the window. 

1 0=Disable gradient background
1=Enable gradient background 
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MenuEntries Subsections 
The MenuEntries section determines which programs appear on the application window. 

The MenuEntries section is locked, which means that you cannot change its Name or Description; 
however, its child sections are not locked and can have any name and description.

Each child section is a program that launches from the application window and must be at the same level 
underneath the MenuEntries section. The order of child sections from top to bottom determines the order 
that the programs appear on the application window. 

Child Section Keys 

The keys in the child sections are locked, which means only their Values can be changed.

MaskPassword Determines if password entries on 
dialog boxes should be masked.

1 0=Disabled; passwords are not 
masked. 

1=Enabled; passwords are 
masked.

TodayScreenSessionT
imeout

When the device is left in suspend 
mode, this key specifies the number 
of hours that need to pass before 
the device returns to the Today 
screen.

0 0=Disabled; the terminal does 
not return to the Today screen 
while in suspend mode.

X=Number of hours.

Key Description Required Available Values 

Name Name to display on the window. The 
name appears under the icon (if there 
is an icon).

Required User-defined

Description Description to display on the window 
in Detail view.

Required User-defined

Key Description Default 
Value

Available Values 
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Exit Icon

Default EZMenu Configuration Files (see page 10-1) contain a section named Exit as a child section of 
the MenuEntries section. 

Enabling the Exit section places this icon  on the application window, which allows users to exit. If you 
want users to be able to exit the application window, make sure the Exit section is a child of the 
MenuEntries section. If you want users to be unable to exit the application window, disable or delete the 
Exit section.

CommandLine Command line to execute when the 
item is selected on the window. This 
is the location of the EXE file for the 
program to launch.

Required Location of the EXE file. 
Also available:
[ADMIN]=Toggles into 

Administrative mode
[EXIT]=Exit menu 

CommandArgs Command line arguments used with 
the CommandLine parameter.

*Optional Program-specific

Password Use this key to password-protect 
access to the window. If no value is 
entered, the window is not password-
protected. 

Optional Enter a password. 

HotKey Hotkey that can be used to launch 
the menu entry. 

Optional HotKey number

HotKeyModifier Modifier for the hotkey. Optional Global: 
16=No Modifier   
17=ALT   
18=CONTROL 
20=SHIFT   

EZMenu only:   
0=No Modifier   
1=ALT   
2=CONTROL   
4=SHIFT 

IconFile  Filename of the icon resource file. Optional The filename of the icon must 
be an EXE or DLL, an ICO file 
will not work. 

Icon ID Icon resource identifier contained in 
the file specified in the IconFile key.

Optional X=Icon resource identifier

SupportFile The key dependencies. Optional X=Variable

StartOption Specifies startup options that must 
be met for the menu entry to appear 
on the window.

Optional See Start Options on page 
10-6.

Key Description Required Available Values 
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Start Options
Start Options define the required system parameters for a software application to launch. The following 
values can be entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category

DISABLED Never, regardless of other startup options specified. None

COLDBOOT The terminal has performed a cold boot.
Boot type

WARMBOOT The terminal has performed a warm boot.

TOUCH The terminal has a touch screen display installed.
Touch Screen

NONTOUCH The terminal doesn’t have a touch screen display installed.

BATCH The terminal is a batch unit (no RF or internal modem cards installed).

Mobility

RF The terminal has an RF card installed (e.g., Cisco 802.11b).

GSM The terminal has a GSM radio.

BT The terminal has a Bluetooth radio.

MODEM The terminal has an internal modem card installed.

IMAGER The terminal has an imager installed.

Scanner
LASER The terminal has a laser scanner installed.

BLIND The terminal has no laser or imager installed.

ANYSCAN The terminal has either an imager or a laser scanner installed.

RFON The RF radio is Enabled.

Radio
GSMON The GSM radio is enabled.

BTON The Bluetooth radio is enabled.

RFGSMBTOFF The RF, GSM, & Bluetooth radios are disabled.
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29KEY The terminal has a 29-key keyboard.

Keyboard

35KEY The terminal has a 35-key keyboard.

38KEY The terminal has a 38-key keyboard.

43KEY The terminal has a 43-key keyboard.

56KEY The terminal has a 56-key keyboard.

NO_KEY The terminal has a 56-key keyboard.

Start Options
Start Options define the required system parameters for a software application to launch. The following 
values can be entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category
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Multiple options can be specified for each category. For example, you can specify both 35KEY and 
43KEY options to request that the program run in either a 35- or 43-key keyboard terminal. Seperate 
multiple options with commas.

7300 It’s a Dolphin 7300 terminal.

Model

7400 It’s a Dolphin 7400 terminal.

7450 It’s a Dolphin 7450 terminal.

74XX It’s any Dolphin terminal beginning with “74”.

7600 It’s a Dolphin 7600 terminal.

76XX It’s any Dolphin terminal beginning with “76”.

7850 It’s a Dolphin 7850 terminal.

78XX It’s any Dolphin terminal beginning with “78”.

7900 It’s a Dolphin 7900 terminal.

79XX It’s any Dolphin terminal beginning with “79”.

9500 It’s a Dolphin 9500 terminal.

9501 It’s a Dolphin 9501 terminal.

9550 It’s a Dolphin 9550 terminal.

9551 It’s a Dolphin 9551 terminal.

95XX It’s any Dolphin terminal beginning with “95”.

9700 It’s a Dolphin 9700 terminal.

9900 It’s a Dolphin 9900 terminal.

99XX It’s any Dolphin terminal beginning with “99”.

PNPID The terminal has a card installed whose identification contains ALL of 
the strings specified in the PNPID setting.

Expansion Card
NONPNPID The terminal doesn’t have a card installed whose identification contains 

ALL of the strings specified in the PNPID setting.

Start Options
Start Options define the required system parameters for a software application to launch. The following 
values can be entered for the StartOption key, wherever it appears:

Option Name The program launches if … Category
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To ignore a category, don’t specify any of its options.
10 - 9



Locking Down the Application Window

You can program a menu configuration file to block access to the Start menu, OK button, and Command 
bar menus on the application window. When all of these items are blocked, the user must navigate the 
terminal from the application window. 

EZMenu carries these settings forward to all windows opened from the application window. This way, 
access to the Start menu, OK button, and Command bar menus can be blocked globally.

1. Open the menu configuration file in EZConfig Editor.
For more information, see Working with Open EXM Files on page 2-8.

2. In the Settings Section (page 10-3), modify the following keys:

a. StartMenu=0  (The Start menu won’t appear on the application window.)

b. OK=0  (The OK button won’t appear on the application window.)

c. Menu=0  (No menus appear in the Command bar.)

3. In the MenuEntries section, delete, disable, or password protect (see Password on page 10-5) the 
Exit subsection to remove the Exit icon.

4. If you are modifying the file in EZConfig Editor on the terminal, tap Tools > Launch Associated 
App. The application window opens displaying your changes. 

If you are modifying the file in EZConfig Editor on the workstation, save, then transfer the file to the 
terminal. On the terminal, navigate to the application window to verify your changes.

Booting the Terminal to the Application Window
You can program the terminal to boot to the application window by modifying the Autorun.exm File (see 
page 4-1).

1. In EZConfig Editor, open Autorun.exm.

2. Open the Programs section and enable the EasyMenu section.

3. In the EasyMenu section, modify the Args key to call the EXM file of the application window. This is 
the path to the menu configuration file; i.e., “/ipsm/***menu.exm.”
By default, the Args key calls /ipsm/demosmenu.exm. 

4. Warm boot the terminal and verify that startup finishes on the application window.
10 - 10



10 - 11



10 - 12



11

SetRAM
Overview

The SetRAM Power Tool adjusts the division of program memory vs. file system memory on Dolphin 
terminals running Windows Mobile 6.0.

Windows Mobile 6.0 Memory

Windows Mobile 6.0 is designed to use a persistent file store rather than a RAM object store. The 
allocation of file system RAM memory versus program memory must be made during hard resets. This 
change is a challenge in devices that use the RAM based file systems because there is no way to predict 
individual application requirements of program memory vs. RAM file store.

As a result, you cannot change the memory allocation in the Memory system setting. 

On Dolphin terminals, the default memory allocation between file store and program memory is 50/50. 
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Accessing SetRAM

1. On the Power Tools Main Window (see page 1-2), tap the SetRAM icon . The SetRAM window 
displays the current memory distribution. 

2. To change the memory allocation, use the slider to adjust the memory allocation:
File MB=File Storage Memory
Prog MB=Program Memory

3. Tap Set RAM Allocation to make the change. 

4. The terminal launches a hard reset, then a soft reset.
This reset process launches AutoInstall, which launches DeviceConfig’s RAM memory allocation 
settings. Therefore, make sure that the RAM section is disabled in DeviceConfig.exm or that it 
contains the same memory settings as SetRAM. For more information, see RAM Memory Allocation 
in DeviceConfig on page 11-2.

RAM Memory Allocation in DeviceConfig 

DeviceConfig contains a RAM section (see page 3-10) that–if enabled–sets the RAM memory allocation 
for the terminal during startup. Dolphin terminals default to the RAM allocation in DeviceConfig. 
Therefore, if you want the changes you make in SetRAM to persist through hard resets, make sure that 
the RAM section in DeviceConfig disabled or, if enabled, matches the parameters in SetRAM. 

For more information about DeviceConfig, see RAM Section on page 3-10.

SetRAM Window

Field Value Description

Total Installed RAM 128 MB Actual size of installed RAM chip.

Memory Statistics: The values displayed in these fields are pulled from the terminal dynamically when 
SetRAM opens.

When SetRAM acquires the information successfully, the SetRAM window displays 
the following message: “RAM Info read success.”
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RAM Memory Restrictions

RAM memory allocation restrictions are built into SetRAM; the slider will not allow you reset the memory 
beyond the terminal’s capabilities.

Total User RAM 121 MB Total RAM available for file system and program memory minus kernel 
overhead.

Min Program RAM 31 MB Minimum amount of memory allowed for program memory.

Min File Sys RAM 16 MB Minimum amount of memory allowed for the file system.

RAM File % 50 Percentage of the Total User RAM allocated to the file system.

Actual File RAM 60 MB The actual amount of memory allocated for the file system.

Actual Prog RAM 60 MB The actual amount of memory allocated for the program memory.

Slider 

XX% 50% The RAM file % represented by the slider position. This percentage 
updates as you move the slider.

Valid Split % Range 13%–75% Valid % range that can be used when setting file system size. If set 
out of range, value will be set to closest min or max.

File MB: & Prog MB: 60 The actual file and program memory (in MBs) represented by the 
slider position. These numbers update as you move the slider.

SetRAM Window

Field Value Description
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Print Power Tools
Overview

Dolphin terminals contain two print utilities:

BTPrint.exe BTPrint prints to a Bluetooth device via the Bluetooth wireless radio; see page 12-2.

IrDAPrintCE.exe IrDAPrint prints to an IrDA device via the IrDA port; see page 12-2.

Both .exes are located in the \Program Files\Power Tools folder.

Print Demo

All Dolphin terminals contain a Print Demo (Start > Demos > Print Demo) that prints a sample receipt or 
bar code to a Bluetooth or IrDA printer. The Print Demo calls the BTPrint.exe when printing to a Bluetooth 
device and the IrDAPrintCE.exe when printing to an IrDA device. 

For more information about the Print Demo, please refer to the Print Demo chapter of the Demos User’s 
Guide, which is available for download from the web site: www.honeywell.com/aidc.

Note: You can also call either EXE to print to a Bluetooth or IrDA printer via command line.
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BTPrint

BTPrint allows you to print to a Bluetooth printer via the command line, provided that the Bluetooth printer 
is set up as a Bluetooth Favorite on the Dolphin terminal. 

For more information about setting up Bluetooth Favorite devices, please see the Bluetooth section of the 
Print Demo chapter in the Demos User’s Guide, which is available on the User CD or from the Partners 
area of www.honeywell.com/aidc.

Calling a Bluetooth Printer

Call BTPrint.exe from the command line \Program Files\Power Tools\BTPrint.exe – with the 
path of the document as the command line argument.

IrDAPrintCE

IrDAPrintCE allows you to print to an IrDA printer via the command line.

Calling an IrDA Printer

Call the IrDAPrintCE.exe from the command line \Program Files\Power 
Tools\IrDAPrintCE.exe with the path of the document as the command line argument.
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Customer Support
Technical Assistance

If you need assistance installing or troubleshooting your device, please call your distributor or the nearest technical support office:

North America/Canada
Telephone:  (800) 782-4263
E-mail:  hsmnasupport@honeywell.com

Latin America
Telephone:  (803) 835-8000
Telephone:  (800) 782-4263
E-mail:  hsmlasupport@honeywell.com

Brazil
Telephone: +55 (21) 3535-9100
Fax:  +55 (21) 3535-9105
E-mail:  brsuporte@honeywell.com

Mexico
Telephone:  (803) 835-8000
E-mail:  hsmlasupport@honeywell.com

Europe, Middle East, and Africa
Telephone:  +31 (0) 40 7999 393
Fax:  +31 (0) 40 2425 672
E-mail:  hsmeurosupport@honeywell.com

Hong Kong
Telephone:  +852-29536436
Fax:  +851-2511-3557
E-mail:  aptechsupport@honeywell.com

Singapore
Telephone:  +65-6842-7155
Fax:  +65-6842-7166
E-mail:  aptechsupport@honeywell.com

China
Telephone:  +86 800 828 2803
Fax:  +86-512-6762-2560
E-mail:  aptechsupport@honeywell.com

Japan
Telephone:  +81-3-3839-8511
Fax:  +81-3-3839-8519
E-mail:  aptechsupport@honeywell.com

Online Technical Assistance
You can also access technical assistance online at www.honeywellaidc.com.
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