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Introduction

The Net Base enables up to four Dolphin 9700 mobile 
computers to communicate with a host device over an 
Ethernet network. In addition, the Net Base provides a 
second RJ45 Ethernet port for connection to an additional 
device such as a printer, workstation, eBase, or another 
Net Base.

We recommend use of Honeywell peripherals, power 
cables, and power adapters. Use of any non-Honeywell 
peripherals, cables, or power adapters may cause 
damage not covered by the warranty.

Unpacking the Net Base

Open the shipping box and inspect the package to see 
that the following standard items are included:

• One Dolphin Net Base Ethernet cradle
• One universal AC/DC power adapter for the

Dolphin Net Base
• One power cord
• One Dolphin Net Base User’s Guide

You will also need to provide a standard CAT-5 Ethernet 
network cable. These items are needed to set up, 
configure, and operate the Net Base. If any items are 
missing or anything appears to be damaged, contact your 
Customer Account Representative.

Keep the original packaging in case you need to return the 
Net Base for service or to store the Net Base while not in 
use.

!
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Software Requirements

Before you connect the Dolphin terminal to the Net Base, 
make sure you have the most current software installed. 
To check the terminal’s system information, tap Start > 
Power Tools > SysInfo. 

• The Kernel version must be 20.01 or later in terminals 
running Windows Mobile 6.5 Classic. In terminals 
running Windows Mobile 6.5 Professional, the kernel 
version must be 21.01 or later.

• The Power Tools version must be 4.12 or later.

Applications on the Dolphin Terminal

Applications running on the Dolphin terminal when it is 
connected to the Net Base should be designed specifically 
for a partially connected network. For more details, please 
refer to the Best Practices for Partially Connected 
Networks document available at 
www.honeywellaidc.com.

http://www.honeywellaidc.com
http://www.honeywellaidc.com
http://www.honeywellaidc.com
http://www.honeywellaidc.com
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Hardware Overview

Front Panel

Terminal Wells 
The Net Base contains four terminal wells. Each well 
has its own dedicated Dock LED and COMM LED 
indicator. 

Place the Dolphin terminal in any one of the four 
wells to communicate with a host device, power the 
terminal, and charge the installed battery pack. The 
Net Base completely charges the main battery in a 
Dolphin terminal in 6 hours.

DOCK LED 
The Dock LED turns solid green when the terminal is 
properly seated in the Net Base.

COMM LED

Dock LED

Terminal Wells

Stylus
Slot
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COMM LED 
The COMM LED indicates the status of data transfer 
between the Dolphin terminal and the Net Base. 
Each terminal well has its own dedicated COMM 
LED. 

When the Dolphin terminal is not docked:

This color and status means…

Red Flashing The Net Base has 
power but no Ethernet 
connection. 

Orange Flashing The Net Base is 
acquiring an IP 
address.

Solid An Ethernet connection 
has been established 
between the network 
and Net Base.

When the Dolphin terminal is docked:

This color and status means…

Red Solid No connection is 
established between 
the Net Base and 
terminal.

Red Flashing The Net Base has 
power but no Ethernet  
connection.
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Back Panel 

DC Power Jack 
Use the power cable from Honeywell that comes with 
the Net Base to supply power to this power jack. For 
more information, see Power on page 7.

Orange Solid RASMan is attempting 
to establishing a 
connection between 
the Net Base and the 
terminal.

Green Solid RASMan has 
established a 
connection between 
the Net Base and the 
terminal.

DC Power Jack

Two RJ45 Ethernet Ports

Green LED

Orange LED

Fastener for 
the Stylus
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RJ45 Ethernet Ports 
The Net Base contains two RJ45 Ethernet ports. You 
can connect the Net Base to an Ethernet-compliant 
device to facilitate Ethernet communication to and 
from the terminal by plugging a standard CAT-5 
Ethernet cable into one of the two Ethernet ports 
provided. The second RJ45 Ethernet port can be 
used for connection to an additional device such as 
a printer, workstation, eBase, or another Net Base.

Note: The Net Base does not use a Spanning Tree Protocol 
(STP). When both RJ45 Ethernet ports are used, do 
not connect both Net Base interfaces to the same layer 
2 LAN. 

Each Ethernet port has a dedicated orange and 
green status LED. 

Bottom Panel

For details on how to mount the Net Base, see Mounting 
the Net Base on page 28.

This color and status means…

Green Flashing Network activity

Orange Solid Ethernet link active

Configuration
Data Reset Button

Compliance
Label

Serial 
Number Label
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Power

The terminal requires 9 Volts DC input for 
communications and battery charging; the power adapter 
on the power cable converts the voltage from the power 
source to 9 volts DC. Only the Honeywell 9 V/8.8A power 
supply provided with the Net Base converts the voltage 
appropriately.

Honeywell recommends that you leave the Net Base 
connected to its power source at all times, so that it is 
always ready to use. 

We recommend use of Honeywell peripherals, power 
cables, and power adapters. Use of any non-Honeywell 
peripherals, cables, or power adapters may cause 
damage not covered by the warranty.

1. Make sure the ON/OFF switch on the power adapter 
is in the OFF position.

2. Plug the A/C power cord into the power adapter.

3. Plug the power connector cable into the power 
connector on the back of the Net Base.

4. Plug the A/C power cord into a standard wall outlet. 
The Net Base is now powered. All four COMM LEDs 
illuminate solid red for approximately 6 seconds, and 
then start flashing red.

!

Power Connector Cable

A/C Power Cord

Power Adapter

ON/OFF Switch
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Charging the Main Battery in the 
Dolphin Terminal

We recommend use of Honeywell Li-Ion battery packs. 
Use of any non-Honeywell battery may result in damage 
not covered by the warranty.

The Net Base provides power to the Dolphin terminals and 
allows the charging of the main batteries in the terminal. 
The intelligent battery charging system incorporated into 
all Dolphin terminals prevents overcharging, which means 
that Dolphin terminals may be stored in the Net Base 
indefinitely without damage to the terminals, battery 
packs, or the Net Base.

1. Install the Li-ion battery pack into the back panel of 
the terminal; see the Dolphin 9700 User’s Guide for 
battery installation instructions.

2. Slide the Dolphin terminal 
into the terminal well until 
the Dock LED illuminates 
green. Charging begins 
immediately if required by 
the Dolphin terminal.

Make sure the terminal is dry before placing it in the Net 
Base. Do NOT place a wet terminal in the Net Base! 
Doing so may cause damage not covered by the 
warranty.

!

!
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Setting up the Net Base

1. Make sure the ON/OFF switch on the power adapter 
is in the OFF position.

2. Plug the A/C power cord into the power adapter.

3. Plug the power connector cable into the power 
connector on the back of the Net Base.

4. Plug the A/C power cord into a standard wall outlet. 
The Net Base is now powered. All four COMM LEDs 
illuminate solid red for approximately 6 seconds, and 
then start flashing red.

5. Plug the CAT-5 Ethernet cable into one of the RJ45 
connectors on the back of the Net Base.

6. Plug the Ethernet cable into the network. 

7. All four COMM LEDs flash orange while the Net Base 
attempts to acquire an IP address.  The COMM LEDs 
change to a solid orange when a network connection 
has been established.

Connecting the Dolphin Terminal to 
the Net Base

After the Net Base is installed, configured, and connected 
to the host computer, you must connect the Dolphin 
terminal to the Net Base. 

1. Remove the Dolphin terminal you want connected 
from the Net Base if it is docked.

2. On the Dolphin terminal, tap Start > ActiveSync > 
Menu > Connections.
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3. Remove the check from the box next to, 
“Synchronize all PCs using this connection”. 
Tap OK.

4. Insert the Dolphin into a terminal well on the Net 
Base. The Dock LED for the well lights green.

5. On the Dolphin terminal, tap Start > Power Tools.

6. Click the RASMan icon once. The terminal starts 
searching for a connection.

Note: During the connection process, the following error 
message may appear. This error message requires no 
action. The message disappears when the connection 
process is complete. 
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7. When the connection is established between the 
Dolphin terminal and the Net Base, the terminal plays 
a sound and the COMM LED on the Net Base lights 
green. The connection icon in the Dolphin’s 

navigation bar changes from    to  .

8. Upon connection, each of the Dolphin terminals 
docked in the Net Base is assigned a unique IP 
address. This IP address can be used by any 
application on the Dolphin terminal. 

9. When you disable RASMan or remove the terminal 
from the Net Base, the terminal plays a sound and 

the disconnected icon  appears in the Navigation 
bar. The COMM LED on the Net Base lights orange.

Note: A soft or hard reset of the terminal disables RASMan and 
the Ethernet connection.  Tap Start > Power Tools > 
RASMan to restart the program and restore the 
connection.

To start RASMan automatically after each soft or hard 
reset, enable the RASMan Program section of the 
Autorun.exm file (see AutoRun RASMan on page 13).

Troubleshooting

If the COMM LED lights red while browsing a web page, 
refresh the page and RASMan will automatically 
reconnect. The COMM LED lights green when the 
connection is established.

x

x
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Displaying the Net Base Terminal Well 
and Dolphin IP Address

Once the Dolphin terminal establishes communication, it 
shares the unique IP address assigned to the terminal well 
it is docked in on the Net Base. If four Dolphin terminals 
are successfully connected, then four different IP 
addresses are assigned to the Net Base, one for each 
terminal well.

1. Tap Start > Power Tools > Network Utilities > 
IPConfig.

2. On the Input tab, tap the Display full configuration 
button.

3. The Dolphin terminal retrieves and displays the IP 
configuration for the entire Dolphin terminal and the 
Net Base terminal well where the Dolphin is docked.

4. Locate the IpAddress field in the IP configuration list.

DeviceConfig and RASMan Settings

If your application requires frequent connecting and 
docking/undocking to the Ethernet, Honeywell 
recommends modifying the Dolphin's DeviceConfig.exm 
and RASMan.exm files to the following settings.

Modifying the DeviceConfig.exm ActiveSync 
Setting
1. Tap Start > Power Tools > EZConfig Utilities > 

DeviceConfig.

2. Locate ActiveSync under the Connections list.

3. Tap and hold the stylus on ActiveSync.
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4. Select Enable from the pop-up menu.

5. Tap twice on AutoConnect in the Key column.

6. Select OFF from the value pull down menu. Tap OK 
on the Navigation bar.

7. Tap on Connection in the Key column, and then tap 
File > Disable. 

8. Tap OK, and then tap Yes to save your changes.

Modifying the RASMan AutoActiveSync 
Setting
1. Tap Start > Power Tools > EZConfig Utilities > 

RASMan.

2. Select Settings from the folder tree, and then tap 
AutoActiveSync under the Key column.

3. Tap Edit > Modify.

4. Select Disable from the Value pull down menu.

5. Tap OK on the Navigation bar.

6. Tap OK, and then tap Yes to save your changes.

AutoRun RASMan

To start RASMan automatically after each soft or hard 
reset, enable the RASMan Program section of the 
Autorun.exm file.

1. Tap Start > Power Tools > EZConfig Utilities > 
AutoRun.

2. Locate RASMan under the Programs list.

3. Tap and hold the stylus on RASMan.

4. Select Enable from the pop-up menu.
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5. Tap OK on the Navigation bar.

6. Tap Yes to save your changes.

RASMan Settings for Applications Requiring 
Net Base Configuration Changes

If your application requires changes to the default Net 
Base configuration settings, Honeywell recommends 
modifying the Dolphin's RASMan.exm file to the following 
settings.

1. Tap Start > Power Tools > EZConfig Utilities > 
RASMan.

2. Select Settings from the folder tree, and then tap 
AutoConnectOnDock under the Key column.

3. Tap Edit > Modify.

4. Select On RS232/USB Connect from the Value pull 
down menu.

5. Tap OK on the Navigation bar.

6. Locate and tap Retry in the Key column.

7. Tap Edit > Modify.

8. Enter 50 as the Retry value.

9. Tap OK.

10. Locate and tap RetryDelay in the Key column.

11. Tap Edit > Modify.

12. Enter 1000 as the RetryDelay value.

13. Tap OK.

14. Tap OK, and then tap Yes to save your changes.
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Configuring the Net Base

By default, the Net Base is configured to obtain IP 
addresses automatically using a DHCP server. This 
means that in most cases, you would simply plug-and-play 
the unit. If necessary, you can use the Cradle Manager 
Configuration utility for dynamic network configuration. 
Note: After modifying the Net Base configuration settings, you 

may need to undock and then dock the Dolphin terminal to 
restore communication between the Net Base and Dolphin 
terminal. See RASMan Settings for Applications Requiring 
Net Base Configuration Changes on page 14.

Accessing the Net Base Cradle Manager 
1. Connect the Ethernet cable to a host workstation on 

the same local area network (LAN) as the Net Base 
to facilitate communication.

2. Ping the Net Base to verify communication between 
the host workstation and the Net Base. 

3. On your host workstation, open the web browser.

4. In the Address line, type the IP address assigned to 
the Net Base well where the Dolphin terminal is 
docked, see Displaying the Net Base Terminal Well 
and Dolphin IP Address on page 12. 
Note: The Net Base acquires a unique IP address for each 

terminal well in which a Dolphin terminal is docked and 
connected. Configuration management is independent 
for each terminal well.

5. Press ENTER.  
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6. A login prompt displays on the host workstation. 
Enter the user name <Admin> and default login 
password <Dolphin>. 
Note: The user name and password are case-sensitive. 

For information on how to change the password, see 
page 17.

7. The Cradle Manager opens for the requested Dolphin 
and terminal well.

Note: Under General Settings, the HTTP Port defaults to 80.
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Changing the Password

You can change the password from the Cradle Manager 
window.

1. Under General Settings, select the check box next 
to, “Change Password”.

2. Enter the new password in the New Password field.

3. Click Apply at the bottom of the screen.

Changing the Dynamic Network Settings

You can modify the Dynamic Network settings from the 
Cradle Manager window.  

1. Under IP Settings, select Dynamic.

2. Enter the new settings in the fields supplied. 
Note: The default reboot time if missing an IP address is 60 

seconds.

3. Click Apply at the bottom of the screen.
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Changing the Static Settings

You can modify the Static Settings from the Cradle 
Manager window.

1. Under IP Settings, select Static.

2. Enter the new settings in the fields supplied. 

3. Click Apply at the bottom of the screen.

Using Telnet for Net Base Configuration 

By default, the Net Base allows use of a web browser for 
configuration management. From the Cradle Manager 
Window, you can modify the Net Base to allow use of a 
Telnet interface instead of a HTTP interface.
Note: For information on how to access the Cradle Manager 

window, see page 15.

Enabling the Telnet Interface

1. Under General Settings, select the option button 
next to Enable Telnet.
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2. Enter the new settings in the fields supplied. By 
default, the Telnet Port is set to 23 and the Telnet 
session timeout is set to 30 seconds.

3. Click Apply at the bottom of the screen.

4. Click OK, when prompted to reboot the EULink 
bridge. The COMM LEDs on the Net Base flash red 
during the reboot process.

Note: A Net Base reboot is required when switching between 
HTTP and Telnet. The reboot process disables the 
HTTP interface and enables the Telnet interface. 

5. After the reboot process is complete, you can 
connect to the Net Base using a standard Telnet 
client. 

Telnet Configuration Command Options

Once a Telnet client connects to the Net Base, you can 
use the following commands to display and modify the Net 
Base configuration settings.

User Mode Commands. 

Command Description

stat Displays the status of the Net Base
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ADMIN Mode Commands

login Logs you into ADMIN Mode where you can 
modify configuration settings or reboot the 
Net Base, see ADMIN Mode Commands 
below.

Note: The default login password is <Dolphin>. 
The password is case sensitive.

help Displays a list of supported USER mode 
commands with a brief description

quit Quits the Telnet session

Command Description and Options

conf Configuration Options

conf h <hostname>
conf ad <dynamic mode>
conf as <static mode>
conf i <iP address>
conf m <subnet mask address>
conf g <Gateway address>
conf d1 <DNS1 address>
conf d2 <DNS2 address>
conf w1 <WINS1 address>
conf w2 <WINS2 address>
conf rt <reboot time>
conf l <location string>

Command Description
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passwd Changes the password

portsel Changes the Net Base interface from 
Telnet to HTTP, or sets the Telnet Port and 
Telnet session timeout settings

Options

portsel hp <http port>
portsel tp <telnet port>
portsel tt <telnet session timeout>

Note: By default the HTTP port is set to 80, the 
Telnet port is set to 23, and the Telnet 
session timeout is set to 30 seconds.

upgrade Upgrades the Net Base Firmware, see 
Using Telnet to Upgrade the Net Base 
Firmware on page 26.

arpstat Displays the ARP Status

routestat Displays the Route Status

ping Ping

reboot Reboots the Net Base

restore Restores the Net Base to the factory 
default configuration

logout Logs you out of ADMIN mode

Command Description and Options
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Disabling Telnet and Enabling HTTP

1. At the command prompt, type <login>, and then 
press Enter.

2. At the password login prompt, type the default login 
password <Dolphin>, and then press Enter. 

3. At the command prompt, type portsel hp <HTT 
Port>, and then press Enter.
Note: The HTTP Port default is 80.

4. The Net Base initiates a reboot sequence for the 
terminal well specified. The reboot sequence 
disables the Telnet interface and enables the HTTP 
interface.
Note: When changing terminal well 

one (1) from Telnet to HTTP, 
the Net Base initiates a 
reboot sequence for all four 
(4) terminal wells.

help Displays a list of supported ADMIN mode 
commands with a brief description of each 
command

quit Quits the Telnet session

Command Description and Options

1
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Restoring the Net Base Factory 
Defaults

To return the Net Base to the factory defaults: 

1. Unplug the power cable on the Net Base.

2. Locate the reset button on the bottom of the Net 
Base. 

3. Push in and hold down the reset button.

4. While holding down the reset button, plug in the 
power cable.

5. Wait 15 seconds, and then release the button. Let the 
Net base finish the rebooting process.

6. Turn power to the Net Base OFF and then ON to 
finish resetting the base.

Note: When the factory defaults are restored, the password 
reverts to the default password, <Dolphin>.

Configuration Data Reset Button
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Upgrading the Net Base Firmware

To upgrade the firmware on the 9700 Net Base, you will 
first need a computer running TFTP server software that 
stores the firmware upgrade file.

Note: The firmware upgrade process 
must be repeated for each of 
the four terminal wells on the 
Net Base.  The recommended 
upgrade sequence is to start 
with terminal well  four (4 ) and 
end with terminal well one (1).  

Using the Cradle Manager to Upgrade the 
Net Base Firmware
1. Verify the Net Base is connected to Ethernet network.

Note: Firmware upgrades for the Net Base do not require a 
Dolphin terminal be installed in the Net Base.

2. Connect the Ethernet cable to a host workstation on 
the same local area network (LAN) as the Net Base 
to facilitate communication.

3. Ping the Net Base to verify communication between 
the host workstation and the Net Base. 

4. On your host workstation, open the web browser.

5. In the Address line, type the IP address assigned to 
the Net Base, see Displaying the Net Base Terminal 
Well and Dolphin IP Address on page 12. 

6. Press ENTER.

1

4
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7. Enter the user name <Admin> and default login 
password <Dolphin>. 
Note: The user name and password are case-sensitive. 

For information on how to change the password, see 
page 17.

8. The Cradle Manager window appears.

9. In the Cradle Manager window, check the box next to 
Firmware upgrade.

10. Enter the IP address of the server in the TFTP 
Server IP Address field. 

11. Under File Name, enter the Net Base firmware 
upgrade file name. 

12. Click Apply. 
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13. Click OK, when prompted to reboot the EULink 
bridge. The COMM LEDs on the Net Base flash red 
during the reboot process.

14. The COMM LEDs flash orange during IP verification 
and the firmware upgrade. 

15. The Net Base automatically reboots. When the Net 
Base successfully auto-connects to the network, the 
COMM LED illuminates green for terminal wells with 
a docked Dolphin or orange for terminal wells without 
a Dolphin. 

Troubleshooting

If the Net Base does not auto-connect and COMM LED 
illuminates solid red after the upgrade process, remove 
and then reinsert the Dolphin terminal in the Net Base. 
The COMM LED illuminates solid green when the Net 
Base connects to the network.

Using Telnet to Upgrade the Net Base 
Firmware 

The following upgrade process requires the Net Base be 
configured to use the Telnet interface, see Using Telnet 
for Net Base Configuration on page 18.

1. At the command prompt, type <login>, and then 
press Enter.
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2. At the password login prompt, type the default login 
password <Dolphin>, and then press Enter. 

3. At the command prompt, type upgrade t <ftp server 
IP address> f <firmware upgrade filename>.

4. Press Enter.

5. The Net Base initiates a reboot sequence for the 
terminal well specified. The COMM LED for the 
terminal well flashes red during the reboot process.
Note: When upgrading the 

firmware for terminal well 
one (1), the Net Base 
initiates a reboot sequence 
for all four (4) terminal wells.

6. The COMM LEDs flash orange during IP verification 
and the firmware upgrade.

7. The Net Base initiates a reboot sequence for the 
terminal well specified (see note above). When the 
Net Base successfully auto-connects to the network, 
the COMM LED illuminates green for terminal wells 
with a docked Dolphin or orange for terminal wells 
without a Dolphin.

Troubleshooting

If the Net Base does not auto-connect and COMM LED 
illuminates solid red after the upgrade process, remove 
and then reinsert the Dolphin terminal in the Net Base. 
The COMM LED illuminates solid green when the Net 
Base connects to the network.

1
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Mounting the Net Base 

Set the Net Base on a dry, stable surface, such as a 
desktop or workbench near an electrical outlet. Be sure to 
provide enough workspace with good lighting for the user 
to view and operate the Dolphin terminal while it is in the 
Net Base.

When choosing a location, bear in mind that the mounting 
location must allow users easy access to the terminal 
wells, the Ethernet ports, and the power jack.

Installation Hardware
Screw: 3/16 in. dia x 5/8 in. long pan head screw
Washer: 1/2 in. OD x 7/32 in. ID x 3/64 in. thick
Nut: 3/16 in. dia

Using the DIN Rail

The DIN rail slot (7.5 X 35 mm) on the bottom panel 
enables secure mounting to a horizontal surface.   

1. Slide the DIN rail into the DIN rail slot along the 
bottom panel of the Net Base. 

2. Then, using the appropriate nuts and bolts, secure 
the DIN rail to the desk or flat surface. 

DIN Rail 
(7.5 X 35 mm)
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Technical Assistance

Contact information for technical support, product service 
and repair can be found at www.honeywellaidc.com.

Limited Warranty

Refer to www.honeywellaidc.com/warranty_information 
for your product’s warranty information.

Disclaimer

Honeywell International Inc. (“HII”) reserves the right to 
make changes in specifications and other information 
contained in this document without prior notice, and the 
reader should in all cases consult HII to determine 
whether any such changes have been made. The 
information in this publication does not represent a 
commitment on the part of HII.

HII shall not be liable for technical or editorial errors or 
omissions contained herein; nor for incidental or 
consequential damages resulting from the furnishing, 
performance, or use of this material.

This document contains proprietary information that is 
protected by copyright. All rights are reserved. No part of 
this document may be photocopied, reproduced, or 
translated into another language without the prior written 
consent of HII.

Web Address: www.honeywellaidc.com

http://www.honeywellaidc.com/warranty_information
http://www.honeywell.com/aidc
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Trademarks

Dolphin is a trademark or registered trademark of Hand 
Held Products, Inc. or Honeywell International Inc.

Microsoft, Windows, Windows Mobile, ActiveSync, 
Windows Explorer, and Windows Mobile Device Center 
are trademarks or registered trademarks of the Microsoft 
Corporation.

Other product names mentioned in this manual may be 
trademarks or registered trademarks of their respective 
companies and are the property of their respective 
owners.

©2010 Honeywell International Inc. All rights reserved.

http://www.honeywellaidc.com
http://www.honeywellaidc.com
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